Navigating Source


Home » Support » Index of All Documentation » Wing IDE Reference Manual » Source Code Editor »

The set of menus at the top of the editor can be used to navigate through your source code. Each menu indicates the scope of the current cursor selection in the file and may be used to navigate within the top-level scope, or within sub-scopes when they exist.

When editor tabs are hidden by clicking on the options drop down in the top right of the editor area, the left-most of these menus lists the currently open files by name.

You can use the Goto Definition menu item in the editor context menu to click on a construct in your source and zoom to its point of definition. Alternatively, place the cursor or selection on a symbol and use the Goto Selected Symbol Defn item in the Source menu, or its keyboard equivalent. Control-Click (and Command-Click on OS X) also jumps to the point of definition.

To visit all points of use of a symbol, right click on it and select Find Points of Use or use the item of the same name in the Source menu. The points of use are shown in the Uses tool. Clicking on items in the list visits that use. Alt-Clicking on a symbol also displays points of use.

When moving around source, the history buttons in the top left of the editor area can be used to move forward and backward through visited files and locations within a file in a manner similar to the forward and back buttons in a web browser.

Other commonly used ways to navigate to files that are open include the Window menu, which lists all open files; the Open Files tool which also supports defining named file sets; the Recent sub-menu in the File menu; Open From Project in the File menu, which finds project files quickly by typing a fragment of the file name; and Open From Keyboard in the File menu, which operates in a temporary input area at the bottom of the IDE window and offers auto-completion of file names as you type.

Find Symbol in the Source menu provides a way to find a symbol defined in the current Python scope by typing a fragment of its name.

See also the Find Uses tool and Source Browser.

« 4.1. Right-click Editor MenuTable of Contents4.3. File status and read-only files »