Improved Zope Support: July 8, 2002


Archaeopteryx Software announced today the second beta release of new and improved support for users of Zope.

This replaces the previous approach of patching Zope and providing special Zope bundles for use with Wing IDE. It allows debugging Zope Products and External Methods on any platform supported by both the Wing IDE debugger and Zope.

Major differences include:

  • No need to patch Zope or wait for Archaeopteryx support for new versions of Zope. Works with your unchanged Zope installation version 2.4.0 or later.
  • Packaged as a Zope Product so debug configuration is from the Zope Management Interface.
  • Debugs only requests on a given http port, which may co-exist with non-debug requests.

The WingDBG product for Zope requires Wing IDE version 1.1.5 or later and cannot be used with a Zope installation that was previously patched for Wing IDE.

For details, please refer to the usage instructions.