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This tutorial introduces Wing Personal by taking you through its feature set with a small coding example.
For a faster introduction, see the Quick Start Guide.

If you are new to programming, you may want to check out the book Python Programming
Fundamentals and accompanying screen casts, which use Wing 101 to teach programming with
Python.

A collection of Wing Tips, available on our website and by weekly email subscription, provides additional
tips and tricks for using Wing productively.

To get started, press the - Next Page icon in the toolbar immediately above this page.


https://wingware.com/doc/howtos/quickstart
https://kentdlee.github.io/CS1
https://kentdlee.github.io/CS1
https://wingware.com/hints

The screenshots in this tutorial were made with Wing Pro and may contain some tools that are not
available in Wing Personal. These can be ignored and will not be discussed in the text that follows.

Tutorial: Why Wing?

Wing Personal is a simple Python IDE designed for students and hobbyists or those using Python
occasionally for fairly simple development tasks. If you have never used Wing before, starting with Wing
Personal is one way to learn the basics of the Wingware Python IDE approach without being distracted
by the larger feature set of Wing Pro.

However, if you are working intensively with Python, you should switch to Wing Pro. You will be much
more productive, and chances are you will have no problem understanding and appreciating Wing Pro's
more advanced features.

Let's get started! To get to the next page in the tutorial, use the Next Page icon in the toolbar
immediately above this page.

Tutorial: Getting Started

To get started using this tutorial, you will need to:
Install Python

If you don't already have it on your system, install Python from python.org. Wing also supports Python
provided by Anaconda ActivePython, MacPorts, Fink, Homebrew, cygwin, and others. See Supported
Python Versions for details.

Install Wing
Then install Wing. For detailed instructions, see Installing Wing.
Start Wing

Wing can be started from a menu, desktop, or tray icon, or by using the command line executable. For
detailed instructions, see Running Wing.

Switch to the Integrated Tutorial

Once Wing is running, you should switch to using the Tutorial listed in Wing's Help menu because it
contains links directly into the IDE's functionality. This includes the next step below.

Copy the Tutorial Directory

Copy the entire tutorial directory out of the Install Directory listed in Wing's About box to another
location on disk. You can do this manually or use the following link, which will prompt you to select the
target directory:

Copy Tutorial Now


https://python.org/download
https://wingware.com/doc/install/supported-python-versions
https://wingware.com/doc/install/supported-python-versions
https://wingware.com/downloads/wing-personal
https://wingware.com/doc/install/installing
https://wingware.com/doc/install/running-the-ide

Note

We welcome feedback, which can be submitted with Submit Feedback in Wing's Help menu or
by emailing support@wingware.com

Tutorial: Getting Around Wing
Let's start with some basics that will help you get around Wing while working with this tutorial.
Wing's user interface is divided into an editor area and two toolboxes separated by draggable dividers.

Try pressing F1 and F2 now to show or hide the two toolboxes. Also try Shift-F2 to maximize the editor
area temporarily, hiding both tool areas and toolbar until Shift-F2 is pressed again.
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< ReadPythonNews ° A £ v X
1#.
v def GetItemCount():
"""This gets the number of items to use in this example"""
return 5

#:
v def ReadPythonNews(count, force=0):
""""Read news from planet.python.org news channel"""

[Open Files|Diff/Merge| Proje

newscache = 'newscache.rdf'

txt = None
v if not force and os.path.exists(newscache):
mtime = os.stat(newscache).st_mtime
4 if time.time() - mtime < 60 % 60 * 24:
f = open(newscache, 'rb')
txt = f.read() {
f.close()

<

Symbol: os.path.exists
~ if txt i< Mnna:

[Testing|Exceptions|Breakpoints|Search|Mercurial Python Shell Debug Probe|OS«< >
Commands execute without debug. Use arrow keys for history. # = Options v

Likely type: callable function exists
def exists(path)
Returns: bool

v

>>> import this
The Zen of Python, by Tim Peters

https://docs.python.org/3/library/
genericpath.html#genericpath.exists

Beautiful is better than ugly.
Explicit is better than implicit.
Simple is better than complex.
Complex is better than complicated.
Flat is better than nested.

Sparse is better than dense.
Readability counts.

% Line 40 Col 29 - [User] (Analyzing Files: P1 S2 Q=95)

Test whether a path exists. v/ PEP287
Returns False for broken
symbolic links

<> Source Assistant Refactoring|Uses|Coc

<

Tool and editor tabs can be dragged to rearrange the user interface, optionally creating a new split or
moving them to a separate window. Right click on the tabs for a menu of additional options, such as
adding or removing splits or to move the toolbox from right to left. The number of splits shown by default
in toolboxes will vary according to the size of your display.


mailto:support@wingware.com

Notice that you can click on an already-active tool tab to minimize that tool area. Click again on any tab
to restore the toolbox to its previous size.

See User Interface Layout for details.
Context Menus

In general, right-clicking provides a menu for interacting with or configuring a part of the user interface.
On some systems you may need to configure your track pad to allow right-clicking, or use a keyboard
modifier to emulate a right mouse click.

Splitting the Editor Area

Splitting your editor area makes it easier to get around this tutorial. To do this now, right-click on the
editor tab area and select Split Side by Side. On small monitors and laptops, it may be preferable to
create a new window for the tutorial by right-clicking on its tab and selecting
Move Wing Help to New Window.

By default, the editor shows all open files in all splits, making it easy to work on different parts of a file
simultaneously. This can be changed by unchecking Show All Files in All Splits in the right-click
context menu on the editor tabs.

Configuring the Keyboard

Use the Edit > Keyboard Personality menu to tell Wing to emulate another editor, such as Visual
Studio, VI/Vim, Emacs, Eclipse, XCode, MATLAB, or Brief.

Wing
Brief
Eclipse
v Emacs
0S X
MATLAB

Visual Studio
XCode

v Enable Auto-Editing
Configure Auto-Editing...

Configure Tab Key...

The Configure Tab Key item in the Edit > Keyboard Personality menu can be used to select among
available behaviors for the Tab key. The default is to match the selected Keyboard Personality.

When the Keyboard Personality is set to Wing, Tab acts differently according to context. For example, if
lines are selected, repeated presses of Tab moves the lines among syntactically valid indent positions.
And, when the caret is at the end of a line, pressing Tab adds one indent level.

See Keyboard Personalities for details.
Accessing Preferences

Preferences for controling how Wing Personal looks and behaves are available from the
Edit > Preferences menu item (or Wing Personal >> Preferences on macOS). Try this nhow so you


https://wingware.com/doc/custom/gui-layout
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will remember how to bring up the preferences dialog as you work through the rest of this tutorial.
However, it's best not to delve into all of the available options right away. The next few sections will
highlight some of the more important ones that are worth looking at now.

Auto-Completion

There are many options for Wing's auto-completer. These are set in the Editor > Auto-completion
preferences group. For example, if you want to use the Enter key for completion, you may wish to select
that now in the Editor > Auto-completion > Completion Keys preference.

Colors and Dark Mode

colors for the user interface can be selected with the User Interface > Display Mode,
User Interface > Light Theme and User Interface > Dark Theme preferences.

The colors used in editor areas and some of the tools, including the Python Shell, can be set
independently with the User Interface > Light Editor and User Interface > Dark Editor preferences.

The following screenshot was created by setting Display Mode to Use Dark Theme and selecting
One Dark for the Dark Display Theme. This display mode will be used in the rest of this tutorial:
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ReadPythonNews » msubdir
v else: ®examplel.py
X = raw_input(msg) @example2.py
® README. txt
@®test_examplel.py
< def GetItemCount():
"""This gets the number of items to use in this example
return 5

Open Files|Diff/Merge|Project

< def ReadPythonNews (count, force=0):
"""Read news from planet.python.org news channel"""

newscache = 'newscache.rdf'

txt = None

if not force and os.path.exists(newscache):
mtime = os.stat(newscache).st_mtime
if time.time() — mtime < 60 * 60 * 24:

= (newscache, 'rb')
+vt — Ff raadl)

Symbol: os.path.exists

Likely type: callable function exists
def exists(path)
Returns: bool

Testing|Exceptions|Breakpoints|Search|Mercurial{Python Shell [Debug Probe|OS

Commands execute without debug. Use arrow keys for history Options

B>= import this
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The Zen of Python, by Tim Peters

genericpath.html#genericpath.exists

Beautiful is better than ugly.
Explicit is better than implicit.
Simple is better than complex.
Complex is better than complicated.
Flat is better than nested.

Sparse is better than dense.
Readability counts.
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Test whether a path exists. PEP287
Returns False for broken
symbolic links
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To set the fonts in the user interface and editor, change the User Interface > Fonts >
Display Font/Size and User Interface > Fonts > Editor Font/Size preferences.

The size and type of tools used in the toolbar at the top of Wing's window can be changed by
right-clicking on one of the enabled tools.

For more information on adjusting the user interface to your needs, see Customization.

Tutorial: Check your Python Integration

Before starting with some code, let's make sure that Wing has succeeded in finding your Python
installation. Bring up the Python Shell tool now from the Tools menu. If all goes well, it should start up
Python and show you the Python command prompt like this:

Testing|Exceptions|Breakpoints|Search|Python Shell [Debug Probe|OS Commands
Commands execute without debug. Use arrow keys for history. & & Options

3.7.0 (v3.7.0:1bf9cc5093, Jun 26 2018, 23:26:24)
[Clang 6.0 (clang-600.0.57)]

Python Type "help", "copyright", "credits" or "license" for more information.
>>>

If this is not working, or the wrong version of Python is being used, you can point Wing in the right
direction with Python Executable in Project Properties, accessed from the Project menu.

An easy way to determine the value to use for Python Executable is to start the Python you wish to use
with Wing and type the following at Python's >>> prompt:

i nport sys
print(sys. execut abl e)

You can also use a virtualenv or Anaconda environment by selecting the Activated Env option here,
but for now let's just use the base Python installation.

You will need to Restart Shell from the Options menu in the Python Shell tool after altering
Python Executable.

Once the shell works, copy/paste or drag and drop these lines of Python code into it:

for i in range(0, 10):
print("*" * i)

This should print a triangle as follows:


https://wingware.com/doc/custom/index

>>> for i in (0, 10):
"k' ok i

*x

kk

skeksk

skekskok
skekskokok
skekskskokok
skekskokokokk
skekskokokokokk
skekskskskokokokok

Notice that the shell removes common leading white space when blocks of code are copied into it. This
is useful when trying out code from source files.

Now type something into the shell, such as:

i nport sys
sys. getrefcount (i)

Note that Wing offers auto-completion as you type and shows call signature and documentation in the
Source Assistant tool. Use the Tab key to enter a selected completion. Other keys can be set up as
completion keys with the Editor > Auto-completion > Completion Keys preference.

You can create as many instances of the Python Shell tool as you wish by right-clicking on a tool tab
and selecting Insert Tool. Each one will run in its own process space.

Tutorial: Set Up a Project

Now we're ready to get started with some coding. The first step is to set up a project file so that Wing
can find and analyze your source code and store your work across sessions.

If you haven't already copied the tutorials directory from your Wing installation, please do so now as
described in Tutorial: Getting Started.

Wing starts up initially with the default project. Instead of using that, create a new project now with
New Project in the Project menu. Select Create Blank Project and then click on OK:

Wing will display a confirmation dialog after creating the new blank project:


https://wingware.com/doc/intro/tutorial-getting-started

Click Save Now to save the new project. Use tutorial.wpr as the project file name and place it in the
tutorial directory that you created earlier.

Next, use the Add Existing Directory item in the Project menu to add your copy of the tutorials
directory. Leave the default options checked so that all files in that directory are added to the project.

O |Project: tutorial Options
'S’ > msubdir
®examplel.py

@ example2.py

® README.txt

@ test_examplel.py

Open Files|Diff/Merge|Proje

Note

To make it easier to work on source code and read this tutorial at the same time, you may want
to right-click on the editor tab area and select Split Side by Side.

Opening Files

Files in your project can be opened by double-clicking in the Project tool, by typing fragments into the
Open From Project dialog, and in other ways that will be described later.

Try Open From Project now, from the File menu. Type ex as the file name fragment and then use the
arrow keys and press Enter to open the file examplel.py. Now try it again with the fragment sub ex.
This matches only files with both sub and ex in their full path names. In larger projects,
Open From Project is usually the easiest way to open a file, so you'll probably want to learn the key
binding listed for this command in the File menu. The binding varies according to which keyboard
personality you have chosen to use.



Enter fragments separated by spaces:
exa Options

examplel.py
example2.py
path_example.py
test_examplel.py

/Users/sdeibel/tutorial/examplel.py

Open Selected\ Cancel

Transient, Sticky, and Locked Files

Wing opens files in one of several modes, in order to keep more relevant files open while auto-closing
others. To see this in action, click on os in import os at the top of examplel.py and press F4 to go to
the definition of os. The file os.py will be opened in non-sticky transient mode, so that it is automatically
closed in least-recently-used order when you navigate away from it to other files.

The mode in which a file is opened is indicated with an icon in the top right of the editor area:
® - The file is sticky and will be kept open until it is closed by the user.

® - The file is non-sticky and may be closed when it is no longer visible. When a non-sticky transient
file is edited, it immediately converts to sticky.

- The file is locked in the editor, so that the editor split will not be used to display other newly opened
files. This mode is only available when multiple editor splits are present.

Clicking on the stick pin icon toggles between the available modes. Right-clicking on the icon displays a
menu of recently visited files. This contains both non-sticky transient and sticky files, while the Recent
list in the File menu contains only sticky files.

' Wing Help

“ management/__init__.py
' views.py

£ urls.py

+ posixpath.py

Configure...

The number of non-sticky transient editors to keep open, in addition to those that are visible, is set with
the Editor > Advanced > Maximum Non-Sticky Editors preference (default=5).

This mechanism is also used in multi-file searching, debugging, and other features that navigate
through many files. In general you can ignore the modes and Wing will keep open the files you are
actually working on, while auto-closing those that you have only visited briefly.



Tutorial: Setting Python Path

Python uses a search path referred to as the Python Path to find modules that are imported into code
with the import statement. Most code only imports modules that are already on the default path, for
example modules in the Python standard library, or modules installed into Python by pip, poetry,
pipenv, conda, or some other package manager.

However, in some cases code will depend on a different path provided either by setting the environment
variable PYTHONPATH before starting Python, or by modifying sys.path at runtime before importing
modules.

If the Python Path is changed by one of these methods, you may also need to tell Wing about this
change. This is done with Python Path in Project Properties, accessed from the Project menu:

[ XoX ) Project Properties: tutorial.wpr
Environment|Debug/Execute|Options|Extensions|Testing|VCS
Python Executable Use default © Custom O Remote

Python Path Use default ©® Custom
a /Users/sdeibel/tutorial /subdir

Insert View as Text

Environment Use inherited environment

Analyze main entry point for sys.path changes

\ v OK ‘ Cancel

For this tutorial, you need to add the subdir sub-directory of your tutorials directory to Python Path, as
shown above. This directory contains a module used as part of the first coding example.

Note that the full path to the directory subdir is used. This is strongly recommended because it avoids
potential problems finding source code during debugging, if the starting directory is ambiguous or
changes over time. If relative paths are needed to make a project work on different machines, use an
environment variable like ${WING:PROJECT_DIR}/subdir. This is described in more detail in
Environment Variable Expansion.

The configuration used here is for illustrative purposes only. You could run the example code without
altering the Python Path by moving the path_example.py file to the same location as the example
scripts.

Startup Environment

Wing uses its startup environment as the default environment for your Python code. As a result, if
PYTHONPATH is set when you start Wing, it will also be used with your code. If this inherited path
matches the needs of your code, then you don't need to set Python Path in Wing. However, if you have


https://wingware.com/doc/proj/variable-expansion

different Python environments on your system or code with different path expectations, then you should
set Python Path in the project so that switching projects will also switch to the correct environment.

Virtualenv and Anaconda Environments

If you are using virtualenv, Anaconda environments, Poetry, or pipenv to set up your Python
environment, you don't need to set Python Path. Instead, set Python Executable to Activated Env
and enter the command that activates your environment. This causes Wing to pick up the correct path
and other environment needed to run code in the environment. In this case, Python is launched by
running python in that environment.

You can also create a new virtualenv or Anaconda environment at the same time as creating a Wing
project by selecting the Create New Virtualenv or Create New Anaconda Environment project types
in the New Project dialog, accessed from the Project menu.

But don't do this now; you'll need the current project as you work through this tutorial.
Python Path Analysis

If your main entry point alters sys.path, and the file is set as the Main Entry Point in
Project Properties then Wing may be able to automatically determine the correct path to use.

When in doubt, compare the value of sys.path at runtime in your code with the value reported by
Show Python Environment in the Source menu. If they match then there is no need to set
Python Path in your project.

Tutorial: Introduction to the Editor

Now that you have set up your project, Wing will have found and analyzed the tutorial examples, and all
the modules that are imported and used by them. This analysis process runs in the background and is
used to provide auto-completion, call tips, goto-definition, code warnings, and other editing and
navigation features. With larger code bases, you may notice the CPU load from this process, and Wing
will indicate that processing is active by displaying Analyzing Files in the status area at the bottom left
of the main IDE window:

& Line 12 Col 16 - [Edit] (Analyzing Files: P2 S1 Q=2)

However, with this tutorial analysis will have happened instantaneously after the project was configured.
Editing with Wing

Let's start by trying out a subset of Wing's editor features, focusing on the auto-completer and
Source Assistant.

Open the file examplel.py from the Project tool. Then bring up the Source Assistant from the Tools
menu or by clicking on its tab. This is where Wing shows documentation, call signature, and other
information as you move around in your source code or work with other tools.



Scroll down to the bottom of examplel.py and enter the following code by typing (not pasting) it into the
file:

news = Rea

Wing displays a context-sensitive auto-completer as you type. You can scroll around in the list with the
arrow keys, type Esc or Ctrl-G to abort completion, or Tab to enter the currently selected completion.

If you are used to using the Enter key for auto-completion, add it to the Editor >
Auto-Completion > Completion Keys preference now.

When you first typed "news" this completer wasn't helpful because you had not yet defined news as a
symbol in your source. However, once you move on to type = Re, Wing displays another completion list
with ReadPythonNews highlighted. Notice that the Source Assistant updates to show call information
for that function, or for whatever symbol is selected in the auto-completer:

ene® tutorialwpr: Wing
RWE@ B I x 3 Q¥ Ay
examplel.py *|example2.py/Help

< PrintAsHTML

Completion:

ReadPythonNews

< def PrintAsText(news): . .
“"Print Python news in plain text format""" Likely type: callable function

ReadPythonNews

def ReadPythonNews(count,

force=0)

Returns: list

v for date, event, url in news:
("%s — %s (%s)" % (date, event, url))

v def PrintAsHTML(news):

"""Print Python news in simple HTML format""" Read news from EER257

planet.python.org
< for date, event, url in news: news channel

('<p><i>%s</i> <a href="%s">%s</a></p>' % (data, url, event))

news = Rea|

o PrintAsText

@ PromptToContinue
=e property
=0 quit
@@ range

@ ReadPythonNews
@0 repr

@ request
=6 ResourceWarning
=0 reversed <

Indentation|Source Assistant|Refactoring Uses|Code Warnings Search in Files|Stack

‘
Testing|Exceptions|Breakpoints|Search|Python Shell Debug Probe|0S Commands
& Line 87 Col 10 * [User]

Next, press the Tab key to enter the completion of ReadPythonNews and enter (. You should now
have the following code in the editor:

news = ReadPyt honNews(

If you are used to using the Enter key for auto-completion, add it to the Editor >
Auto-completion > Completion Keys preference now.



Then type Get to start entering arguments for your invocation of ReadPythonNews. You will see the
Source Assistant alter its display to highlight the first argument in the call signature for
ReadPythonNews and add information on the argument's completion value:

tutorial.wpr: Wing
Rw®@® I ‘x = Tl mQ Ay
examplel.py *|lexample2.py|Help S
<« PrintAsHTML

Invoking: ReadPythonNews

Likely type: callable function
ReadPythonNews

def ReadPythonNews(count,
force=0)

Returns: list

v def PrintAsText(news):
"""Print Python news in plain text format"""

~ for date, event, url in news:
("%s —— %s (%s)" % (date, event, url))

v def PrintAsHTML(news): Completion: GetltemCount

Print Python news in simple HTML format Likely type: callable function

GetltemCount
def GetltemCount()
Returns: int

~ for date, event, url in news:
('<p><i>%s</i> <a href="%s">%s</a></p>' % (data, url, event))

This gets the number [VJBER281
of items to use in this
example

news = ReadPythonNews(Get
=6 format
@ from(snippet)
=e frozenset
8 gen(snippet)
@0 getattr
o GetItemCount
=6 globals
=6 hasattr
=6 hash
=6 help 5

Indentation|Source Assistant|Refactoring Uses|Code Warnings|Search in Files|Stack

<

Testing|Exceptions|Breakpoints|Search|Python Shell Debug Probe|OS Commands
& Line 87 Col 25 * [User]

The docstring for ReadPythonNews is temporarily hidden to conserve screen space. This behavior can
be toggled with the Show docstring during completion option in the Source Assistant's right-click
context menu.

Now continue entering the rest of the line so you have the following complete line of source code:

news = ReadPyt honNews( Cet |t entCount ())

To play around with the editor a bit more, enter the following additional lines of code:

Pri nt AsText (news)
Pr onpt ToCont i nue()
Pri nt ASHTM.( news)

At this point you have a complete program that can be run in the debugger. Don't try it yet, however. It
contains some deliberate bugs and first we should take a look at some of Wing's code navigation
features.



Tutorial: Navigating Code

As already noted, the Source Assistant updates as you move your insertion caret around the editor, or
when browsing through the auto-completer. This includes links to the point of definition of symbols. For
example, try moving between the invocation of PrintAsText and the variable news in the code you just
typed. The blue links in the Source Assistant can be used to jump to the points of definition of each
symbol listed there.

After visiting the point of definition with one of these links, use the green back arrow at the top left of the
editor to return from the value or type definition:

The link after Symbol: goes to the point of definition of that variable, while any links after Type: or
Likely Type: go to the point of definition of that data type. These are the same if the symbol is a
function, method, or class, but they differ for variables and attributes. For example, for news the point of
definition is the line where news is first assigned a value and the type is a Python list.

Python Documentation

For built-ins and code in the Python standard library, Wing tries to add links into the Python
documentation. For example, type open in the editor and try out the https://docs.python.org link. The
documentation will be opened in your default web browser.

Symbol: open

Likely type: builtin function open

def open(file: Union[str,bytes,int, PathLike], mode: str=...,
buffering: int=..., encoding: Optional[str]=..., errors:
Optional[str]=..., newline: Optional[str]=..., closefd: bool=...)
Returns: 10[Any]

https://docs.python.org/3/library/functions.html#open

Open file and return a stream. Raise |IOError upon PEP287
failure.

Now use Undo or the Delete key to remove open from your code.
Goto-Definition

A quicker way to visit the point of definition of a symbol is to click on it and press F4 or right-click and
use one of the Goto Definition context menu items. Again, you can use the history back/forward arrows
at the top left of the editor to return from the point of definition.

Try this for ParseRDFNews in examplel.py. Wing will open up the file path_example.py and show the
point of definition of ParseRDFNews.

Source Index



Wing maintains a set of source index menus at the top of the editor area. The menus are updated as
you move around code, and additional levels of menus are added as needed, based on context.

< MyClass OneMethod - nested_function ho£ v

Try these now to navigate to CHandler in path_example.py, and then use the second menu to
navigate to endElement.

Then use the history back arrow at top left of the editor area to return to the invocation of
ParseRDFNews in examplel.py. You will need to press the arrow several times to move back through
your visit history.

Find Symbol

If you are looking for a symbol defined in the current scope, use Find Symbol in the Source menu. This
displays a dialog where you can type a fragment matching the symbol name. Use the arrow keys to
traverse the matches and press Enter to visit the symbol's point of definition.

®0e Find Symbol

Options

date

event

news

url

def GetltemCount()

kCannedData

news

os

ParseRDFNews

def PrintAsHTML(news)

def PrintAsText(news)

def PromptToContinue(msg="Press Enter to Continue: ")
def ReadPythonNews(count,force=0)
request

PrintAsText|0|.date

\goto Definition| Cancel

There are many other editor features worth learning, but we'll get back to those later in this tutorial, after
we try out the debugger.

Tutorial: Debugging

The examplel.py program you have just created connects to python.org via HTTP, reads and parses
the Python-related news feed in RDF format, and then prints the most recent five items as text and
HTML. Don't worry if you are working offline. The script has canned data it will use when it cannot
connect to python.org.

To start debugging, set a breakpoint on the line that reads return 5 in the GetltemCount function. This
can be done by clicking on the line and selecting the < Break toolbar item, or by clicking on the
left-most margin to the left of the line. The breakpoint should appear as a filled red circle:



< def GetItemCount():

"""This gets the number of items to use in this example
return 5

Next start the debugger with Debug in the toolbar or the Start/Continue item in the Debug menu.
Wing will show the Debug Properties dialog with the properties that will be used during the debug run.
Just ignore this for now, uncheck the Show this dialog before each run checkbox at the bottom, and
press OK.

Wing will run to the breakpoint and stop, placing a red indicator on the line. Notice that the toolbar
changes to include additional debug tools, as shown below:

B » = ¢ 21 ¥ P P OE =

Break Debug Stop Restart Debug To Cursor Step Into  Step Over  Step Out Up Stack  Show Position

Your display may vary depending on the size of your screen, or if you have altered the toolbar's
configuration. Wing displays tooltips explaining what the items do when you hover the mouse over
them.

Now you can inspect the program state at that point with the Stack Data tool and by going up and down
the stack with + Up Stack and Down Stack in the toolbar or from the Debug menu. The stack can
also be viewed as a list using the Call Stack tool:

example.py: tutorial.wpr: Wing

alaie
Rwie
examplel.pylexample2.py|Help
< GetltemCount

< def PromptToContinue(msg="Press Enter to Continue: "):
"""Prompt to continue and wait for the user to press Enter
v if sys.hexversion >= 0x03000000:
= (msg)
v else:
X = raw_input(msg)

< def GetItemCount():
"""This gets the number of items to use in this example
return 5

~ def ReadPythonNews (count, force=0):
"""Read news from planet.python.org news channel"""

Testing|Exceptions|Breakpoints|Search|Stack Data Python Shell|Debug Probe|OS Commands
examplel.py (pid 17310) (paused) - *GetltemCount(): examplel.py, line 31 Options
Value
<locals dict; len=0>
<globals dict; len=19>
» kCannedData [[June 13, 2013 11:43 AM', 'EuroPython 2014/2015 Conference Team Call fo

stant/Refactoring|Uses|Code Warnings|Search in Files |Open Files Diff/Merge Project

* Line 31 Col 0 - [User]

Notice that the debug status indicator in the lower left of Wing's main window changes color depending
on the state of the debug process. Hover the mouse over the indicator to see detailed status in a tooltip.



Next, try stepping out to the enclosing call to ReadPythonNews. In this particular context, you can
achieve this in a single click with the Step Out in the toolbar or Debug menu. Two clicks on
Step Over also work. ReadPythonNews is a good function to step through in order to try out the basic
debugger features described above.

Try stepping or running to a breakpoint on the last line of this function, which reads
return news[:count]. In this context, right-clicking on news under locals in Stack Data allows viewing
the value in textual form or as an array. The latter loads data incrementally for only the visible portion of
the value, which is useful with numpy arrays, pandas DataFrames, sqlite query results, and other
larger data sets.

Data can also be viewed in tooltips on the editor by hovering the mouse over a value. Try this with
count to see the value 5.

Finally, try Step Over to reach the return event in ReadPythonNews, which is indicated by a
change from the solid debug line marker to an underline. Notice that hovering the mouse over return in
the editor displays the value that is being returned from the function. Similarly, <return value> is added
to the locals shown in the Stack Data tool.

9.1. Tutorial: Debug I/0

Before continuing any further in the debugger, bring up the Debug I/O tool so you can watch the
subsequent output from the program. This is also where keyboard input takes place in debug code that
requests it.

Once you step over the line PrintAsText(news) you should see output similar to the following:

Debug I/0[Testing|Exceptions|Breakpoints|Search|Stack Data|Python Shell|Debug Probe|OS Commands

examplel.py (pid 17310) (running,~ Debug I/O (stdin, stdout, stderr) appears below Options

Tue, 22 Jan 2019 Codementor: AI introduction in healthcare (https://www.codementor
Tue, 22 Jan 2019 codingdirectional: Create an animated image feature for the videc
Tue, 22 Jan 2019 Python Software Foundation: Python Software Foundation Fellow Men
Tue, 22 Jan 2019 Vasudev Ram: Factorial one-liner using reduce and mul for Python
Tue, 22 Jan 2019 — Codementor: How to Install Anaconda on ECS (https://www.codementc
Press Enter to Continue:

For code that reads from stdin or uses input() or Python 2.x's raw_input(), the Debug I/O tool is where
you would type input to your program. Try this now by stepping over the PromptToContinue call with

Step Over in the toolbar. You will see the prompt "Press Enter to Continue" appear in the Debug 1/0
tool and the debugger will not complete the Step Over operation until you press Enter while keyboard
focus is in the Debug I/0 tool.

You can also configure Wing to use an external console from the Options menu in the Debug /O tool.
This is useful for programs that requires a more complete console implementation to run correctly, for
example those that use the curses module.

See Debug Process 1/O for details.


https://wingware.com/doc/debug/debug-process-i-o

9.2. Tutorial: Debug Process Exception Reporting

Wing's debugger reports any exceptions that would be printed when running the code outside of the
debugger.

Try this out by continuing execution of the debug process with the Debug toolbar icon or
Start / Continue in the Debug menu. Wing will stop on an incorrect line of code in PrintAsHTML and
report the problem in the Exceptions tool:

example.py: tutorialwpr: Wing

[ K )

Rw@E I ‘x
examplel.pylexample2.py|Help
< PrintAsHTML

< for date, event, url in
"%s — %s (%s)" % (date, event, url))

~ def PrintAsHTML(news):
"""print Python news in simple HTML format"""

~ for date, event, url iIn news:

int('<p><i>%s</i> <a href="%s">%s</a></p>' % (data, url, event))

news = ReadPythonNews(GetItemCount())
PrintAsText (news)

PromptToContinue()

PrintAsHTML (news)

Debug 1/0|Testing|Exceptions |Breakpoints|Search|Stack Data|Python Shell|Debug Probe|OS Commands
examplel.py (pid 17310) (exception) Ignore this exception location Options

* File "/Users/sdeibel /tutorial/examplel.py", line 90, in <module>
PrintAsHTML(news)

* File "/Users/sdeibel /tutorial/examplel.py", line 81, in PrintAsHTML
print(‘'<p><i>%s</i> <a href="%s">%s</a></p>"% (data, url, event))

builtins.NameError: name 'data’ is not defined

Source Assistant|/Refactoring|Uses|Code Warnings [Search in Files/Open Files|Project

% Line 81 Col 0 - [User]
The Exceptions tool highlights the current stack frame as you move up and down the stack. You can
click on frames to navigate the exception backtrace, showing the source code for each frame.

Whenever you are stopped on an exception, the debugger status indicator in the lower left of Wing's
main window turns red.

After reaching an exception in the debugger, you can correct your code, stop the debugger with the =
Stop icon in the toolbar, and then start debugging again.
Exception Handling Options

In Wing Pro and Wing Personal, the debugger provides several exception handling modes, which differ
in how they determine when exceptions should be reported. It is also possible to ignore specific
exceptions and to specify exception types to always report or never report. Most users will not need to
alter these options, but being aware of them is useful.

See Managing Exceptions for details.


https://wingware.com/doc/debug/managing-exceptions

9.3. Tutorial: Execution Environment

In this tutorial we've been running code in the default environment and with the default Python
interpreter. In a real project you may want to specify one or more of the following:

« Python interpreter and version
* PYTHONPATH

» Environment variables

« Initial run directory

* Options sent to Python

* Command line arguments

Wing lets you set these for your project as a whole and for specific files.
Project Properties

The Environment and Debug/Execute tabs in the Project Properties dialog, accessed from the
Project menu, can be used to select the Python interpreter that is being used, the effective
PYTHONPATH, the values of environment variables, the initial directory for the debug process, and any
options passed to Python itself.

In most cases, Project Properties is where you will make changes to the runtime environment for all
the project code that you execute and debug.

Try this out now by adding an environment variable TESTPROJECT=1 to Environment in
Project Properties. Then restart the Python Shell from its Options menu and type os.environ to
confirm that the new environment variable is defined. The same environment will be defined in any
debug processes that you start from the IDE.

File Properties and Launch Configurations

File Properties are used to configure the command line arguments sent to a file when it is executed or
debugged, and optionally to override the project-defined environment on a file by file basis.

The File Properties dialog is accessed from the Current File Properties item in the Source menu or
by right-clicking on a file in the editor or Project tool and selecting Properties.

File Properties: examplel.py

00
File Attributes|Editor|Debug/Execute [Testing

Environment Use Project Settings and the Following Run Args: - @

Show this dialog before each run



The most common use of File Properties is simply to set the command line arguments to use with the
file. Try this now by bringing up File Properties for examplel.py and set the run arguments in the
Debug/Execute tab to test args.

Now if you restart debugging, os.environ will contain the environment variable TESTPROJECT and
sys.argv will end in test args.

To also override the project-defined environment for a particular file, define a Launch Configuration
and select it in File Properties. This sets up an environment like that which can be specified in
Project Properties and pairs it with a particular set of command line arguments. A launch configuration
can be reused with multiple files or in Named Entry Points (see below).

Try this now by bringing up File Properties for examplel.py again and selecting
Use Selected Launch Configuration for Environment under the Debug/Execute tab. Press the New
button that appears, use”"My Launch Config™ as the name for the new launch configuration, and press
OK. Wing will show the properties dialog for the new launch configuration.

Next enter run arguments other args and change the Environment to Add to Project Values and
enter TESTFILE=2 and TESTPROJECT=. This adds environment variable TESTFILE and removes the
TESTPROJECT from the inherited project-defined environment.

Now restart debugging again and os.environ will contain the environment variable TESTFILE but not
TESTPROJECT and sys.argv will end in other args.

See File Properties and Launch Configurations for details.
Main Entry Point

You can specify one file in your project as the main entry point for debugging and execution. When this
is set, debugging will always start there unless you use Debug Current File in the Debug menu.

To set a main entry point use Set Current as Main Entry Point in the Debug menu, right click on the
Project tool and select Set as Main Entry Point, or use the Main Entry Point property under the
Debug tab of the Project Properties dialog.

Try this now by setting examplel.py as the main entry point. After doing so, it is no longer necessary to
bring examplel.py to front in order to start debugging it.

Whether or not you set a main entry point depends on the nature of your project.
See Specifying Main Entry Points for details.
Named Entry Points

In some projects it is more convenient to define multiple entry points for executing and debugging code.
To accomplish this, Named Entry Points can be set up from the Debug menu. Each named entry point
binds an environment, either specified in the project or in a launch configuration, to a particular file.
Once defined, they can be assigned a key binding or accessed from the Debug Named Entry Point
and Execute Named Entry Point items in the Debug menu.

Named Entry Points are a good way to launch a single file with different arguments or environment.


https://wingware.com/doc/proj/file-properties
https://wingware.com/doc/proj/launch-configs
https://wingware.com/doc/debug/main-entry-point

See Named Entry Points for details.

9.4. Tutorial: Debugging from the Python Shell

In addition to launching code to debug from Wing's menu bar and Debug menu, it is also possible to
debug code that is entered into the Python Shell.

Enable this now by clicking on the bug icon in the top right of the Python Shell. Once this is done, the
status message at the top of the Python Shell should change to include
Commands will be debugged and an extra margin is shown in which you can set breakpoints. Wing
will reach those breakpoints, as well as any breakpoints in editors for code that is invoked. Any
exceptions will be reported in the debugger.

Let's try this out. First stop any running debug process with the B Stop icon in the toolbar. Then paste
the following into the Python Shell and press Enter so that you are returned to the >>> prompt:

def test_function():
x = 10
print(x)
X += 5
y = 20
print (x+y)

Next place a breakpoint on the line that reads print(x) by clicking in the breakpoint margin to the left of
the prompt on that line.

Then type this into the Python Shell and press Enter:

test function()

Wing should reach the breakpoint on print(x).

You can now work with the debugger in the same way that you would if you had launched code from the
toolbar or Debug menu. Try stepping and viewing the values of x and y as they change, either in the
Stack Data tool or by hovering the mouse over the variable names.

Take a look at the stack in the Call Stack or Stack Data tool to see how stack frames that occur within
the Python Shell are listed. You can move up and down the stack just as you would if your stack
frames were in an editor.

Notice that if you step off the end of the call, you will return to the shell prompt. If you press the ® Stop
item in the toolbar or select Stop Debugging from the Debug menu, Wing will complete execution of
the code without debug and return you to the >>> prompt. Note that the code is still executed to
completion in this case becaused there is no way to simply abandon a number of stack frames in the
Python interpreter.

See Debugging Code in the Python Shell for details.
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9.5. Tutorial: Debugging Code Not Launched by the IDE

So far we've been debugging code launched from inside of Wing. Wing can also debug processes that
are running within a web framework, as scripts in a larger application, or that get launched from the
command line. These are cases where a debug process cannot be launched from the IDE, so another
method is needed to initiate debug.

Let's try this now with example2.py in your tutorial directory. First, copy wingdbstub.py out of the
Install Directory listed in Wing's About box. Place wingdbstub.py in the same directory as
example2.py. Next, click on the bug icon in the lower left of Wing's main window and select
Accept Debug Connections. Then set a breakpoint on lines 10 and 22 of example2.py:

example2.py: tutorial.wpr: Wing

[ JoX )

RAwi@ il
examplel.py|example2.py Help
|

import os

("Starting up...")
("This code runs outside of the debugger")
x = "test value"

("Now starting the debugger and attaching to the IDE")
import wingdbstub

~ if 'WINGDB_ACTIVE' in os.environ:
("Success starting debug")

Search in Files|Open Files|Project

v else:
t("Failed to start debug... continuing without debug")

(x)

(“Done")
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Debug I/O|Testing|Exceptions|Breakpoints|Search|Stack Data |Python Shell|Debug Probe|OS Commal
& Line 14 Col 0 - [User]

If you are working on macQOS, or used the Windows zip or Linux tar installers for Wing, you will need to
edit wingdbstub.py in order to set WINGHOME to the full path to the Install Directory you copied it
from. This is done automatically by the other installers. If you are using one of those you can skip this
step.

Now we're ready to debug example2.py when it is launched from outside of the IDE. To launch it, use
the DOS Command prompt on Windows, a bash or similar command prompt on Linux, or Terminal or an
xterm on macOS to type:

pyt hon exanpl e2. py

You may need to specify the full path to python if it is not on your path.



This should start up the code, print some messages, connect to the IDE, and stop on the breakpoint on
line 22. Notice that the breakpoint on line 10 was not reached because debugging had not yet been
initiated at that point. Read through the code and the messages printed to better understand what is
happening. You can verify that the debugger attached by looking at the color of the bug icon in the lower
left of the IDE window, and by hovering the mouse over it:

¥ Line 22 Col 0 - [User]

Once you are stopped at a breakpoint or exception in externally launched code, the debugger works just
as it would had you launched the debug process from the IDE. The only difference is that the
environment is set up by the process itself and the settings specified in Project Properties and
File Properties are not used.

When you continue the debugger from the toolbar or Debug menu, the program should print the value
of x and exit.

This is a very simple example to illustrate how externally launched code can be debugged. The import
of wingdbstub can also be placed in functions or methods, and there is a debugging API that provides
control over starting and stopping debugging.

See Debugging Externally Launched Code for details.
Remote Debugging

Using the same mechanism, but with some additional configuration, it is also possible to debug Python
code launched on another machine. This is documented in Manually Configured Remote Debugging in
the Wing manual. If you need to do this, you may also want to consider using Wing Pro, which has
expanded and easier-to-use support for remote development.

Tutorial: Indentation Features

Since indentation is syntactically significant in Python, Wing provides a number of features to make
working with indentation easier.

Auto-Indentation

By now you will have noticed that Wing auto-indents lines as you type, according to context. This can be
disabled with the Editor > Indentation > Auto-Indent preference.

Wing also adjusts the indentation of blocks of code that are pasted into the editor. If the indentation
change is not what you wanted, a single Undo removes the indentation adjustment, if there was one.

See Auto-indent for details.
Block Indentation

One or more selected lines can be increased or reduced in indentation, or adjusted to match indentation
according to context, from the Indentation toolbar group:


https://wingware.com/doc/debug/debugger-api
https://wingware.com/doc/debug/debugging-externally-launched-code
https://wingware.com/doc/debug/manual-remote-debugging
https://wingware.com/doc/edit/auto-indent

Repeated presses of the Match Indent tool will move the selected lines among the possible
syntactically correct indent levels for that context. The default action of the Tab key does the same
thing.

These indentation features are also available in the Source menu, where their key bindings are listed.
Converting Indentation Styles

In Wing Pro and Wing Personal, the Indentation tool can be used to analyze and convert the style of
indentation found in source files.

See Indentation Tool for details.
Folding

Unless the feature is disabled with the Editor > Folding > Enable Folding preference, Wing Pro and
Wing Personal can fold editor code by indentation levels to hide areas that are not currently of interest,
or as a way to see a quick summary of the contents of a source file.

The folding operations are enumerated in the Folding sub-menu of the Source menu and in the fold
margin's right-click context menu.

Folding acts in such a way that selecting across a fold and copying will copy the text, including its
hidden portions.

See Folding for details.
Other Features

Wing Pro and Wing Personal can also show indentation guides on the editor and set preferred
indentation style and policies, among other things. See Indent Guides, Policies, and Warnings for
details.

Tutorial: Other Editor Features

There are a number of other editor features that are worth knowing about:
Goto-Line

You can navigate quickly to a numbered source line with Goto Line in the Edit menu, or with the key
binding displayed there. Type the line number and then press Enter to complete the action.

In Wing Pro and Wing Personal, line humbers can be shown in the editor with the Show Line Numbers
item in the Edit menu.

Multiple Selections

In Wing Pro and Wing Personal, multiple selections can be made on the editor with the
Edit > Multiple Selections menu items and '/ Multiple Selections in the toolbar.
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This provides a quick way to select several identical occurrences of text either sequentially, or within a
particular file, class, function, or block:

has_location = True
for instance in instance_seq:
val = name_map.get(instance)
if val is not None and val[@] == name and instance.fCo
like_instances.append(instance)
if not (instance, '_GetLocation'):
has_location = Ealco

5 Selections i
for 1

ap.get( )

me and . fConta

append ( )

. (
seen_prefixes = sets.5et()

if has_locatic
prefix_chanc
prefix_name

success = Ti 1 (B

Once there are multiple selections, edits made will be applied to all the selections concurrently.

Multiple selections may also be made by pressing Ctrl+Alt (or Command+Option on the Mac) while
making a selection with the mouse.

Selection Mode and Structural Code Selection

Wing supports character, line, and block mode selection from Selection Mode in the Edit menu, and
the key bindings shown there.

In Python code, the Select sub-menu in the Edit menu can be used to easily select and traverse logical
blocks of code. The Select More and Select Less operations are particularly useful when preparing to
type over or copy/paste ranges of text.

Try these out now on urllib in ReadPythonNews in examplel.py. Each repeated press of Ctrl-Up will
select more code in logical units. Press Ctrl-Down to select less code.

The other operations in the Select sub-menu can be used for selecting and moving forward or
backward over whole statements, blocks, or scopes.

See Selecting Text for details.
Code Warnings

As you probably noticed while working through the tutorial, Wing flags some types of incorrect code by
underlining it. This is done for syntax errors, indentation errors, code that can't be reached, and other
types of errors. Hovering the mouse cursor over an indicator on the editor displays details for that
warning or error in a tooltip.

Note that Wing Pro implements a much richer code warnings capability that supports more error types
and can display warnings fromg external checkers like ruff, flake8, mypy, pep8, and pylint.

Line Editing

In Wing Pro and Wing Personal, lines can quickly be inserted, deleted, duplicated, swapped, or moved
up or down with the operations in the Line Editing sub-menu of the Source menu.
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If your keyboard personality does not support them, then you can add your own key bindings with the
User Interface > Keyboard > Custom Key Bindings preference. The command names are:
new-line-before, new-line-after, duplicate-line-above, duplicate-line, move-line-up,
move-line-down, delete-line, and swap-lines.

Block Commenting

Lines of code can be commented out or un-commented quickly from the Source menu . In Python code,
the Editor > Block Commenting Style preference controls the type of commenting that is used. The
default is to use indented single # characters since this works better with some of Wing's other features.

Brace Matching

Wing highlights brace matches as you type, unless this is disabled from the Editor >
Brace Matching > Brace Highlighting preference. The Match Braces item in the Source menu
causes Wing to select all the code that is contained in the nearest matching braces, as found from the
current insertion point on the editor. Repeated invocations of the command will traverse outward or
forward in the file.

Text Reformatting

Code can be re-wrapped to the column configured in the preference Editor > Line Wrapping
> Reformatting Wrap Column with the Rewrap Text item in the Source menu. This will limit wrapping
to a single logical line of code, so it can be used to reformat function or method arguments or long list or
tuple without altering surrounding code.

Tutorial: Searching

Wing Personal provides several different interfaces for searching your code. Which you use depends on
what you want to search and how you prefer to interact with the search and replace functionality.

12.1. Tutorial: Toolbar Search

A quick way to search through the current editor or documentation page is to enter your search string
into the search area provided by the toolbar:

If you enter only lower case letters, then the search will be case-insensitive. Entering one or more
upper-case letters causes the search to become case-sensitive.

Try this now in examplel.py: Type Getltem into the toolbar search area. Wing will search
incrementally, starting when the first letter is typed. Press the Enter key to move on to the next match,
wrapping around to the top of the file if necessary.

Toolbar-based searches always go forward in the file from the current editor caret position.

See Toolbar Quick Search for details.


https://wingware.com/doc/edit/toolbar-quick-search

12.2. Tutorial: Keyboard-Driven Search and Replace

If you prefer a more powerful search interface using the keyboard only, try the key bindings listed in the
Mini-search sub-menu of the Edit menu. The bindings vary according to the currently selected
Keyboard Personality.

Mini-search supports searching forward and backward in the current editor, documentation,
Python Shell, Debug Console (Wing Pro only), or Debug 1/O tool, optionally using the current
selection in the editor as the search string, or using regular expression matching. You can also initiate
replace operations.

Try this in the examplel.py file: If you are using the default keyboard personality, press Ctrl-U. For
other keyboard personalities, refer to Mini-search in the Edit menu.

This will display an entry area at the bottom of the IDE window and will place focus there:

@ Line 90 Cols 24-27 * [User] Search: |Get

Continue by typing G, then e, then t. Notice how Wing searches incrementally with each key press.
Search Behavior

As in toolbar search, typing only lower case letters results in case-insensitive search, while using one or
more upper case letters results in case-sensitive search.

While the mini-search area is still active, try pressing the same key combination you used to display it
again. Wing will search for the next matching occurrence.

If no match is found Failed Search will be displayed. After this, pressing the mini-search key
combination again will wrap around and start searching at the top of the file, if there are any matches.

To start searching again using the most recently used search string, press the key combination for
search twice, once to display the search entry area, and once again to recall the previous search string.

Search direction can be changed during a search session, by switching to the key bindings assigned to
the desired direction.

You can exit from the search by pressing the Esc key or Ctrl-G, or with arrow keys and other editor
commands.

Regular Expression Search

The regular expression search options found in Mini-search in the Edit menu work similarly but expect
regular expressions for the search criteria.

Replace

Keyboard-driven mini-replace works similarly, except that you will be presented with two entry areas,
one for your search string and one for the replace string.

Two replace operations are available. Both of these operate only on text that follows the caret in the file
and do not wrap:
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Query/Replace prompts for Y and N for each replace location
Replace String replaces all following matches in the file without prompting.

See Keyboard-Driven Search and Replace for details.

12.3. Tutorial: Search Tool

The Search tool provides simple search and replace operations on the current editor or documentation
page. Key bindings for operations on this tool are given in the Search and Replace group in the Edit
menu.

Testing | Stack Data| Search [Python Shell| Debug Probe |OS Commands
Search: | Getltem

Case sensitive Whole words In Selection

4 Previous & Next Search Successful Options

Searches may span the whole file or be constrained to the current selection, can be case sensitive or
insensitive, and may optionally be constrained to matching only whole words.

By default, searching is incremental while you type your search string. To disable this, uncheck
Incremental in the Options menu.

Replacing

When the tool is displayed with Replace, or when the Show Replace item in the Options menu is
activated, Wing will show an area for entering a replace string and add Replace and Replace All
buttons to the Search tool:

Testing |Stack Data| Search [Python Shell | Debug Probe |OS Commands
Search: | PrintAs
Replace: | OutputAs

Case sensitive Whole words In Selection

4 Previous & Next Replace Replace All | Search Successful Options

Try replacing examplel.py with search string PrintAs and replace string OutputAs.

Select the first result match and then Replace repeatedly. One search match will be replaced at a time.
Search will occur again after each replace automatically unless you turn off the Find After Replace
option. Changes can be undone in the editor, one at a time. Do this now to avoid saving this replace
operation.

Next, try Replace All instead. Wing will simply replace all occurrences in the file at the same time.
When this is done, a single undo in the editor will cancel the entire replace operation.

Wildcard Searching
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By default, Wing searches for straight text matches on the strings you type. In Wing Pro and Wing
Personal, wildcard and regular expression searching are also available in the Search tool's Options
menu.

Wildcard searching allows you to specify a search string that contains * to match anything, ? to match a
single character, or ranges of characters specified within [ and ] to match any of the specified
characters. This is the same syntax supported by the Python glob module and is described in more
detail in Wildcard Search Syntax.

Try a wildcard search now by selecting Wild Card from the Options menu while examplel.py is your
current editor. Set the search string to PrintAs*(. This should display all occurrences of the string
PrintAs, followed by zero or more characters, followed by (:

Testing | Stack Data| Search [Python Shell | Debug Probe |OS Commands
Search: | PrintAs*(

Case sensitive Whole words In Selection

4 Previous ¥ Next Search Successful Options

Also try searching on PrintAs*[A-Z]( with the Case Sensitive search option turned on. This matches all
strings starting with PrintAs followed by zero or more characters, followed by any capital letter from A
to Z, followed by (.

Finally, try PrintAsT???, which will match any string starting with PrintAsT followed by any three
characters.

Regular Expression Search

Regular expressions are most useful for complex search tasks, such as finding all calls to a particular
function that occur as part of an assignment statement.

For example, open\(newscache( )?,.*\) matches only calls to the function open where the first
argument is named newscache and there are at least two parameters. If you try this with examplel.py
after selecting Regex search from the Options menu then you should get exactly one search match:
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examplel.py: tutorial.wpr: Wing

[ JoX )

Rwi@W i s
examplel.pylexample2.py|Help|test_examplel.py
ReadPythonNews

txt = f.read()
f.closel()

if txt is None:
try:
if sys.hexversion >= 0x03000000:

svc = request.urlopen("http://planet.python.org/rss20.xml")

else:

svc = urllib.urlopen("http://planet.python.org/rss20.xml")

txt = svc.read()
svc.close()
except:
return kCannedData
i = (newscache, 'wb')
f.write(txt)
f.close()

<~ if (txt) == 0:
return []

Testing|Stack Data|Search |Python Shell|OS Commands|Debug Probe

NEl{dMllopen\(newscache()?,.*\)l

Case sensitive ] Whole words [ In Selection

t Previous ¥ Next

& Line 57 Cols 8-29 - [User]

In this mode, the replace string can reference regex match groups with m, m, etc,

re.sub() call.

The details of regular expression syntax and usage see Regular Expression Syntax in the Python

manual.

See also Search Tool for more information.

12.4. Tutorial; Search in Files

The Search in Files tool in Wing Pro and Wing Personal supports multi-file batch search of the disk,
project, open editors, documentation, or other sets of files. It can also search and replace using

wildcards and regular expressions.

Regex Flags

Options

nt|Refactoring|Uses|Code Warnings|Search in Files|Open Files|Project

as in the Python


https://docs.python.org/library/re.html
https://wingware.com/doc/edit/search-tool

examplel.py: tutorial.wpr: Wing

[ JoX )

Rwi@W i s
examplel.pylexample2.py|Help|test_examplel.py
< PromptToContinue

v~ def PromptToContinue(msg="Press Enter to Continue: "):
"""Prompt to continue and wait for the user to press Enter"""
~ 1if sys.hexversion >= 0x03000000:
= (msg)
v else:
X = raw_input(msg)

v def GetItemCount():
"""This gets the number of items to use in this example
return 5

< def ReadPythonNews(count, force=0):

Search in Files Testing|Stack Data|Search|Python Shell|OS Commands|Debug Probe
Look in: |Project Files Filter: [Python Files
Search: |def *(

Case sensitive ] Whole words Text search ©@ Wildcard search O Regex search

t Previous ¥ Next File: examplel.py Options
examplel.py, line 21: def PromptToContinue(msg="Press Enter to Continue: “):

examplel.py, line 29: def GetltemCount():

examplel.py, line 34: def ReadPythonNews(count, force=0):

examplel.py, line 69: def PrintAsText(news):

examplel.py, line 76: def PrintAsHTML(news):

& Line 21 Cols 0-21 - [User]

nt|Refactoring|Uses|Code Warnings|Search in Files|Open Files|Project

Before worrying about the details, try a simple batch search on the examplel.py file. Select
Current File from the Look in selector on the Search in Files tool. Then enter PrintAs into the search
area.

Wing will start searching immediately, restarting the search whenever you alter the search string or
make other changes that affect the result set, or if the files being searched change.

When you are done typing, you should see results similar to those shown in the screen shot above.
Click on the first result line to display examplel.py in the editor with the corresponding search match
highlighted.

Next, change the Look in selector to Project Files and change your search string to HTML. This works
the same way as searching a single file, but lists the results for all files that have been added to your
project.

You can also search all currently open files or within Wing's documentation by instead selecting
Open Files or Documentation from Look in.

File Filters

In many cases, searching is more useful if constrained to a subset of files in your projects such as only
Python files. This can be done with by selecting Python Files in the Filter selector. You can also define
your own file filters using the Create/Edit Filters item in the Filter selector. This will display the
Files > File Types > File Filters preference:



Name Specification

All Source Files : Wild Card on File Name: *.pyo; Wild C:
C/C++ Files Mime Type: text/x-c-source; Mime Typ
HTML and XML Files Mime Type: text/html; Mime Type: text

File Filters

Hidden & Temporary Files Wild Card on File Name: *.pyo; Wild Car

Vpse Ao - Vo e
El

»

Insert

Each file filter has a name and a list of include and exclude specifications. Each of these specifications
can be applied to the file name, directory name, or the file's MIME type. An example would be to specify
*.Jjs wildcard for matching Javascript files by nhame, or using the text/html mime type for all HTML files.

Searching Disk

Wing can also search directly on disk. Try this by typing a directory path in the Look in area. Assuming
you haven't changed the search string, this should search for HTML in all text files in that directory.

Disk search can be recursive, in which case Wing searches all sub-directories as well. This is done by
selecting a directory in the Look in scope selector and enabling Recursive Directory Search in the
Options menu.

You can alter the format of the result list with the Show Line Numbers item and Result File Name
group in the Options menu.

Note that searching Project Files is usually faster than searching a directory structure because the set
of files is precomputed and thus the search only needs to look in the files and not spend time
discovering them.

Multi-file Replace

When replacing within multiple files, Wing opens each changed file into an editor, whether or not it is
already open. This allows you to undo changes by not saving files or by issuing Undo within each
editor.

If you check Replace Operates on Disk in the Options menu, Wing will change files directly on disk
instead of opening editors into the IDE. This can be much faster but is not recommended unless you are
using a revision control system that can be used to undo mistakes.

Note that even when operating directly on disk, Wing will replace changes in already-open editors only
within the IDE. This avoids creating two versions of a file if there are already edits in the IDE's copy. We
recommend selecting Save All from the file menu immediately after each replace operation. This avoids
losing parts of a global replace operation.

See Multi-File Search and Replace for details.

Tutorial: Other IDE Features

By now you have seen many of the IDE's features. Before we call it a day, let's look at a few other major
features that are worth knowing about.

OS Commands


https://wingware.com/doc/edit/search-in-files

The OS Commands tool can be used to set up, execute, and interact with external commands, for
building, deployment, and other tasks. The Build Command field in the Debug/Execute tab of
Project Properties can be used to configure and select one command to execute automatically before
any debug session begins. OS Commands can also be bound to keys, and the Start Terminal item in
the Tools menu uses it to start command prompt in Wing:

Search in Files|Testing|Stack Data|Search|Python Shell|OS Commands|Debug Probe
Terminal 1 4 @ OQOptions

Running... (6 lines)
bash-3.2$ 1s
README. txt newscache.rdf tutorial.wpu

__pycache__  subdir wingdbstub.py
examplel.py test_examplel.py
example2.py tutorial.wpr

bash-3.2$

See OS Commands Tool for details.
Source Browser

The Source Browser in Wing Pro and Wing Personal can be used to inspect and navigate the module
and class structure of your Python source code.

ect

Browse Project Modules Options
> ¢ cache
> @ capabilities
v @ codewarnings
» @ cap_warningspanel
Y @ manager
» @ CCodeWarningsManager
* kEnable
» -
» 2 command
v @ config
> @ GetDefaultProjectLoc()
> @ GetWingFilename()
» @ SetLanguageEnvVariable()
» @ _GetSteamlIDs()
of
+ gStartupEnv
+ kAboutimagelLoc

0J

Call Stack|Snippets|Source Browser|Pr

Double-clicking on items in the Source Browser opens them into an editor. When Follow Selection is
enabled in the Options menu, Wing also opens files that are single-clicked or visited by keyboard
navigation within the Source Browser.

The popup menu at the top left of the Source Browser selects whether to browse the current file, all
project modules, or all project classes. The Options menu in the top right allows sorting and filtering
symbols by type.

Notice that the Source Assistant tool is integrated with the Source Browser, and will update its
content as you move around the Source Browser.


https://wingware.com/doc/oscommands/index

File Sets

Wing allows you to create named sets of files which you can open as a group or search in the
Search in Files tool. See File Sets for details.

File Operations

Files can be created, deleted, moved, and renamed from the Project tool by right-clicking, dragging,
and clicking on names in the tree. Deleted files are moved to the system's trash or recycling bin.

When files are in a revision control system, Wing will also issue the necessary revision control
commands to create, delete, move, or rename the file in the repository.

See File Operations for details.
Perspectives

Perspectives are a way to store and later revisit particular arrangements of the user interface. For
example, you may set up one set of visible tools to use when testing, another for working on
documentation, and still another for debugging.

Perspectives are accessed from the Tools menu.

[} Manage Perspectives
Name Shared Style Key Binding
debug tools-only
> edit tools-only
testing tools-only Ctrl-X T
user tools-only

+ &
Right click on the list for additional operations

s\ Preferences... B Show Docs... Load \ Close

Wing can optionally switch perspectives automatically whenever debugging starts or stops, so that the
user interface differs according to how the tools were left when last editing or debugging. This is done
by selecting Enable Auto-Perspectives in the Tools menu.

See Perspectives for details.
Command Set and Key Bindings

Wing's complete command set is documented in the Command Reference. Any of these commands
can be bound to a key binding with the User Interface > Keyboard > Custom Key Bindings
preference. A key binding may be a single chord such as Shift-Ctrl-X or a sequence like Ctrl-; A.

To invoke a command directly even if it does not appear in a menu or toolbar item, use the
Command by Name item in the Edit menu.

The default key bindings are documented in Key Binding Reference. You can check what command a
key is bound to using the command describe-key-briefly, also invoked from Command by Name in
the Edit menu.


https://wingware.com/doc/edit/file-sets
https://wingware.com/doc/proj/file-operations
https://wingware.com/doc/custom/perspectives
https://wingware.com/doc/commands/index
https://wingware.com/doc/keymaps/index

Extending the IDE

Wing can be extended by writing Python scripts that call into the IDE's scripting API. This is useful for
adding everything from simple editor commands and debugger add-ons to new tools.

Script-defined commands may be bound to keys, added to menus, or invoked from the toolbar just like
Wing's built-in commands.

There is a collection of user-contributed scripts for Wing in the contributed materials area.

For details see Scripting and Extending Wing.

Tutorial: Further Reading
Congratulations, you've finished the tutorial!

As you work with Wing Personal on your own software development projects, the following resources
may be useful:

Wing Reference Manual which documents all the features in detail.

Wing Support Website which includes a Q&A support forum, mailing lists, documentation, links to social
media, and other information for Wing users.

A collection of Wing Tips, available on our website and by weekly email subscription, provides additional
tips and tricks for using Wing productively.

Thanks for using Wing Personal!


https://github.com/wingware-dev/wing-contrib
https://wingware.com/doc/scripting/index
https://wingware.com/doc/manual
https://wingware.com/support
https://wingware.com/hints
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