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This is a collection of HOW-TOs designed to make it easier to get started using Wing on
certain platforms with special requirements and with specific tools and libraries for GUI,
web, and other types of development.
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Wing IDE Quick Start Guide

This is a minimalist guide for those wanting to get started with Wing IDE as quickly as
possible. For a more in-depth introduction, try the Tutorial.

Also available: Quick start guides specifically for OS X installation, Zope, Plone, Tur-
bogears, Django, wxPython, PyGTK PyQt, Debugging Web CGIs, mod_python,
PyGame, and many others

We welcome feedback and bug reports, both of which can be submitted directly from
Wing IDE using the Submit Feedback and Submit Bug Report items in the Help
menu, or by emailing us at support at wingware.com.

Install Python and Wing IDE

Both Python and Wing IDE must be installed. The Wing IDE executable is called wing3.0.
See Installing, Running the IDE, and Installing your License for details.

Set up a Project

Wing starts up initially with a blank Default Project. To get the most out of Wing, you
must set up your project as follows:

e Use Add Directory and other items in the Project menu to add source files to the
project.

e Use Project Properties in the Project menu to specify Python Path and in some
cases select the specific version of Python for use with your project. These two steps


mailto:support@wingware.com

tell Wing how to resolve imports in your code, so it can discover and analyze your
source base. This powers Wing’s source browser, auto-completer, source assistant,
and code navigation features. It is also used for the debugger.

e Save your project to disk.

Note: Depending on the size of the code base you have added to your project, Wing may
consume considerable CPU time for up to several minutes analyzing your source code.
Once this is done, Wing should run with a snappy and responsive interface even on slower
machines. If not, please let us know.

See Debug Properties and Source Code Analysis for details.

Key Features

You are now ready to start coding and debugging. Most of Wing’s features are readily
evident from the user interface. The Wing Tips tool provides useful usage hints.

These are the features you should be sure to try while evaluating Wing IDE:

e Configurable Key Bindings -- Wing can emulate Visual Studio, VI/Vim, Emacs, and
Brief key bindings, selected with the editor Personality preference.

e Configurable Tab Key -- Wing maps the tab key to Indent To Match by default for
Python and Increase Indent for other files. This can be changed from the Tab Key
Action preference.

o Auto-completion and Source Assistant -- Wing’s editor and the Source Assistant
tool (in Wing Pro only) provide context-appropriate completion options and doc-
umentation as you edit your code. The auto-completer uses Tab by default for
completion, but this can be changed in the Completion Keys preference

o (Customizable User Interface -- Many options are available from Preferences, and
you can split tools panels and move around the tools within them. Right click on
the notebook tabs for options, or use the Windows menu to create tools in separate
windows. Your configuration is remembered in your project.

e Goto-definition -- Available from the toolbar, Source menu, and by right-clicking on
symbols in the editor.

e Source Index -- Quick access to other parts of a source file from the menus at the top
of the source editor.



e Mini-search -- Wing’s powerful keyboard-driven search and replace facility is available
from the Edit menu. Using the keyboard equivalents given in the menu, bring up
the search entry area at the bottom of the screen, type in a search string, then repeat
the key bindings for repeated search forward /backward.

e Search Managers -- Provide single and multi-file, wild card, and regular expression
search and replace. Available as Search and Search in Files in the tools area.

e Source Browser -- Module or class oriented display of the structure of your source
code. Show both the Source Browser and Source Assistant for detailed informa-
tion about selected symbols.

e Python Shell -- This Python command prompt lets you try out code in a sandbox
process kept isolated from Wing IDE and your debug process.

e Basic Debugging -- Set a breakpoint and start debugging. You can use the Stack
Data tools to inspect or change program data. Wing distinguishes between fatal
and non-fatal exceptions at the time they are raised, allowing you to inspect live
program state more often. Debug process 1/0 is shown in the integrated I/0 tool
(or optionally in an external console).

e Conditional breakpoints -- A powerful tool in isolating complex bugs by stopping
before they occur.

e Debug Probe -- This tool provides an interactive Python prompt that executes code in
the current stack frame of a paused debug process. The Debug Probe is particularly
useful in isolating and understanding complex bugs, and designing code that fixes the
problem.

o Watching Values -- Enter expressions to watch in the Watch tool, or right-click on
any of the data views to track value over time by symbolic name or object reference.

e Other Tools -- Templating / code snippets, bookmarks, macros, unit testing tool,
aand many other powerful features are available from Wing’s menus.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Tutorial, a detailed guided tour for Wing IDE.

e Wing IDE Reference Manual, which describes Wing IDE in detail.



e OS X Quickstart

e How-tos for using Wing with common packages



Wing IDE for OS X

Wing IDE uses X windows on OS X, but support for X is not by default part of all versions
of OS X. Thus you also need to obtain and install an X server and X Window manager.
There are a number of options for this:

(1) Apple’s X11 Server for OS X is among the fastest and best integrated options.
It includes both the X Server and a native Aqua window manager, although you
can replace the default window manager with your favorite if you wish. Apple
X11 Server comes with OS X 10.3 and later, but is not installed by default and
must be installed separately, usually from Install Disk #2 (but location varies
by exact version of the OS). Sometimes the installer is hidden by default so
you’ll need to scroll down in the Finder window for the installation disk to find
it. For OS X 10.3, X11 is also available as downloadable package from Apple’s
website, but this version will not work with OS X 10.4. If all else fails, search
on your install disks for X11User.pkg, which is the package to install.

(2) XDarwin (1.1 or later) can be used together with the window manager of
your choice. Window Maker is one that users have reported as working well.
OroborOSX (0.75a4r2 or later) also works but can be quite slow in compari-
son with other options (as of 0.8 preview 2). Note that for some versions of
OroborOSX, you need to unpack both the top-level OroborOSX tar file and the
XDarwin.tar file located inside the installation.

Once this is set up, you're ready to install Wing IDE. Just download Wing IDE, double
click on the disk image, and move its contents place on your disk (or, you can just run
Wing directly from the disk image).

Next make sure your X Windows server chosen above is running and set up to allow
connections from X clients on :0.0. Wing will automatically start Apple X11 Server if it
is present and not yet running.

Then double click on the Wing IDE app. The first time you start Wing, it will ask you
to accept the license agreement and will ask for a license. Use the first (default) option in


http://www.apple.com/macosx/features/x11/
http://www.xdarwin.org/
http://www.windowmaker.info/
http://oroborosx.sf.net/
http://wingware.com/wingide/downloads

10

the dialog that appears to obtain a 10 day trial license (this can be renewed twice when
the trial period expires).

At this time, Wing will create a User Settings Directory in ~/.wingide3, which is used
to store preferences and other settings.

The location of Wing’s internal application contents folder is referred to as WINGHOME. For
example if you unpacked Wing into /Applications/Wing then WINGHOME will be /Appli-
cations/Wing/WingIDE.app/Contents/Mac0S.

To start Wing from the command line, execute wing located in WINGHOME
(/Applications/Wing/WingIDE.app/Contents/Mac0S/wing in the above example).
When you do this, you may need to set your DISPLAY environment variable to point to
your X Server (for example setenv DISPLAY :0.0).

See the Tutorial and Wing IDE Quickstart Guide for additional information on getting
starting with Wing IDE.

Usage Tips

Wing starts with a keyboard mapping that emulates the most commonly used key standards
on the Macintosh. This mapping will not work properly unless you uncheck the “Enable
Keyboard Shortcuts under X11” preference in Apple X11 Server configuration (this was
called “Enable Key Equivalents under X11” in older versions). Wing will warn when this
option is checked, but may fail to do so under other X11 server software. Wing also tries
to detect if an Apple keyboard is in use, but you may need to set the Apple Keyboard
preference to yes or no if the detection fails.

You can alter keyboard mapping (for example, to use Emacs bindings instead) with the
Personality preference, or change individual key mappings with the Custom Key Bind-
ings preference. If you do use a keyboard personality other than the OS X personality, you
may want to map the option or command key to the Alt modifier using the Global X11
Alt Key preference. The option key should be used only if you don’t need the option key
to enter individual characters. Note that this preference affects all X11 applications, not
just Wing. It may also affect whether the Custom Key Bindings preference will accept
Command as a key modifier.

Under OS X 10.4 (Tiger), the option/compose key used to enter accented and other foreign
characters will not work because of changes in the Apple X11 applications. To fix this,
enable the Fix Option key bug in Tiger (OS X 10.4) preference. This will affect all
X11 applications, not just Wing.
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If you are running other X11 applications and want to work around this bug yourself, you’ll
want to either enable the XKEYBOARD extension on the X11 server or use xmodmap to
assign the Mode_Switch key to a modifier other than modl. The xmodmap script that
Wing runs when the Fix Option key bug in Tiger (OS X 10.4) preference is enabled
is ${ WINGHOME} /resources/osx/fix-tiger-mode-switch.xmodmaprc. The script removes
Mode_Switch from modl and adds it to mod5 and is run only if the preference is enabled
and xmodmap reports that Mode_Switch is assigned to mod1.

If the X11 Application “Use the system keyboard layout” preference is enabled, then the
X11 server may modify its keyboard mapping when the system keyboard changes. You
may need to disable this preference or restart Wing after the keyboard layout changes
because Wing will not re-apply the fix after the X11 keyboard changes. This should only
be an issue if you change keyboard layouts while Wing is running.

Depending on the version of Apple X11 Server and possibly other factors, any of the
keyboard preference changes made in X11 Server configuration or those Wing preferences
indicated above as affecting all X11 applications may require restarting both Wing and
Apple X11 Server before the work properly.

Changing Display Themes

Although Wing is not a native OS X application, it starts up with a display theme that
tries to match the OS X look and feel (font size often needs to be altered from the Dis-
play Font /Size preference). Additional display themes can be selected from the Display
Theme preference.

It is also possible to download other themes for GTK2 and place them into
Contents/Mac0S/bin/gtk-bin/share/themes inside your Wing IDE installation. Once
this is done and Wing is restarted, they will show up in the Display Theme preference.

One nice OS X like theme is AquaX, currently not included with Wing because we cannot
redistribute it under its licensing.

Note that only themes that do not use a theme engine or use one of those in /bin/gtk-
bin/lib/gtk-2.0/2.4.0/engines in your Wing installation will work with Wing IDE. We can-
not make any guarantees for performance or results when using themes not included with
Wing IDE, although Aqua X is known to work well.


http://art.gnome.org/themes/gtk2/
http://themes.freshmeat.net/projects/aquax-gtk2/
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Finding WINGHOME

When using the Zope Support Module or following instructions that refer to WINGHOME
note that WINGHOME is defined as the location of the wing executable, which on
Mac OS X is inside the Contents/Mac0S folder of the Wing IDE app folder. E.g.,
if you unpacked Wing into /Applications/Wing then WINGHOME will be /Applica-
tions/Wing/WingIDE.app/Contents/MacOS.

Mouse Buttons

Right-click for menus by holding down the Option/Alt key while clicking. Middle-click
by holding down the Control key while clicking. These defaults can be changed in your
X11 server’s preferences. For example, under Apple X11 Server, change so Option/Alt is
button two and Control is button three with this command:

defaults write com.apple.x11 fake_button2 option
defaults write com.apple.x11l fake_button3 control

Or change so that Option/Alt is button two and Apple/Command is button three:

defaults write com.apple.x11 fake_button2 option
defaults write com.apple.x11l fake_button3 command

Then restart the X11 Server.

Window Focus

You can configure Apple X11 Server to automatically transfer focus to the window the
mouse pointer is over, or to pass through the click that is used to bring focus to the
window so it is also processed by the application.

To move focus with the mouse pointer:
defaults write com.apple.x11 wm_ffm true

To pass through the focus click:
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defaults write com.apple.x1l wm_click_through -bool true

You must restart Apple X11 changing either of these configurations before they take effect.
Other configuration options like this can be obtained by looking in the manual pages for

quartz-wm and Xquartz:

man quartz-wm
man Xquartz

Known Problems

At least some versions of the MacPorts packaging of Python are known not to work with
Wing’s debugger because it contains an _md5 module that won’t load. To work around
this, use a different distribution of Python instead.

The copy of Python shipped with OS X does not include source files for the standard
libraries, so Wing’s editor will not offer autocompletion values for those modules. To work
around this, use a copy of Python installed from the standard source distribution.

There is no way to control-click on a Mac, so control-left-click for the goto-definition feature
doesn’t work. Instead, use Goto Selected Symbol from the Source menu instead; this works
relative to position of the insertion cursor in the current editor and can be accessed by the
key binding shown in the Source menu.

Please send bug reports to bugs at wingware.com.

Related Documents

e Wing IDE Quickstart Guide, which contains additional information about getting
started with Wing IDE.

e Other How-Tos, for getting started with Wing IDE and specific tools.

e Wing IDE Reference Manual, which describes Wing IDE in detail.


mailto:bugs@wingware.com
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How-Tos for Web Development

The following How-Tos provide tips and short cuts for using a number of popular web
development frameworks with Wing IDE.

3.1. Using Wing IDE with Zope

“The best solution for debugging Zope and Plone” -- Joel Burton, Member,
Plone Team, Jul 2005

Wing IDE can be used to develop and debug Python code running under Zope2 or Zope3,
including Products, External Methods, file system-based Scripts and Zope itself. It is also
useful for Zope-based frameworks like Plone (see Plone Quickstart).

Wing provides auto-completion, call tips, and other features that help to write, navigate,
and understand Zope code. Wing’s debugger can work with Zope’s code reloading features
to achieve a very short edit/debug cycle.

Note: This guide is for Zope2 users. If you are using Zope3, please try z3wingdbg
by Martijn Pieters or refer to Debugging Externally Launched Code in the users
manual to set up Zope3 debugging manually.

Limitations: Wing IDE cannot debug DTML, Page Templates, ZCML, or Python code
that is not stored on the file system.

Security Warning: We advise against using the WingDBG product on production web
servers. Any user connected to the Wing IDE debugger will (unavoidably) have extensive
access to files and data on the system.

15


http://wingware.com/wingide
http://www.plone.org/
http://www.zopatista.com/projects/z3wingdbg
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Upgrading from earlier Wing versions

If you are upgrading from an older version of Wing and have previously used Wing with
your Zope installation(s), you need to manually upgrade WingDBG in each Zope instance.
Otherwise, debugging may fail.

The easiest way to do this is to go to the Zope Control Panel, click on Wing Debug Service,
and then Remove the control panel. Then restart Zope. Next, go into your Wing project’s
Extension Tab, verify that you've got the Zope Instance Home set correctly, and press
Apply. This will offer to re-install WingDBG with the latest version and will configure it to
point to the new version of Wing.

Quick Start on a Single Host

To use Wing IDE with Zope running on the same host as the IDE:

e Install Zope -- You can obtain Zope from zope.org. Version 2.5.1 or newer will work
with Wing.

e Install Wing IDE -- You will need Wing IDE 2.1 or later. See Installing for
details.

e Configure Wing IDE -- Start Wing, create or open the project you wish to use
(from the Project menu). Then use the Extensions tab in Project Properties
to enable Zope2/Plone support and to specify the Zope2 Instance Home to
use with the project. Wing will find your Zope installation by reading the file
etc/zope.conf in the provided Zope instance. Once you press Apply or 0K in the
Project Properties dialog, Wing will ask to install the WingDBG product and will
offer to add files from your Zope installation to the project.

e Configure the WingDBG Product -- Start or restart Zope and log into
http://localhost:8080/manage (assuming default Zope configuration). The Wing De-
bugging Service will be created automatically on startup; you can find it under the
Control Panel of your server.

Starting the Debugger

Proceed to the Wing Debugger Service by navigating to the Control Panel, then selecting
the "Wing Debugging Service’. Click in the “Start” button. The Wing IDE status area
should display “Debugger: Debug process running”.


http://www.zope.org
http://wingware.com/downloads
http://localhost:8080/manage
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Note that you can configure WingDBG to start and connect to the IDE automatically
when Zope is started from the Advanced configuration tab.

Problems? See the Trouble-Shooting Guide below.

Test Drive Wing IDE

Once you’ve started the debugger successfully, here are some things to try:

Run to a Breakpoint -- Open up your Zope code in Wing IDE and set a breakpoint on a
line that will be reached as the result of a browser page load. Then load that page in your
web browser using the port number displayed by the Zope Management Interface after you
started the debugger. By default, this is 50080, so your URL would look something like
this:

http://localhost:50080/Rest/0f/Usual/Url

Explore the Debugger Tools -- Take a look at these tools available from the Tools
menu:

e Stack Data -- displays the stack, allows selecting current stack frame, and
shows the locals and globals for that frame.

e Debug Probe -- lets you interact with your paused debug process using a
Python shell prompt

e Watch -- watches values selected from other value views (by right-clicking
and selecting one of the Watch items) and allows entering expressions to
evaluate in the current stack frame

e Modules -- browses data for all modules in sys.modules
e Exceptions -- displays exceptions that occur in the debug process

e Debug I/0 -- displays debug process output and processes keyboard input
to the debug process, if any

Continue the Page Load -- When done, select Start / Continue from the Debug menu
or toolbar.

Try Pause -- From Wing, you can pause the Zope process by pressing the pause icon in
the toolbar or using Pause from the Debug menu. This is a good way to interrupt a lengthy
computation to see what’s going on. When done between page loads, it pauses Zope in its
network service code.
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Other Features -- Notice that Wing IDE’s editor contains a source index and presents
you with an auto-completer when you're editing source code. The Source Assistant will
display context appropriate call tips and documentation. Control-click on a source symbol
to jump to its point of definition (or use Goto Selected Symbol in the Source menu). Bring
up the Source Browser from the Tools menu to look at the module and class structure of
your code.

Setting Up Auto-Refresh
When you edit and save Zope External Methods or Scripts, your changes will automatically
be loaded into Zope with each new browser page load.

By default, Zope Products are not automatically reloaded, but it is possible to configure
them to do so. This can make debugging much faster and easier.

Take the following steps to take advantage of this feature:
e Place a file called refresh.txt in your Product’s source directory (for example,

Products/MyProductName inside your Zope installation). This file tells Zope to allow
refresh for this product.

e Open the Zope Management Interface.

e Expand the Control Panel and Products tabs on the upper left.

e Click on your product.

e Select the Refresh tab.

e Check the “Auto refresh mode” check box and press “Change”.

e Make an edit to your product source, and you should see the changes you made take

effect in the next browser page load.

Limitations: Zope may not refresh code if you use import statements within functions or
methods. Also, code that manages to retain references to old code objects after a refresh
(for example, by holding the references in a C/C++ extension module) will not perform
as expected.

If you do run into a case where auto-reload causes problems, you will need to restart Zope
from the Zope Management Interface’s Control Panel or from the command line. Note
that pressing the Stop button in Wing only disconnects from the debug process and does
not terminate Zope.
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Setting up Remote Debugging

Configuring Wing for remote debugging can be complicated, so we recommend using X
Windows (Linux/Unix) or Remote Desktop (Windows) to run Wing IDE on the same
machine as Zope but display it remotely. When this is not possible, you can set up Wing
to debug Zope running on another machine, as described below:

e Set up File Sharing -- You will need some mechanism for sharing files between the
Zope host and the Wing IDE host. Windows file sharing, Samba, NFS, and ftp or
rsync mirroring are all options. For secure file sharing via SSH on Linux, try sshfs.

e Install Wing on the Server -- You will also need to install Wing on the host where
Zope is running, if it is not already there. No license is needed for this installation,
unless you plan to also run the IDE there. If there is no binary distribution of Wing
available for the operating system where Zope is running, you can instead install
only the debugger libraries by building them from source code (contact Wingware
for details).

e Basic Configuration -- Follow the instructions for Single-Host Debugging above
first if you have not already done so. Then return here for additional setup instruc-
tions.

e Configure Allowed Hosts -- You will need to add the IP address of the Zope host
to the Allowed Hosts preference in Wing. Otherwise Wing will not accept your
debug connections.

e Configure File Mapping -- Next, set up a mapping between the location of the
Zope installation on your Zope host and the point where it is accessible on you
Wing IDE host. For example, if your Zope host is 192.168.1.1 Zope is installed
in /home/myuser/Zope on that machine, and /home/myuser is mounted on your
Wing IDE host as e:, you would add a Location Map preference setting that maps
192.168.1.1 to a list containing /home/myuser/Zope and file:e:/Zope. For more
information on this, see File Location Maps and Location Map Examples in
the Wing IDE manual.

e Modify WingDBG Configuration -- When debugging remotely, the value given
to WingDBG for the Wing Home Directory must be the location where Wing is
installed on the Zope host (the default value will usually need to be changed).

e Check Project Configuration -- Similarly, the paths identified in Project Prop-
erties should be those on the host where Wing IDE is running, not the paths on the
Zope host.


http://fuse.sourceforge.net/sshfs.html
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Trouble Shooting Guide

You can obtain additional verbose output from Wing IDE and the debug process as follows:

o [f Zope or Plone on Windows is yielding a Site Error page with a notFoundEr-
ror when run under Wing’s debugger, you may need to go into the Zope Manage-
ment Interface and delete the access rule (... accessRule.py ...). Now, Zope/Plone
runs on port 8080, does not alter the configuration of port 80, and will work prop-
erly with Wing’s debug port (50080 by default). If the URL for your front page is
http://localhost:8080/default /front-page, the Wing IDE debug url will always be the
same but with the different port: http://localhost:50080/default/front-page (Thanks
for Joel Burton for this tip!)

e Go into the Wing Debugging Service in the Zope Management Interface and set Log
file under the Configure tab. Using <stdout> will cause logging information to
be printed to the console from which Zope was started. Alternatively, set this to the
full path of a log file. This file must already exist for logging to occur.

e Restart Zope and Wing and try to initiate debug.

e Inspect the contents of the log. If you are running Zope and Wing IDE on two sepa-
rate hosts, you should also inspect the error-log file on the Wing IDE host (located
in the User Settings Directory). It contains additional logging information from
the Wing IDE process.

For additional help, send these errors logs to support at wingware.com.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.
e Zope home page, which contains much additional information for Zope programmers.

e Quick Start Guide and Tutorial which contain additional basic information about
getting started with Wing IDE.


http://localhost:8080/default/front-page
http://localhost:50080/default/front-page
mailto:support@wingware.com
http://www.zope.org
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3.2. Using Wing IDE with Plone

“The best solution for debugging Zope and Plone” -- Joel Burton, Member,
Plone Team, Jul 2005

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for Plone, a powerful web content management system.

Since Plone is based on Zope, setting up Wing IDE with Plone is very similar to setting
up Wing IDE with Zope, which is described in detail in the Zope quickstart guide. The
only difference is that you will download and install Plone instead of Zope. Also, instead of
launching Zope only, you will be launching Plone (which on win32 is done with the Plone
launcher tool from the Start menu).

Performance Hints

Plone and Zope together contain a very large Python code base. If you Add Directory
from the Project menu to include the entire Plone installation, you will see significant
CPU intensive processing, which can be an issue on slower machines and may take several
minutes to complete. Wing should remain responsive during this time but may be sluggish
in some cases.

As long as the initial analysis is in process, the Source Browser will contain a subset of all
the code constructs available and some features like goto-definition may not work until the
entire source has been processed.

Processing chould cease after a period of time and the rest of your Wing IDE session should
run at near zero CPU usage, with a snappy and responsive GUI even on slower machines.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Using Wing IDE with Zope, which describes how to set up Zope for use with
Wing IDE.

e Wing IDE Reference Manual, which describes Wing IDE in detail.


http://wingware.com/wingide/
http://www.plone.org/
http://www.zope.org
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e Plone home page, which provides links to documentation.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

e Plone Bootcamps offer comprehensive training on Plone using Wing IDE throughout
the course. Students learn how to set up and use Wing IDE with Plone.

3.3. Using Wing IDE with Turbogears

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for Turbogears, a powerful web development system.

In order to debug Turbogears applications, you will need Wing 3.0 or later, since earlier
versions did not support multi-threaded debugging.

Installing Turbogears

The Turbogears website provides complete instructions for installing Turbogears. The
procedure varies slightly by OS.

Configuring Turbogears to use Wing

This section assumes your Turbogears project is called wingtest. If not, substitute your
project name in the following instructions.

e Go into the Turbogears instance directory wingtest and run Wing

e Add your directory to the project and save it as wingtest.wpr

e Open start-wingtest.py in Wing and set it as main debug file from the Debug
menu

e Edit start-wingtest.py and add the following before the server is started towards
the end of the script:


http://www.plone.org/
http://plonebootcamps.com
http://wingware.com/wingide/
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http://www.turbogears.org/
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import os
if os.environ.has_key(’WINGDB_ACTIVE’):
cherrypy.config.update({’autoreload.on’: False})

This is needed to prevent creation of a sub-process controlled by the auto-restarter,
which breaks debugging since Wing’s debugger will not be running in the sub-process.
If you omit this step, the symptom will be failure to stop on any breakpoints in your
Turbogears application.

e Set a breakpoint on the return line of Root.index() in your controllers.py or
somewhere else you know will be reached on a page load

e Start debugging in Wing from the toolbar or debug icon

e Bring up the Debug I/0 tool in Wing and wait until the server output shows that it
has started

e Load http://localhost:8080/ or the page you want to debug in a browser

e Wing should stop on your breakpoint

Notes

Some packages installed by Turbogears are not in unpacked eggs so the debugger cannot
show the source code. This can be fixed by unpacking the *.egg files that are zip files so
that they are replaced with directories of the same name that contain the contents of the
zip files. For example, on Linux:

mkdir tmp

mv cElementTree-1.0.5_20051216-py2.4-1inux-1i686.egg tmp
cd tmp

unzip cElementTree-1.0.5_20051216-py2.4-1inux-1i686.egg
cd

mv tmp cElementTree-1.0.5_20051216-py2.4-1inux-1686.egg

Turbogears will install itself into whichever instance of Python runs the installer script,
and only certain versions of Python work with a given version of Turbogears.

If you want to avoid adding Turbogears to an install of Python that you are using
for other purposes, you can install Python to a new location and dedicate that in-
stance to Turbogears. On Linux, this can be done as follows (assuming you create
/your/path/to/turbogears as the place to install):
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e In a Python source dist do:

./configure --prefix=/your/path/to/turbogears
make
make install

e Download tgsetup.py from the Turbogears website

e Edit tgsetup.py and change the one occurence of /usr/local/bin to
/your/path/to/turbogears/bin

e Run /your/path/to/turbogears/bin/python tgsetup.py
e Change to /your/path/to/turbogears
e Run bin/tgadmin quickstart

e Enter project name wingtest and defaults for the other options

Similar steps should work on Windows and OS X.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.
e Turbogears home page, which provides links to documentation.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

3.4. Using Wing IDE with Django

“Having to debug Django issues is almost enjoyable with the new debugger
support.” -- Doug Napoleone, Oct 2007
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Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for Django, a powerful web development system.

In order to debug Django applications, you will need Wing 3.0 or later, since earlier versions
did not support multi-threaded debugging.

Note: This document contains information obtained from users of Wing IDE. Its accuracy
has not yet been verified by Wingware.

Installing Django

The Django website provides complete instructions for installing Django.

Debugging Django with Wing

By default, Django runs in an environment that spawns and automatically re-launches a
sub-process for servicing web requests. This is used to automatically restart the server
if for some reason it crashes. However, this does not work with Wing’s debugger if you
launch Django from Wing, since the debugger has no way to cause the sub-process to be
debugged when it is started by the main process.

There are two ways to debug Django code: Either configure Django so it can be launched
by Wing’s debugger, or cause Django to attach to Wing on the fly as code that you wish
to debug is executed.

Launching from Wing

When Django is launched from Wing, it must be configured to avoid auto-reload and other
options that break the debugger.

Newer versions of Django include a --noreload option that you can pass to the manage . py
or django-admin. py scripts to turn off the auto restart feature of Django.

The typical way to do all this is to set the manage.py file as the primary debug file in
Wing and give it the following Run Arguments via the Debug properties tab in the File
Properties dialog:

runserver —--noreload
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Other options can be added here as necessary for your application.

Some versions of Django may also require adding --settings=devsettings to the argu-
ments for runserver, in order for debugging to work. If Wing is not be able to stop on
any breakpoints, try adding this.

In older versions of Django, the --noreload option does not exist. The only way to
solve the problem there is to make a modification to the code to prevent launching of a
sub-process, or to use the alternative method described below.

Debugging with Auto-reload

Another method of debugging Django is to use wingdbstub.py to initiate debugging when
Django is started from outside of Wing IDE. This will allow Django to restart automatically
after code changes and to automatically reconnect the debugger to Wing IDE as needed.

This is done by placing a copy of wingdbstub.py, which is located in your Wing IDE
installation directory, in the top of the Django directory, where manage.py is located.
Next, place the following code into files you wish to debug:

import wingdbstub

Then make sure that the Enable Passive Listen preference is enabled in Wing and start
Django. The Django process should connect to Wing IDE and stop at any breakpoints set
after the import wingdbstub.

When code is changed, just save it and Django will restart. The debugger will reconnect to
Wing IDE once you request a page load in your browser that leads to one of your import
wingdbstub statements.

Related Documents
Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.
e Django home page, which provides links to documentation.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.
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3.5. Using Wing IDE with Paste and Pylons

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for Paste and Pylons (which is based on Paste).

In order to debug Pylons and Paste applications, you will need Wing 3.0 or later, since
earlier versions did not support multi-threaded debugging.

Note: This documentcontains information obtained from users of Wing IDE. Its accuracy
has not yet been verified by Wingware.

Installing Paste and/or Pylons

The Pylons website and Paste website provide complete instructions for installing Pylons
or Paste

Debugging in Wing IDE

Paste and Pylons can be set to run in an environment that spawns and automatically
relaunches a sub-process for servicing web requests. This is used to automatically restart
the server if for some reason it crashes. However, this does not work with Wing’s debugger
since the debugger has no way to cause the sub-process to be debugged when it is started
by the main process.

To avoid this, do not specify the --reload flag for Paste. Place the following in a file that
you add to your project and set as the main debug file:

from paste.script.serve import ServeCommand
ServeCommand ("serve") .run(["development.ini"])

This may vary somewhat, as necessary for your application.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.
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e Pylons home page, which provides links to documentation.
e Paste home page, which provides links to documentation.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

3.6. Using Wing IDE with Webware

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for Webware, an open source web development framework.

To get started, refer to the tutorial in the Help menu in Wing and/or the Wing IDE
Quickstart Guide.

Introduction

Wing IDE allows you to graphically debug a Webware application as you interact with
it from your web browser. Breakpoints set in your code from the IDE will be reached,
allowing inspection of your running code’s local and global variables with Wing’s various
debugging tools. In addition, in Wing IDE Pro, the Debug Probe tab allows you to
interactively execute methods on objects and get values of variables that are available in
the context of the running web app.

There is more than one way to do this, but in this document we focus on an “in process”
method where the Webware server is run from within Wing as opposed to attaching to a
remote process. The technique described below was tested with Webware 0.9 and Python
2.4 on Cent0S Linux. It should work with other versions and on other OSes as well. Your
choice of browser should have no impact on this technique.

Setting up a Project

Though Wing supports the notion of “Projects” for organizing one’s work for this debugging
scenario you can use the Default Project and simply add your source code directory to
it by using Add Directory from the Project menu.
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You will also need to specify a Python Path in your Project Properties with something
like following (your actual paths depend on your installation of Webware and OS):

/usr/local/lib/Webware-0.9/WebKit:/usr/local/lib/Webware-
0.9:/home/dev/mycodebase

Note that on Windows, the path separator should be ’;’ (semicolon) instead. The Webware
MakeAppDir.py script creates a default directory structure and this example assumes that
the source code is nested within this directory.

To debug your Webware app you’ll actually be running the DebugAppServer and not the
regular AppServer, so you'll need to bring in the Debug AppServer and a couple of other
files with these steps:

1) Copy the DebugAppServer.py, ThreadedAppServer.py, and Launch.py from
the WebKit directory and put them in the root of the directory that MakeAp-
pDir.py created.

2) Right click on Launch.py in Wing’s editor and select the menu choice File
Properties. Click the Debug tab and enter DebugAppServer.py in the Run
Arguments field. If you're using the default project then leave the initial direc-
tory and build command settings as they are.

3) If you need to modify the version of Python you’re running, you can change the
Python Executable on the Environment tab of this debug properties window,
or project-wide from the Project Properties.

4) Optionally, after adding Launch.py to the project, right-click on its name in
the project view and select Set as Main Debug File. This will cause Wing
to always launch this file, regardless of which file is current in the editor.

Starting Debug

To debug, press the green Debug icon in the toolbar. If you did not set a main debug file
in the previous section, you must do this when Launch.py is the current file.

The file properties dialog will appear. Optionally, deselect Show this dialog before
each run. If you do this you can access the dialog again later by right clicking on the file
in Wing’s editor and selecting Properties.
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Click OK to start the debug process. The Debug 1/0 tool will show output from the
Webware process as it starts up. What you will see there depends upon your Webware
application and server settings, but you should see some log messages scroll by. If there is
a path or other kind of problem as the debugging process proceeds errors will display in
the Debug I/0 tool or in a pop-up error message in Wing if you have a missing library or
run into another unhandled exception.

Once the process has started up, you will be able to access web pages from your browser
according to your configuration of Webware, just as you would when running the server
outside of Wing.

Now for the fun part -- fire up your browser and go to the home page of your application.
Go into the source file for any Python servlet in Wing and set a breakpoint somewhere in
the code path that you know will be executed when a given page is requested. Navigate
to that page in your browser and you should see the Wing program icon in your OS task
bar begin to flash. (You'll see that the web page won’t finish loading -- this is because the
debugger has control now; the page will finish loading when you continue running your app
by pressing the Debug icon in the toolbar).

Now you can make use of all of the powerful debugging functionality available in Wing
instead of sprinkling your code with print statements.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

3.7. Using Wing IDE with mod_python

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to debug code that is run by the mod_python module for the
Apache web server. This document assumes mod_python is installed and Apache is config-
ured to use it; please see the installation chapter of the mod_python manual for information
on how to install it.
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Since Wing’s debugger takes control of all threads in a process, only one http request can
be debugged at a time. In the technique described below, a new debugging session is
created for each request and the session is ended when the request processing ends. If a
second request is made while one is being debugged, it will block until the first request
completes. This is true of requests processed by a single Python module and it is true of
requests processed by multiple Python modules in the same Apache process and its child
processes. As a result, it is recommended that only one person debug mod_python based
modules per Apache instance and production servers should not be debugged.

Quick Start

Copy wingdbstub.py from the Wing IDE installation directory into either the direc-
tory the module is in or another directory in the Python path used by the module.

Edit wingdbstub. py if needed so the settings match the settings in your preferences.
Typically, nothing needs to be set unless Wing’s debug preferences have been modi-
fied. If you do want to alter these settings, see the Remote Debugging section of
the Wing IDE reference manual for more information.

Copy wingdebugpw from your User Settings Directory into the directory that
contains the module you plan to debug. This step can be skipped if the module to
be debugged is going to run on the same machine and under the same user as Wing
IDE. The wingdebugpw file must contain exactly one line.

Insert import wingdbstub at the top of the module imported by the mod_python
core.

Insert if wingdbstub.debugger != None: wingdbstub.debugger.StartDebug()
at the top of each function that is called by the mod_python core.

Enable passive listening in Wing by setting the Enable Passive Listen preference
to true.

Restart Apache and load a URL to trigger the module’s execution.

Example

To debug the hello.py example from the Publisher chapter of the mod_python tutorial,
modify the hello.py file so it contains the following code:



32

import wingdbstub

def say(req, what="NOTHING"):
if wingdbstub.debugger != None:
wingdbstub.debugger.StartDebug()
return "I am saying %s" 7% what

And set up the mod_python configuration directives for the directory that hello.py is in
as follows:

AddHandler python-program .py
PythonHandler mod_python.publisher

Then set a breakpoint on the return "I am saying %s" % what line, make sure Wing is
listening for a debug connection, and load http://[server]/[path] /hello.py in a web
browser (substitute appropriate values for [server| and [path]). Wing should then stop at
the breakpoint.

Related Documents

e Wing IDE Reference Manual, which describes Wing IDE in detail.

e Mod_python Manual, which describes how to install, configure, and use mod_python.

3.8. Debugging Web CGIs with Wing IDE

Wing IDE can be used to debug CGI scripts written in Python, even as they are running
as the result of a page load from a web browser. To set up your CGIs for debugging with
Wing IDE, refer to the Debugging Externally Launched Code section of the manual.
Pay careful attention to the permissions on files, especially if your web server is running
as a different user than the process that is running Wing IDE. You will also need to make
sure that the wingdebugpw file is referenced correctly as described in the instructions.

The rest of this guide provides some tips specific to the task of debugging CGIs:

(1) If Wing is failing to stop on breakpoints, check whether you are loading a web page
that loads multiple parts with separate http requests -- in that case, Wing may still be
busy processing an earlier CGI request when a new one comes in and will fail to stop on
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breakpoints because only one debug process is serviced at a time. This is a limitation in
Wing. The work-around is to load specific parts of the page in the browser by entering the
URL you wish to debug.

(2) Any content from your CGI script that isn’t understood by the web server will be
written to the server’s error log. Since this can be annoying to search through, it is much
easier to ensure that all output, including output made in error, is displayed in your web
browser.

To do this, insert the following at the very start of your code, before importing wingdbstub
or calling the debugger API:

print "Content-type: text/html\n\n\n<html>\n"

This will cause all subsequent data to be included in the browser window, even if your
normal Content-type specifier code is not being reached.

(3) Place a catch-all exception handler at the top level of your CGI code and print exception
information to the browser. The following function is useful for inspecting the state of the
CGI environment when an exception occurs:

import sys
import cgi
import traceback
import string

def DisplayError():
""" Qutput an error page with traceback, etc """

print "<H2>An Internal Error Occurred!</H2>"
print "<I>Runtime Failure Details:</I><P>"

t, val, tb = sys.exc_info()
print "<P>Exception =", t, "<br>"
print "Value = ", val, "\n", "<p>"

print "<I>Traceback:</I><P>"
tbf = traceback.format_tb(tb)
print "<pre>"

for item in tbf:
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outstr = string.replace(item, ’<’, ’&lt;’)
outstr = string.replace(outstr, ’>’, ’&gt;’)
print string.replace(outstr, ’\n’, ’\n’), "<BR>"
print "</pre>"
print "<P>"

cgi.print_environ()
print "<BR><BR>"

(4) If you are using wingdbstub.py, you can set kLogFile to receive extra information
from the debug server, in order to debug problems connecting back to Wing IDE.

(5) If you are unable to see script output that may be relevant to trouble-shooting, try
invoking your CGI script from the command line. The script may fail but you will be able
to see messages from the debug server, when those are enabled.

(6) If all else fails, read your web browser documentation to locate and read its error log
file. On Linux with Apache, this is often in /var/log/httpd/error_log. Any errors not
seen on the browser are appended there.

(7) Once you have the debugger working for one CGI script, you will have to set up the
wingdbstub import in each and every other top-level CGI in the same way. Because this
can be somewhat tedious, and because the import needs to happen at the start of each
file (in the __main__ scope), it makes sense to develop your code so that all page loads
for a site are through a single entry point CGI and page-specific behavior is obtained via
dispatch within that CGI to other modules. With Python’s flexible import and invocation
features, this is relatively easy to do.



How-Tos for GUI Development

The following How-Tos provide tips and short cuts for using a number of popular GUI
development frameworks with Wing IDE.

4.1. Using Wing IDE with wxPython

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for the powerful wxPython cross-platform GUI development toolkit.

wxPython is a good choice for GUI developers. It currently available for MS Windows,
Linux, Unix, and Mac OS X and provides native look and feel on each of these platforms.

While Wing IDE does not provide a GUI builder for wxPython, it does provide the most
advanced debugger and source browser capabilities available for the Python programming
language, and it can be used with other available GUI builders, as described below.

Installation and Configuration

Take the following steps to set up and configure Wing IDE for use with wxPython:

e Install Python and Wing. You will need a specific version of Python depending on
the version of wxPython you plan to use. Check the wxPython Getting Started
Wiki when in doubt. See the generic Wing IDE Quickstart Guide for installation
instructions.

e Install wxPython. See the wxPython’s website Getting Started Wiki for installation
instructions. Note that you need to install the version of wxPython to match your
Python version, as indicated on the download page.

35
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e Start Wing from the Start menu on Windows, the Finder or OS X, or by typing
wing3.0 on the command line on Linux other Posix systems. Once Wing has started,
you may want to switch to reading this How-To from the Help menu. This will add
links to the functionality of the application.

e Select Show Analysis Stats from the Source menu and if the Python version re-
ported there doesn’t match the one you're using with wxPython, then select Project
Properties from the Project menu and use the Python Executable field to select
the correct Python version.

e Open the wxPython demo into Wing IDE. This may be located within
your Python installation at site-packages/wx/demo/demo.py, or Lib/site-
packages/wx/demo/demo.py, or c:\Program Files\wxPython2.6 Docs and De-
mos\demo, or similar location. On Linux it may be part of a separate wx exam-
ples package, for example on Ubuntu 6.06 LTS the demo is in the package wx2.6-
examples, is installed in /usr/share/doc/wx2.6-examples/examples/wxPython,
and some files in this directory need to be gunzip‘‘ed before the demo
will work. Once you’ve opened ‘‘demo.py, select Add Current File from the
Project menu. If you can’t find demo.py but have other wxPython code that works,
you can also just use that. However, the rest of this document assumes you're using
demo . py so you will have to adapt the instructions.

e Set demo.py as main entry point for debugging by right clicking on it in the project
panel and selecting Set As Main Debug File.

e Save your project to disk. Use a name ending in .wpr.

Test Driving the Debugger

Now you're ready to try out the debugger. To do this:

Start debugging with the Start / Continue item in the Debug menu. Uncheck the Show
this dialog before each run checkbox at the bottom of the dialog that appears and
select OK.

The demo application will start up. If its main window doesn’t come to front, bring it to
front from your task bar or window manager. Try out the various demos from the tree on
the left of the wxPython demo app.

Important: In earlier wxPython 2.6 versions, a change to the demo code breaks all
debuggers by not setting the co_filename attribute on code objects correctly. To fix this,
change the line that reads description = self.modules[modID] [2] around line 804 in
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demo\main.py to instead read description = self.modules[modID] [3] -- Wing will not
stop at breakpoints until this is done.

Next open ImageBrowser.py (located in the same directory as demo.py) into Wing IDE.
Set a breakpoint on the first line of runTest () by clicking on the dark grey left margin.
Go into the running demo app and select More Dialogs / ImageBrowser. Wing will stop
on your breakpoint.

Select Stack Data from the Tools menu. Look around the stack in the popup at the top of
the window and the locals and globals shown below that for the selected stack frame. You
may see some sluggishness (a few seconds) in displaying values because of the widespread
use of from wx import * in wxPython code, which imports a huge number of symbols
into the globals name space. This depends on the speed of your machine.

Select Debug Probe (Wing Pro only) from the Tools menu. This is an interactive command
prompt that lets you type expressions or even change values in the context of the stack
frame that is selected on the Debugger window when your program is paused or stopped
at an exception. It is a very powerful debugging tool.

Also take a look at these tools available from the Tools menu:

e I/0 -- displays debug process output and processes keyboard input to the
debug process, if any

e Exceptions -- displays exceptions that occur in the debug process
e Modules -- browses data for all modules in sys.modules

e Watch -- watches values selected from other value views (by right-clicking
and selecting one of the Watch items) and allows entering expressions to
evaluate in the current stack frame

Test Driving the Source Browser
Don’t forget to check out Wing’s powerful source browser:

e Add package Lib/site-packages/wx or site-packages/wx inside your Python in-
stallation to your project file with the Add Directory item in the Project menu.

e After doing so, Wing may consume significant CPU for some time, depending on the
speed of your machine. As it does this, you can already bring up the Source Browser
from the Tools menu. Just be patient if things are a bit sluggish at first; there is
an awful lot of Python code that Wing needs to analyse. Once the initial analysis is
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done, Wing will return to being responsive since the results are cached (a similar but
shorter effect is seen when Wing is restarted, as it reads the analysis disk cache).

e Select Browse Project Classes mode at the top of the source browser. This is
generally the best view to use for wxPython. If you duse the Browse Project Mod-
ules view, it helps to select Hide Inherited Classes from the Options menu in
the browser.

e Use the right-click menu to zoom to base classes. In general in Wing, right-clicking
will bring up menus specific to the tool being clicked on.

e Related to the Source Browser is the auto-completion capability in Wing’s source
editor. Try typing in one of the wxPython source files and you will see the auto-
completer appear. Tab completes the currently selected item, but you can add Enter
to the Completion Keys preference to also complete when the Enter key is pressed.
See the Wing IDE Quickstart Guide for information on other commonly used
preferences. Note: Depending on the speed of your machine, the auto-completer
may be sluggish at first, once again due to the large number of symbols imported
into most wxPython files with from wx import *. However, this should only happen
once per Wing IDE session.

e See also the Source Assistant tool in the Tools menu. This provides additional
information about source constructs in the active source editor as the insertion cursor
or selection is moved around. Note that this tool is also integrated with the source
browser, and with the auto-completer in the editor, Python Shell, and Debug Probe
(in Wing Pro).

Using a GUI Builder

Wing IDE doesn’t currently include a GUI builder for wxPython but it can be used with
other tools, such as Boa Constructor, which does provide a GUI builder but doesn’t have
the raw power of Wing IDE’s debugger and source browser.

To use an external GUI builder, configure Wing to automatically reload files that
are altered by the GUI builder. This is done in Preferences in the Files Reloading area.

Then you can run Wing IDE and your GUI builder at the same time, working with both
in an almost seamless manner.

A Caveat: Because Python lends itself so well to writing data-driven code, you may want
to reconsider using a GUI builder for some tasks. In many cases, Python’s introspection
features make it possible to write generic GUI code that you can use to build user interfaces
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on the fly based on models of your data and your application. This can be much more
efficient than using a GUI builder to craft individual menus and dialogs by hand. In general
hand-coded GUIs also tend to be more maintainable.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.

e wxPython Getting Started page, which contains much additional information for
wxPython programmers.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

4.2. Using Wing IDE with PyGTK

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for PyGTK and GTK+, a mature open source GUI development toolkit.

PyGTK is currently available for Linux/Unix, MS Windows, and Mac OS X (requires X11
Server). Like PyQt and unlike wxPython, PyGTK runs on the same (GTK-provided)
widget implementations on all platforms. Themes can be used to approximate the look
and behavior of widgets on the native OS. It is also possible to display native dialogs like
the Windows file and print dialogs along side GTK windows. While PyGTK does not offer
perfect native look and feel, its provides excellent write-once-works-anywhere capability
even in very complex GUIs. Wing IDE is itself written using PyGTK.

Other advantages of PyGTK include: (1) high quality anti-aliased text rendering, (2) pow-
erful signal-based architecture that, among other things, allows subclassing C classes in
Python, (3) multi-font text widget with embeddable sub-widgets, (4) model-view architec-
ture for list and tree widgets, and (5) a rich collection of widgets and stock icons.

While Wing IDE does not currently provide a GUI builder for PyGTK, it does provide
the most advanced debugger and source browser capabilities available for the Python pro-
gramming language and it can be used with other available GUI builders, as described
below.


http://wiki.wxpython.org/index.cgi/Getting_Started
http://wingware.com/wingide
http://www.pygtk.org/
http://www.gtk.org/
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Installation and Configuration

Take the following steps to set up and configure Wing IDE for use with PyGTK:

e Install Python and Wing. See the generic Wing IDE Quickstart Guide for in-

stallation instructions.

Install GTK and PyGTK. If you are on Linux, you may already have one or both in-
stalled, or you may be able to install them using your distribution’s package manager.
Otherwise, check out the gtk website and pygtk website.

Start Wing from the Start menu on Windows, the Finder or OS X, or by typing
wing3.0 on the command line on Linux other Posix systems. Once Wing has started,
you may want to switch to reading this How-To from the Help menu. This will add
links to the functionality of the application.

Select Show Analysis Stats from the Source menu and if the Python version re-
ported there doesn’t match the one you're using with PyGTK, then select Project
Properties from the Project menu and use the Python Executable field to select
the correct Python version.

Add some files to your project, and set the main entry point by right clicking on a
file in the project panel and selecting Set As Main Debug File.

Save your project to disk. Use a name ending in .wpr.

You should now be able to debug your PyGTK application from within Wing. If you
see ImportErrors on the PyGTK modules, you will need to add Python Path in
the Debug tab of Project Properties, accessed from the Project menu.

Auto-completion and Source Assistant

To obtain auto-completion options and call signature information in Wing’s Source As-
sistant, you may need to run a script that converts from PyGTK’s defs files into Python
interface files that Wing’s source analyser can read. This is only necessary if you are
working with PyGTK significantly different than version 2.7.4, because Wing ships with
pre-built interface information for PyGTK 2.7.4. If you do need to build interface files, do
so as follows:


http://www.gtk.org/
http://www.pygtk.org/
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e Download the pygtk to_pi.py script and the PyGTK sources for your version of
PyGTK if you don’t already have them.

e Run as described within the script to produce a *.pi file for each *.so or *.pyd file
in the PyGTK sources.

e Copy these *.pi files into the installed copy of PyGTK, so they sit next to the
compiled *.so or *.pyd extension module file that they describe.

e Wing should now provide auto-completion and Source Assistant information when
you import gtk and type gtk. in the editor.

With newer PyGTK versions, it may be necessary to make modifications to the
pygtk_to_pi.py script to track changes in the nature of the source base.

Using a GUI Builder

Wing IDE doesn’t currently include a GUI builder for PyGTK but it can be used with
other tools, such as glade.

To use an external GUI builder, configure Wing to automatically reload files that
are altered by the GUI builder. This is done in Preferences in the Files / Reloading area.

Then you can run Wing IDE and your GUI builder at the same time, working with both
in an almost seamless manner.

A Caveat: Because Python lends itself so well to writing data-driven code, you may want
to reconsider using a GUI builder for some tasks. In many cases, Python’s introspection
features make it possible to write generic GUI code that you can use to build user interfaces
on the fly based on models of your data and your application. This can be much more
efficient than using a GUI builder to craft individual menus and dialogs by hand. In general
hand-coded GUIs also tend to be more maintainable.

Details and Notes

e Building GTK from sources can be a challenge. Wingware has developed some build
support scripts which we can provide on request. We also have patches that allow
GTK to be relocated after building on Linux/Unix.


http://wingware.com/pub/wingide/contrib/pygtk_to_pi.py
http://pygtk.org/downloads.html
http://glade.gnome.org/
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e Native look and feel on Windows is provided by the gtk-wimp theme. If you plan
to deploy on Windows, you may wish to contact us to obtain our latest performance
patches for GTK on Windows.

Unfortunately not all of our patches have been merged into the current GTK sources,
although we have contributed patches in all cases so they can be retrieved from the source
forge bug tracker as well.

Related Documents

Wing IDE provides many other options and tools. For more information:

e Wing IDE Reference Manual, which describes Wing IDE in detail.

e Wing IDE Quickstart Guide which contains additional basic information about
getting started with Wing IDE.

4.3. Using Wing IDE with PyQt

Wing IDE is an integrated development environment for the Python programming lan-
guage. Wing can be used to speed up the process of writing and debugging code that is
written for the PyQt cross-platform GUI development toolkit.

PyQt is a commercial GUI development environment that runs with native look and feel on
Windows, Linux/Unix, Mac OS, and the Sharp Zaurus. It is also available for free for non-
commercial users on Windows and for open source developers on Linux/Unix. Licensing
is per developer, with no cost for each deployed product (even for commercial products).

While Wing IDE does not currently provide a GUI builder for PyQt, it does provide the
most advanced debugger and source browser capabilities available for the Python program-
ming language and it can be used with other available GUI builders, as described below.

Installation and Configuration

Take the following steps to set up and configure Wing IDE for use with PyQt:


http://gtk-wimp.sourceforge.net/
http://wingware.com/wingide
http://www.riverbankcomputing.co.uk/pyqt/index.php

43

e Install Python and Wing. Check the PyQt download page to make sure you install a
version of Python that will work with the version of PyQt that you use. For example,
PyQt 3.5 worked with any version of Python between 1.5.2 and 2.2.x. The generic
Wing IDE Quickstart Guide provides installation instructions for Wing.

e Install Qt from Trolltech. You will either need to purchase a developer’s licence or
download the non-commercial package for Windows or Linux/Unix. The easiest way
to find the downloads area is to search on “download qt” on their site.

e Install PyQt from the Riverbank PyQt download area.

e Start Wing from the Start menu on Windows, the Finder or OS X, or by typing
wing3.0 on the command line on Linux other Posix systems. Once Wing has started,
you may want to switch to reading this How-To from the Help menu. This will add
links to the functionality of the application.

e Select Show Analysis Stats from the Source menu and if the Python version re-
ported there doesn’t match the one you’re using with PyQt, then select Project
Properties from the Project menu and use the Python Executable field to select
the correct Python version.

e Open PyQt/Examples/widgets.py into Wing IDE (located within your Python in-
stallation) and select Add Current File from the Project menu.

e Set widgets.py as main entry point for debugging by right clicking on it in the
project panel and selecting Set As Main Debug File.

e Save your project to disk. Use a name ending in .wpr.

Test Driving the Debugger

Now you’re ready to try out the debugger. To do this:

e Start debugging with the Start / Continue item in the Debug menu. Uncheck the
Show this dialog before each run checkbox at the bottom of the dialog that
appears and select OK.

e The demo application will start up. If its main window doesn’t come to front, bring
it to front from your task bar or window manager.

e Next open PyQt/Examples/widgets.py (within your Python installation) into Wing
IDE. Set a breakpoint towards the end of AnalogClock’s paintEvent() method.


http://www.riverbankcomputing.co.uk/pyqt/download.php
http://www.trolltech.com/
http://www.riverbankcomputing.co.uk/pyqt/download.php
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During the next clock update, which happens once a minute, Wing IDE will stop at
that point. You can also cause the breakpoint to be reached sooner by obscuring and
then unobscuring the clock with some other window.

e Use the Stack Data tool in the Tools menu to look around the stack and the locals
and globals for the selected stack frame.

e Select Debug Probe (Wing Pro only) from the Tools menu. This is an interactive
command prompt that lets you type expressions or even change values in the context
of the stack frame that is selected on the Debugger window when your program is
paused or stopped at an exception. It is a very powerful debugging tool.

Also take a look at these tools available from the Tools menu:

e I/0 -- displays debug process output and processes keyboard input to the debug
process, if any

e Exceptions -- displays exceptions that occur in the debug process
e Modules -- browses data for all modules in sys.modules

e Watch -- watches values selected from other value views (by right-clicking and select-
ing one of the Watch items) and allows entering expressions to evaluate in the current
stack frame

As you try out the various demos for PyQt, you may sometimes see Wing IDE pause
and report exceptions in the debugger’s Exceptions tool. There are a few bugs in some
versions of PyQt’s demos, so Wing will catch those when the occur.

Test Driving the Source Browser
Don’t forget to check out Wing’s powerful source browser:

e Add package Lib/site-packages or site-packages (inside your Python installa-
tion) to your project with the Add Diretory item in the Project menu. Also add
directory tree PyQt (also inside your Python installation) to your project file with
the Add Directory item in the Project menu.

e Next bring up the Source Browser from the Tools menu. You can select the view
style at the top of the window, to browse by modules, by classes, or only the current
file. The Options menu on the right will filter what types of symbols are being
displayed in the browser.
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e Double clicking on the browser will show the corresponding source code in the source
editor area. Note that files are automatically closed when you browse elsewhere
unless they were already open, edits are made, or you click on the stick pin icon in
the upper right of the editor area to specify that the editor should remain open until
closed explicitly.

e Use the right-click menu on the Source Browser to zoom to base classes. In general,
right-clicking will bring up menus specific to the tool being clicked on.

e Related to the Source Browser is the auto-completion capability in Wing’s source
editor. Try typing in one of the PyQt source files and you will see the auto-completer
appear. Tab completes the currently selected item, but you can set the Completion
Keys preference to also complete when the Enter key is pressed. See the Wing IDE
Quickstart Guide for information on this and other commonly used preferences.

e See also the Source Assistant tool in the Tools menu. This provides additional
information about source constructs in the active source editor as the insertion cursor
or selection is moved around. Note that this tool is also integrated with the source
browser, and with the auto-completer in the editor, Python Shell, and Debug Probe
(in Wing Pro).

Using a GUI Builder

Wing IDE doesn’t currently include a GUI builder for PyQt but it can be used with other
tools, such as Black Adder, which does provide a GUI builder but doesn’t have the raw
power of Wing IDE’s debugger and source browser. Another GUI builder for PyQt is Qt
Designer, which outputs language-independent UT files that can be converted into Python
using PyQt’s pyuic utility.<P>

To use an external GUI builder, configure Wing to automatically reload files that
are altered by the GUI builder. This is done in Preferences in the Files Reloading area.

Then you can run Wing IDE and your GUI builder at the same time, working with both
in an almost seamless manner.

A Caveat: Because Python lends itself so well to writing data-driven code, you may want
to reconsider using a GUI builder for some tasks. In many cases, Python’s introspection
features make it possible to wr