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Introduction
This chapter describes how to install and start using Wing Personal. See also the Quick Start Guide and
Tutorial.

1.1. Product Levels
This manual is for the Wing Personal product level of the Wing family of Python IDEs, which currently
includes Wing Pro, Wing Personal, and Wing 101.

Wing Pro is the full-featured Python IDE for professional programmers. It is a commercial product for sale
on our website, and may be licensed either for Commercial Use or Non-Commercial Use. You may
download Wing Pro for free and then usd it on a 30-day trial period or with a purchased license.

Wing Personal is a simplified Python IDE that contains a subset of the features found in Wing Pro. It is
designed for students, hobbyists, and other users that don't need all the features of Wing Pro. Wing
Personal is free to download and use.

Wing 101 is a heavily scaled back IDE that was designed specifically for teaching entry level computer
science courses. It omits most of the features of Wing Pro and Personal, and is free to download and use.

Wing Pro, Wing Personal, and Wing 101 are independent products and may be installed at the same time
on your system without interfering with each other.

For a list of the features in each product level, see https://wingware.comdownloads

1.2. Supported Platforms
Wing 6 is available for Microsoft Windows, Linux, and Mac OS X.

Windows

Wing runs on Windows 7, Windows 8, and Windows 10 for Intel processors. Earlier versions of Windows
are not supported and will not work.

OS X

Wing runs on Mac OS X 10.7+ as a native application.

Linux

Wing runs on 64-bit Intel Linux versions with glibc version 2.15 or later (such as Ubuntu 12.04+, CentOS
7+, Kali 1.1+, and Fedora 20+).

1.3. Supported Python versions
Wing 6 supports versions 2.5 to 2.7 and 3.2 to 3.6 of Python from python.org, Anaconda, ActivePython,
EPD, Stackless Python, cygwin, MacPorts, Fink, and Homebrew.

OS X and Linux come with Python. On Windows, you will need to install one of the above before using
Wing.

Wing can also be used with alternative Python implementations such as PyPy, IronPython, and Jython,
but the debugger and Python Shell will not work.

Both 32-bit and 64-bit compilations of Python are supported on Windows and OS X. On Linux only 64-bit
Python is supported, but 32-bit Python can be debugged using Wing Pro's remote development feature.

Wing Pro users can also compile Wing's debugger on other operating systems, and against custom
versions of Python (requires NDA).

https://wingware.com/doc/howtos/quickstart
https://wingware.com/doc/intro/tutorial
https://wingware.comdownloads
https://python.org/downloads
https://www.continuum.io/downloads
http://activestate.com/activepython
http://www.enthought.com/products/epd
http://stackless.com/
http://cygwin.com
https://wingware.com/doc/proj/remote-hosts
https://wingware.compub/wingide/support/source-non-discl.pdf


1.4. Technical Support
If you have problems installing or using Wing, please submit a bug report or feedback using the
Submit Bug Report or Submit Feedback items in Wing's Help menu.

Wingware Technical Support can also be contacted by email at support at wingware.com, or online at
https://wingware.comsupport.

Bug reports can also be sent by email to bugs at wingware.com. Please include your OS and product
version number and details of the problem with each report.

If you are submitting a bug report via email, see Obtaining Diagnostic Output for more information on how
to capture a log of Wing and debug process internals. Whenever possible, these should be included with
email-based bug reports.

1.5. Prerequisites for Installation
To run Wing, you will need to obtain and install the following, if not already on your system:

• A downloaded copy of Wing

• A supported version of Python

• A working TCP/IP network configuration (for the debugger; no outside access to the internet is
required)

1.6. Installing Wing
Before installing Wing, be sure that you have installed the necessary prerequisites. If you are upgrading
from a previous version, see Upgrading first.

Note: The installation location for Wing is referred to as WINGHOME. On OS X this is the name of Wing's
.app folder.

Windows

Install Wing by running the downloaded executable. Wing's files are installed by default in
C:\Program Files (x86)\Wing IDE Personal 6.0, but this location may be modified during
installation. Wing will also create a User Settings Directory in the location appropriate for your version of
Windows. This is used to store preferences and other settings.

The Windows installer supports a /silent command line option that uses the default options, including
removing any prior install of version 6.0 of Wing. If a prior install is removed, a dialog with a progress bar
will appear. You can also use a /dir=<dir name> option to specify an alternate installation directory.

Linux

Use the RPM, Debian package, or tar file installer as appropriate for your system type. Installation from
packages is at /usr/lib/wingide-personal6 or at the selected location when installing from the tar
file. Wing will also create a User Settings Directory in ~/.wingpersonal6, which is used to store
preferences and other settings.

For more information, see the Linux installation details.

Mac OS X

On OS X, Wing is installed simply by opening the distributed disk image and dragging to the Applications
folder, and optionally from there to the task bar.

1.7. Running Wing
For a quick introduction to Wing's features, refer to the Quickstart Guide. For a more gentle in-depth start,
see the Wing Tutorial.

On Windows, start Wing from the Program group of the Start menu.

mailto:support@wingware.com
https://wingware.comsupport
mailto:bugs@wingware.com
https://wingware.com/doc/install/trouble-diagnostic
https://wingware.comdownloads
https://wingware.com/doc/install/supported-python-versions
https://wingware.com/doc/install/prerequisites-for-installation
https://wingware.com/doc/install/upgrading
https://wingware.com/doc/install/user-settings-dir
https://wingware.com/doc/install/user-settings-dir
https://wingware.com/doc/install/linux-installation-detail
https://wingware.com/doc/howtos/quickstart
https://wingware.com/doc/intro/tutorial


On Linux/Unix, execute wing-personal6.0 (which is on the PATH by default for RPM and Debian
installs) or execute wing-personal located inside the Wing installation directory.

On Mac OS X, start Wing by double clicking on the app folder.

To run Wing from the command line see Command Line Usage.

1.8. User Settings Directory
The first time you run Wing, it will create your User Settings Directory automatically. This
directory is used to store your license, preferences, default project, history, and other files used internally
by Wing. It also contains any user-defined snippets, scripts, color palettes, syntax colors, file sets, and
shared perspectives.

Wing cannot run without this directory. If it cannot be created, Wing will exit.

The settings directory is created in a location appropriate to your operating system. That location is listed
as your Settings Directory in the About Box accessible from the Help menu.

On Windows the settings directory is called Wing Personal 6 and is placed within the per-user
application data directory. For Windows running on c: with an English localization the location is:

c:\Users\${username}\AppData\Roaming\Wing Personal 6

On Linux and OS X the settings directory is a sub-directory of your home directory:

~/.wingpersonal6

Cache Directory

Wing also creates a Cache Directory that contains the source analysis caches, auto-save directory, and a
few other things. This directory is also listed in Wing's About box, accessed from the Help menu.

On Windows, the cache directory is located in the AppData\Local area. On Linux, it is
~/.cache/wingpersonal6 and on OS X, it can be found with the symbolic link
~/.wingpersonal6/cache-dir-symlink.

Overriding Settings and Cache Directories

The default location of the settings directory can be changed by passing --settings=fullpath on the
command line, where fullpath is the full path of the directory to use. If the directory does not exist it
will be created only if its parent directory exists. Otherwise, Wing falls back to using the default location for
the settings directory.

Similarly, the default location of the cache directory can be changed with --cache=fullpath.

1.9. Upgrading
If you are upgrading within the same minor version number of Wing (for example from 6.0 to 6.x) this will
replace your previous installation. Once you have upgraded, your previous preferences and settings
should remain and you should immediately be able to start using Wing.

If you are upgrading across major releases (for example from 5.1 to 6.0), this will install the new version
along side your old version of Wing.

New major releases of Wing will read and convert any existing Wing preferences, settings, and projects.
Projects should be saved to a new name for use with the new major release since they cannot be read by
earlier versions.

To install an upgrade, follow the steps described in Installing

See also Migrating From Older Versions.

https://wingware.com/doc/install/command-line-usage
https://wingware.com/doc/install/installing
https://wingware.com/doc/install/migrating


1.9.1. Migrating From Older Versions

Moving to Wing 6 from earlier versions should be easy. The first time you start Wing 6, it will automatically
convert your preferences from any older version of Wing and place them into your User Settings Directory.

Wing 6 can be installed and used side by side with older versions of Wing and operates completely
independently. Projects from earlier versions of Wing will be converted and opened as untitled, and should
be saved to a new file name since older versions of Wing cannot open Wing 6 projects.

Licensing

Perpetual licenses for Wing 5 and earlier that are not covered by Support+Upgrades must be upgraded
before they can be activated for Wing 6. This can be done in the online store.

Compatibility Changes in Wing 6

Wing 6 makes some incompatible changes in terms of which Python and OSes versions are supported,
and in some of its feature set.

Suported Python Versions

• Support for Python 3.1 was dropped. Python versions 2.5 through 2.7 and 3.2 through 3.6 are
supported.

• Wing now prefers the latest Python version even if it is Python 3.x

Supported OSes

• Wing no longer runs on older Windows versions. Windows 7 and later are supported.

• Wing no longer runs on OS X 10.6. Versions 10.7+ will work.

• Old Linux distributions have been dropped. Ubuntu 12.04+, CentOS 7+, Kali 1.1+, Fedora 20+, and
other glibc 2.15+ distributions should work.

• Wing no longer runs on 32-bit Linux

• On Linux, Wing can no longer use the native display style due to cross-distribution binary
compatibility issues

Other Compatibility Changes

• Wing Personal is now free and no longer requires a license to operate

• The IDE error-log file in the User Settings Directory has been renamed ide.log

• Wing 6 now runs on PyQt5, which solves some issues on newer OS versions and improves stability
and performance

• The Display Style and Color Palette preferences have been simplified

• The default encoding for the Debug I/O and other tools is now utf-8. An external console can be used
on Windows in order to use the encoding used in a cmd.exe.

• When debugging with wingdbstub, Wing 6 will not work with the Wing 5 debugger

• Host identity is now computed differently, which may affect when Wing accepts a previous license
activation (please email support@wingware.com with any problems)

• Renamed the preference Allow Dynamic Introspection to Allow Calls in Data Inspection

• The pypath attrib returned from CAPIProject.GetLaunchAttrib in the scripting API has changed from
a string with os.pathsep delimiter to a list of strings so this can handle the remote debugging case

• Leading/trailing white space is now stripped from file names entered into preferences or project/file
properties, including also Python Path entries

• Wing now uses a more compact default output for 'hg annotate'

• Active Range no longer shows code lines in the shell and instead points at exceptions in the editor

https://wingware.com/doc/install/user-settings-dir
https://wingware.comstore/upgrade
mailto:support@wingware.com


• Wing no longer inherits DYLD_LIBRARY_PATH in its environment on OS X, although the inherited
value is still used for code debugged or executed from the IDE

1.9.2. Fixing a Failed Upgrade

In rare cases upgrading may fail to overwrite old files, resulting in random or bizarre behaviors and
crashing. The fix for this problem is to completely uninstall Wing and manually remove remaining files
before installing the upgrade again.

If this does not solve the problem, try moving aside the User Settings Directory and then starting Wing. If
this works, try restoring files from the old user settings directory one by one to find the problem. Key files
to try are license.act*, preferences and recent*. Then submit a bug report to
support@wingware.com with the offending file.

1.10. Installation Details and Options
This section provides some additional detail for installing Wing and describes installation options for
advanced users.

1.10.1. Linux Installation Notes

On Linux, Wing can be installed from RPM, Debian package, or from tar archive. Use the latter if you do
not have root access on your machine or wish to install Wing somewhere other than
/usr/lib/wingide-personal6. Only 64-bit Linux is supported, although in Wing Pro remote
development can be used to develop on a 32-bit host.

Installing Wingware's Public Key

Some systems will complain when you try to install Wing without first installing our public key into your key
repository. The key is available here. Copy and paste the key into a file wingware.pub and then use the
following to import the key.

For RPM systems:

sudo rpm --import wingware.pub

For Debian systems:

sudo apt-key add wingware.pub

An alternative is just to bypass the key check with --nogpg command line option for rpm,
--nogpgcheck for yum, and --no-debsig for dpkg.

Installing from RPM:

Wing can be installed from an RPM package on RPM-based systems, such as RedHat and Mandriva. To
install, run rpm -i wingide-personal6-6.0.6-1.amd64.rpm as root or use your favorite RPM
administration tool to install the RPM. Most files for Wing are placed under the
/usr/lib/wingide-personal6 directory and the wing-personal6.0 command is placed in the
/usr/bin directory.

Installing from Debian package:

Wing can be installed from a Debian package on Debian, Ubuntu, and other Debian-based systems.

To install, run dpkg -i wingide-personal6_6.0.6-1_amd64.deb

as root or use your favorite package administration tool to install. Most files for Wing are placed under the
/usr/lib/wingide-personal6 directory and the wing-personal6.0 command is placed in the
/usr/bin directory.

https://wingware.com/doc/install/removing-wing
https://wingware.com/doc/install/user-settings-dir
https://wingware.com/doc/proj/remote-hosts
https://wingware.com/doc/proj/remote-hosts
https://wingware.com/pgpkey


It may be necessary to install some dependencies before the installation will complete, as requested by
dpkg. The easiest way to do this is sudo apt-get -f install -- this installs the missing
dependencies and completes the configuration step for Wing's package.

Installing from Tar Archive:

Wing may also be installed from a tar archive. This can be used on systems that do not use RPM or
Debian packages, or if you wish to install Wing into a directory other than
/usr/lib/wingide-personal6. Unpacking this archive with
tar -zxvf wingide-personal-6.0.6-1-amd64-linux.tar.gz will create a
wingide-personal-6.0.6-1-amd64-linux directory that contains the wing-install.py script
and a binary-package.tar file.

Running the wing-install.py script will prompt for the location to install Wing, and the location in
which to place the executable wing-personal6.0. These locations default to
/usr/local/lib/wingide-personal and /usr/local/bin, respectively. The install program must
have read/write access to both of these directories, and all users running Wing must have read access to
both.

1.10.2. Remote Display on Linux

Wing for Linux can be displayed remotely by enabling X11 forwarding in ssh as described here.

In summary: You need to send the -X option to ssh when you connect from the machine where you want
windows to display to the machine where Wing will be running, and you need to add
X11Forwarding yes to your ssh configuration (usually in ~/.ssh/config) on the machine where
Wing will be running.

Speeding up the Connection

To improve performance, in most cases you should leave off the -C option for ssh, even though it is often
mentioned in instructions for setting up X11 forwarding. The compression that is enabled with -C is only
useful over extremely slow connections and otherwise increases latency and reduces responsiveness of
the GUI.

Another option to try is -Y (trusted X11 port forwarding) instead of -X (untrusted X11 port forwarding) as
this may reduce overhead as well. However, this disables security options so it's a good idea to
understand what it does before using it.

If you are displaying to Windows, the choice of X11 server software running on Windows can make a
huge difference in performance. If the GUI seems very slow, try a different X11 server.

Other Options

Other options for displaying Wing remotely from Linux include:

• XRDP -- implements the protocol for Windows Remote Desktop.

• NoMachine -- Another free remote desktop toolkit.

1.10.3. Installing Extra Documentation

On Windows, Wing looks for local copies of Python documentation in the Doc directory of the Python
installation(s), either in CHM or HTML format.

If you are using Linux or OS X, the Python manual is not included in most Python installations, so you may
wish to download and install local copies.

To do this, place the top-level of the HTML formatted Python manual (where index.html is found) into
python-manual/#.# within your Wing installation. Replace #.# with the major and minor version of the
corresponding Python interpreter (for example, for the Python 2.7.x manual, use python-manual/2.7).

Once this is done, Wing will use the local disk copy rather than going to the web when the Python Manual
item is selected from the Help menu.

https://unix.stackexchange.com/questions/12755/how-to-forward-x-over-ssh-from-ubuntu-machine
http://www.xrdp.org/
https://www.nomachine.com/
https://docs.python.org/download.html


1.11. Backing Up and Sharing Settings
To back up your license, preferences, and other settings, you only need to back up the Settings Directory,
which is listed in Wing's About box, accessed from the Help menu.

The process of restoring Wing or moving to a new machine consists simply of installing Wing again,
restoring the above directory, and (in Wing Pro) reactivating your license if necessary.

The only other Wing-specific data that the IDE will write to your disk is in your project files (*.wpr).

Wing also writes to a cache directory (also listed in the About box) and your OS-provided temporary
directory, but those can be recreated from scratch if it is lost. The only possible exception to this is
autosave in the cache directory, which contains unsaved files open in the IDE.

For more information on the location of these directories, see User Settings Directory.

Sharing Settings

Many of the settings found in the User Settings Directory can be shared to other machines or with other
users of Wing. This includes the following files and directories:

• filesets -- shared file sets used for selecting files to search or include in the project.

• launch -- shared launch configurations used for defining environment for debugging and executing
code.

• palettes -- any user-defined color palettes used for configuring the user interface.

• perspectives -- shared perspectives which store particular configurations of tools and editors.

• preferences -- Wing's preferences, as configured in the Preferences dialog.

• pylintpanel.cfg -- the configuration for the PyLint tool.

• recent* -- lists of recent files, projects, commands, and so forth.

• scripts -- scripts that extend IDE functionality.

• syntax -- user-defined syntax colors for file types available in the editor.

Follow the links above to find details on the file formats involved. Most are simple textual formats that are
easy to generate or modify if necessary. Wing does need to be restarted when replacing these files, and
may overwrite changes made while it is running.

1.12. Removing Wing
Windows

On Windows, use the Add/Remove Programs control panel, select Wing IDE Personal 6 and remove
it.

Linux/Unix

To remove an RPM installation on Linux, type rpm -e wingide-personal6.

To remove an Debian package installation on Linux, type dpkg -r wingide-personal6.

To remove a tar archive installation on Linux/Unix, invoke the wing-uninstall script in the install
directory listed in Wing's About box. This will automatically remove all files that appear not to have been
changed since installation. It will ask whether it should remove any files that appear to be changed.

Mac OS X

To remove Wing from Mac OS X, just drag its application folder to the trash.

User Settings

You may also want to remove the User Settings directory and cache directories if you don't plan to use
Wing again on your system.
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1.13. Command Line Usage
You can run Wing from the command line as follows:

On Windows, the executable is called wing-personal.exe and is located in the bin directory in your
Wing installation. This is not on the PATH by default, but may be added with the Windows Control Panel.
On Linux, the executable is called wing-personal6.0 and is already on the PATH as long as Wing
was installed from Debian or RPM package. Otherwise, the executable is wing-personal in the
installation directory. On OS X, the executable is called wing-personal and is located in
Contents/Resources within the .app bundle directory. This is not on the PATH by default, but could
be added either by adding that directory to PATH in ~/.profile (for example,
PATH="/Applications/WingPersonal.app/Contents/Resources:${PATH}"; export PATH)
or by placing a symbolic link (for example, by typing sudo ln -s
/Applications/WingPersonal.app/Contents/Resources/wing-personal
wing-personal6.0 in a directory that is already on the PATH).

Opening Files and Projects

Once you have established a way to start Wing from the command line, you may specify a list of files to
open after the executable name. These can be arbitrary text files and a project file. For example, the
following will open project file myproject.wpr and also the three source files mysource.py, README,
and Makefile:

wing-personal.exe mysource.py README Makefile myproject.wpr

Wing determines file type by extension, so position of the project file name (if any) on the command line is
not important.

A line number may be specified for the first file on the command line by appending :<line-number> to
the file name. For example, README:100 will position the cursor at the start of line 100 of the README
file.

Command Line Options

The following valid options may be specified anywhere on the command line:

--prefs-file -- Add the file name following this argument to the list of preferences files that are opened by
the IDE. These files are opened after the system-wide and default user preferences files, so values in
them override those given in other preferences files.

--new -- By default Wing will reuse an existing running instance of Wing to open files specified on the
command line. This option turns off this behavior and forces creation of a new instance of Wing. Note that
a new instance is always created if no files are given on the command line.

--reuse -- Force Wing to reuse an existing running instance of Wing IDE even if there are no file names
given on the command line. This just brings Wing to the front.

--settings=fullpath -- Use the given fullpath instead of the default location for the User Settings Directory.

--cache=fullpath -- Use the given fullpath instead of the default location for the cache directory.

--verbose -- (Posix only) This option causes Wing to print verbose error reporting output to stderr. On
Windows, run console_wing.exe instead for the same result.

--use-winghome -- (For developers only) This option sets WINGHOME to be used during this run. It is
used internally and by developers contributing to Wing. The directory to use follows this argument.

--use-src -- (For developers only) This option is used to force Wing to run from Python source files even if
compiled files are present in the bin directory, as is the case after a distribution has been built.

--orig-python-path -- (For developers only) This option is used internally to indicate the original Python
path in use by the user before Wing was launched. The path follows this argument.
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--squelch-output -- (For developers only) This option prevents any output of any kind to stdout and
stderr. Used on Windows to avoid console creation.

Customization
There are many ways to customize Wing in order to adapt it to your needs or preferences. This chapter
describes the options that are available to you.

Note

These are some of the areas of customization that are available:

• The editor can run with different personalities such as VI/Vim, Emacs, Visual Studio, Eclipse,
and Brief emulation

• The action of the tab key can be configured

• The auto-completer's completion keys can be altered

• The layout, look, color, and content of the IDE windows can be configured

• Editor syntax colors can be configured

• Keyboard shortcuts can be added, removed, or altered for any Wing command

• Perspectives can be used to save and restore user interface state

• File filters can be defined to control some of the IDE features

• Many other options are available through preferences

2.1. Keyboard Personalities
The default keyboard personality for Wing implements most common keyboard equivalents found in a
many text editors.

Note

Before doing anything else, you may want to set Wing's keyboard personality to emulate another
editor, such as vi, emacs, Visual Studio, Eclipse, XCode, or Brief. This is done with the
Edit > Keyboard Personality menu or with the User Interface > Keyboard >
Personality preference.

Under the VI/Vim and Emacs personalities, key strokes can be used to control most of the editor's
functionality, using a textual interaction 'mini-buffer' at the bottom of the IDE window where the current line
number and other informational messages are normally displayed.

Other preferences that alter keyboard behaviors include Tab Key Action and Completion Keys for
the auto-completer.

In Wing Pro and Wing Personal it is also possible to add, alter, or remove individual keyboard command
mappings within each of these personalities. See the following sub-sections for details.



2.1.1. Key Equivalents

The command a key will invoke may be modified by specifying a custom key binding. A custom key
binding will override any binding for a particular key found in the keymap. Custom key bindings are set via
the Custom Key Bindings preference.

To add a binding, click the insert button, then press the key to be bound in the Key field, and enter the
name of the command to invoke in the Command field. Commands are documented in the Command
Reference.

Key bindings may consist of multiple key strokes in a row, such as Ctrl-X Ctrl-U or Esc X Y Z.
Also, multiple modifiers may be pressed. Ctrl-Shift-X is distinct from Ctrl-X.

If multiple comma-separated commands are specified, the key binding will execute the first available
command in the listed. For example, specifying debug-restart, debug-continue as the command
will first try to restart an existing debug session, and if no debug session exists it will start a new one.

To disable a key binding, leave the command field blank.

Some commands take arguments, which can be specified in the binding, for example by using
show-panel(panel_type="debug-probe") or
enclose(start="(", end=")")``in the ``Command field. Any unspecified arguments that do not
have a default defined by the command will be collected from the user, either in a dialog or in the data
entry area at the bottom of the IDE window.

Key bindings defined by default or overridden by this preference will be shown in any menu items that
implement the same command. In cases where a command is given more than one key equivalent, only
the last equivalent found will be displayed (although both bindings will work from the keyboard).

2.1.2. Key Maps

Wing ships with several keyboard maps found at the top level of the Wing IDE installation, including
keymap.normal, keymap.emacs, keymap.vi, and others. These are used as default key maps for the
corresponding editor personalities, as set with the
User Interface > Keyboard > Keyboard Personality preference.

In order to develop an entirely new key binding, or in other cases where the Custom Key Bindings
preference is not sufficient, it is possible to create a custom key map and use it as your default map
through the Key Map File preference.

In a key map file, each key equivalent is built from names listed in the Key Names section. These names
can be combined as follows:

1. A single unmodified key is specified by its name alone, for example 'Down' for the down arrow key.

2. Modified keys are specified by hyphenating the key names, for example 'Shift-Down' for the
down arrow key pushed while shift is held down. Multiple modifiers may also be specified, as in
'Ctrl-Shift-Down'.

3. Special modifiers are defined for Vim mode: Visual, Browse, Insert, and Replace. These
correspond with the different editor modes, and will only work if the Keyboard Personality preference
has been set to VI/Vim.

4. Multi-key combinations can be specified by listing multiple key names separated by a space. For
example, to define a key equivalent that consists of first pushing ctrl-x and then pushing the a key by
itself, use 'ctrl-x a' as the key sequence.

The command portion of the key equivalency definition may be any of the commands listed in section
Command Reference. See the examples below for usage options.

Examples

Here is an example of adding a key binding for a command. If the command already has a default key
binding, both bindings will work:
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'Ctrl-X P': 'debug-attach'

This example removes a key equivalent entirely:

'Ctrl-C Ctrl-C': None

These can be combined to changes the key binding for a command without retaining its default key
binding:

'Ctrl-C Ctrl-C': None
'Ctrl-G': 'debug-continue'

Wing always retains only the last key binding for a given key combination. This example binds Ctrl-X to
'quit' and no other command:

'Ctrl-X': 'debug-stop'
'Ctrl-X': 'quit'

If multiple commands are specified separated by commas, Wing executes the first command that is
available. For example, the following will either restart the debug process whether or not one is currently
running:

'Ctrl-X': 'debug-restart, debug-continue'

Command arguments can be specified as part of the binding. Any unspecified arguments that do not have
a default will be collected from the user in a dialog or in the data entry area at the bottom of the IDE
window:

'Ctrl-X P': 'show-panel(panel_type="debug-probe")'

If Keyboard Personality is set to VI/Vim, modifiers corresponding to the editor modes restrict availability of
the binding to only that mode:

'Visual-Ctrl-X': 'cut'

2.1.3. Key Names

The best way to obtain the names of keys is to enter a new key binding in the User Interface > Keyboard >
Custom Key Bindings. preference. Alternatively, refer to the following enumeration of all supported
keys.

Key modifiers supported by Wing for key bindings are:

• Ctrl -- Either Control key.

• Shift -- Either Shift key. This modifier is ignored with some key names, as indicated below.

• Alt -- Either Alt key. Not recommended for general use since these bindings tend to conflict with
accelerators and operating system or window manager operations.

• Command -- Macintosh Command/Apple key. This may be mapped to other keys on other systems,
but is intended for use on the Macintosh.

On Linux it is possible to remap the function of the Control, Alt, command, and windows keys. In those
cases, the Ctrl and Alt modifiers will refer to the keys specified in that mapping.

Basic Keys such as the digit keys and core western alphabet keys are specified as follows:
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Most punctuation can be specified but any Shift modifier will be ignored since these keys can vary in
location on different international keyboards. Allowed punctuation includes:

` ~ ! @ # $ % ^ & * ( ) - _ + = [ ] { } \ | ; : ' " / ? . > , <

Special Keys can also be used:

Escape, Space, BackSpace, Tab, Linefeed, Clear, Return, Pause, Scroll_Lock, Sys_Req, Delete, Home,
Left, Up, Right, Down, Prior, Page_Up, Next, Page_Down, End, Begin, Select, Print, Execute, Insert,
Undo, Redo, Menu, Find, Cancel, Help, Break, Mode_switch, script_switch, Num_Lock,

F1, F2, F3, F4, F5, F6, F7, F8, F9, F10, F11, L1, F12, L2, F13, L3, F14, L4, F15, L5, F16, L6, F17, L7,
F18, L8, F19, L9, F20, L10, F21, R1, F22, R2, F23, R3, F24, R4, F25, R5, F26, R6, F27, R7, F28, R8,
F29, R9, F30, R10, F31, R11, F32, R12, F33, R13, F34, R14, F35, R15,

Additional Key Names that also work but ignore the Shift modifier since they tend to appear in different
locations on international keyboards:

AE, Aacute, Acircumflex, Adiaeresis, Agrave, Ampersand, Any, Apostrophe, Aring, AsciiCircum,
AsciiTilde, Asterisk, At, Atilde, Backslash, Bar, BraceLeft, BraceRight, BracketLeft, BracketRight, Ccedilla,
Colon, Comma, Dollar, ETH, Eacute, Ecircumflex, Ediaeresis, Egrave, Equal, Exclam, Greater, Iacute,
Icircumflex, Idiaeresis, Igrave, Less, Minus, Ntilde, NumberSign, Oacute, Ocircumflex, Odiaeresis,
Ograve, Ooblique, Otilde, ParenLeft, ParenRight, Percent, Period, Plus, Question, QuoteDbl, QuoteLeft,
Semicolon, Slash, Space, THORN, Uacute, Ucircumflex, Udiaeresis, Ugrave, Underscore, Yacute, acute,
brokenbar, cedilla, cent, copyright, currency, degree, diaeresis, division, exclamdown, guillemotleft,
guillemotright, hyphen, macron, masculine, mu, multiply, nobreakspace, notsign, onehalf, onequarter,
onesuperior, ordfeminine, paragraph, periodcentered, plusminus, questiondown, registered, section,
ssharp, sterling, threequarters, threesuperior, twosuperior, ydiaeresis, yen

2.2. User Interface Options
Wing provides many options for customizing the user interface to your needs. Preferences can be set to
control display style and colors, the number and type of windows, layout of tools and editors, text fonts
and colors, and type of toolbar.

2.2.1. Display Style and Colors

By default Wing runs with native look and feel for each OS (except on Linux where Wing cannot use the
system-provided UI), and with a classic white background style for the editor.

Editor Color Configuration

The colors used in the user interface are selected with the Editor Color Palette preference. This
affects editor background color and the color of markers on text such as the selection, debug run marker,
caret line highlight, bookmarks, diff/merge annotations, and other configurable colors. Palettes also define
20 additional colors that appear in preferences menus that are used for selecting colors.

The defaults set by the color palette preference can be overridden on a value by value basis in
preferences. For example, the Text Selection Color preference is used to change the text selection
color to a value other than the one specified in the selected color palette. Each such preference allows
selection of a color from the current color palette, or selection of any color from a color chooser dialog.

In Wing Pro and Wing Personal, the colors used for syntax highlighting code in the editor can be
configured separately, as described in Custom Syntax Coloring.

UI Color Configuration

To apply the editor color palette also to the UI outside of the editor, enable the
Use Color Palette Throughout the UI preference.
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Add Color Palettes

Additional color palettes can be defined and stored in the palettes sub-directory of the user settings
directory. This directory must be created if it does not already exist. Example palettes are included in your
Wing installation in resources/palettes. After adding a palette in this way, Wing must be restarted
before it is available for use.

2.2.2. Windowing Policies

Wing can run in a variety of windowing modes. This is controlled by the Windowing Policy preference,
which provides the following options:

• Combined Toolbox and Editor Windows -- This is the default, in which Wing opens a single
window that combines the editor area with two toolbox panels.

• Separate Toolbox Windows -- In this mode, Wing moves all the tools out to a separate shared
window.

• One Window Per Editor -- In this mode, Wing creates one top-level window for each editor that is
opened. Additionally, all tools are moved out to a separate shared toolbox window and the toolbar
and menu are moved out to a shared toolbar/menu window.

The windowing policy is used to describe the initial configuration and basic action of windows in the IDE.
When it is changed, Wing will reconfigure your projects to match the windowing policy the first time they
are used with the new setting.

However, in Wing Pro and Wing Personal, it is possible to create additional IDE windows and to move
editors and tools out to another window or among existing windows without changing from the default
windowing policy. This is described below.

2.2.3. User Interface Layout

When working in the default windowing policy, Wing's main user interface area consists of two toolboxes
(by default at bottom and right) and an area for source editors and integrated help.

Clicking on an already-active toolbox tab will cause Wing to minimize the entire panel so that only the
toolbox tabs are visible. Clicking again will return the toolbox to its former size. The F1 and F2 keys toggle
between these modes. The command Maximize Editor Area in the Tools menu (Shift-F2) can also
be used to quickly hide both tool areas and toolbar.

In other windowing modes, the toolboxes and editor area are presented in separate windows but share
many of the configuration options described below.

Configuring the Toolbar

Wing's toolbar can be configured by altering the size and style of the toolbar icons in the toolbar, and
whether or not text is shown in addition to or instead of icons. This is controlled with the
Toolbar Icon Size and Toolbar Icon Style preferences.

Alternatively, the toolbar can be hidden completely with the Show Toolbar preference.

Configuring the Editor Area

The options drop down menu in the top right of the editor area allows for splitting and joining the editor
into multiple independent panels. These can be arranged horizontally, vertically, or any combination
thereof. When multiple splits are shown, all the open files within the window are available within each split,
allowing work on any combination of files and/or different parts of the same file.

The options drop down menu can also be used to change between tabbed editors and editors that show a
popup menu for selecting among files (the latter can be easier to manage with large number of files) and
to move editors out to a separate window or among existing windows when multiple windows are open.

Configuring Toolboxes

The number of tool box splits Wing shows by default depends on your monitor size. Each of the toolboxes 
can be split or joined into any number of splits along the long axis of the toolbox by clicking on the options
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drop down icon in the tab area of the toolbox and selecting Add Toolbox Split or
Remove Toolbox Split. This menu is also accessible by right-clicking on the tool tabs.

Toolbox splits can also be added or removed by dragging tools around by their tabs, either within each
toolbox, to a different toolbox, or out to a new window. The size of splits is changed by dragging the
divider between them.

In Wing Pro and Wing Personal, the options drop down or right-click menu can also be used to insert or
duplicate tools, and to move them around among splits or out to separate windows.

The toolboxes as a whole (including all their tools) can be moved to the left or top of the IDE window with
Move to Left or Move to Top in the options dropdown or right click menu. Individual splits or the
whole toolbox can also be moved out to a new window from here.

All the available tools are enumerated in the Tools menu, which will display the most recently used tool of
that type or will add one to your window at its default location, if none is already present.

Creating Additional Windows

In addition to moving existing editors or tools to new windows, in Wing Pro and Wing Personal it is also
possible to create new tool windows (initially with a single tool) and new document windows (with editor
and toolbars if applicable to the selected windowing policy) from the Windows menu.

Wing will remember the state of windows as part of your project file, so the same window layout and
contents will be restored in subsequent work sessions.

2.2.4. Altering Text Display

Wing tries to find display fonts appropriate for each system on which it runs, but many users will want to
customize the font style and size used in the editor and other user interface areas. This can be done with
the Source Code Font/Size and Display Font/Size preferences.

For information on altering colors used for syntax highlighting in the editor, see Custom Syntax Coloring.

2.3. Preferences
Wing has many preferences that control features of the editor, unit tester, debugger, source browser,
project manager, and other tools (some of which are available only in Wing Personal or Wing Pro)

To alter these, use the Preferences item in the Edit menu (or WingPersonal menu on OS X). This
organizes all available preferences by category and provides access to documentation in tooltips that are
displayed when mousing over the label area to the left of each preference. Any non-default values that are
selected through the Preferences Dialog are stored in the user's preferences file, which is located in
the User Settings Directory.

All preferences are documented in the Preferences Reference.

2.4. Custom Syntax Coloring
There are two ways to configure syntax highlighting in Wing: Minor adjustments can be made in
preferences, and comprehensive configuration can be achieved by creating a syntax color specification
file.

Minor Adjustments

For minor tweaks to syntax coloring in the editor, use Syntax Formatting in the
Edit > Syntax Coloring preference group. For each supported file type, and each lexical state for
the file type, it is possible to set the foreground and background colors, to use bold or italic font, and to fill
the end of line character so it appears as a solid block of color.
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Comprehensive Changes

For more comprehensive changes to syntax coloring, textual syntax coloring specifications can be placed
into a directory called syntax within the User Settings Directory. This directory must be created if it is not
already present.

Your custom syntax coloring configuration files can be modeled on the system-wide defaults, which are
stored in resources/syntax within the install directory listed in Wing's About box. Copy only the files
you intend to edit. Any values missing from these files cause Wing to fall back to the system-wide
defaults.

Wing must be restarted to pick up changes made in these files. To make this easier to do while working
on syntax color configurations, bind a key to the command restart-wing or right-click on the toolbar to
add an icon for this command.

Overriding Preferences

Note that any non-default syntax coloring preferences will take precedence over syntax files found in the
user settings directory or system-wide. So if you have previously set syntax colors in preferences, you will
need to undo those settings. One way to do this is to edit the preferences file in your User Settings
Directory and remove the value for edit.syntax-formatting. You'll need to do this when Wing is not
running, or edit a copy of the file in Wing and move it into place while Wing is not running.

Color Palette-Specific Configuration

To override syntax colors only for one particular Color Palette, place the syntax file in a sub-directory
of the syntax directory whose name matches the palette specification file name. For example, use
syntax/black-background/python.stx to specify colors to use in Python files only with the Black
Background color palette.

Print-Only Colors

To override syntax colors for printing only, place the syntax file in a print sub-directory of the syntax
directory. For example, use syntax/print/python.stx to specify colors to use in Python files when
printing.

Automatic Color Adjustment

If the currently selected Color Palette uses a non-white background for the editor, or if the
Background Color in the Editor > Syntax Coloring preference group is set to a color other
than white, then Wing will automatically adjust all configured foreground colors when necessary to ensure
that the text remains visible. This avoids the need to create completely new color configurations for
different editor background colors.

This feature applies both to colors set in preferences and colors in a *.stx file. However, automatic
color adjustment is disabled when using a palette-specific syntax configuration file, as describe above,
since in that case the colors are being designed for a specific background color.

Color Names for Python

The syntax color names shown in preferences and the *.stx files vary by file type. For Python they are
defined as follows:

• default -- any text that is not covered by the following

• commentline -- a comment starting with a single #

• number -- any integer, float, binary, octal, or hexadecimal number

• string -- a string with double quotes "like this"

• character -- a string with single quotes 'like this'

• word -- any Python keyword, like if, else, for, try, etc.
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• triple -- a triple quoted string with single quotes '''like this'''

• tripledouble -- a triple quoted string with double quotes """like this"""

• classname -- the name of a class when just after the keyword class

• defname -- the name of a function or method when just after the keyword def

• operator -- any operator, like +, -, /, ==, and so forth

• identifier -- any variable including function or class names if not at point of definition

• commentblock -- a comment starting with ##

• stringeol -- indicates an unterminated string

• word2 -- any Python builtin like open, file, ord, int, isinstance, and so forth

• decorator -- a function, method, or class decorator starting with @

• fstring -- a double-quoted f-string f"like this"

• fcharacter -- a single-quoted f-string f'like this'

• ftriple -- a triple quoted f-string with single quotes f'''like this'''

• ftripledouble -- a triple quoted f-string with double quotes f"""like this"""

2.5. Perspectives
Wing Pro and Wing Personal allow you to create and switch between subsets of the IDE's tools, as
appropriate for particular kinds of work, such as editing, testing, debugging, working on documentation,
and so forth.

These subsets, or perspectives, are named and then accessed from the Tools menu, which provides a
sub-menu for switching between them. The current perspective is shown in brackets in the lower left of
Wing's window.

Perspective Manager

The Tools menu also contains an item for displaying the Perspective Manager. The Perspective
Manager shows the name of each perspective, whether or not the perspective is shared, whether or not
the perspective is auto-saved, the perspective style, and the key binding (if any) that is assigned to it.

The name of a perspective can be changed by clicking on the name within the list and editing it in place.

When perspectives are shared, they are stored in the shared perspectives file, which is configured with
the Shared Perspective File preference, instead of in the project file. This makes the shared
perspectives available across all projects, or potentially to multiple users. When multiple instances of Wing
share this file, Wing will watch for changes and auto-reload the set of perspectives into each instance of
Wing, as another instance makes changes. Note that when a shared perspective is un-shared, it is moved
into the project currently open in the instance of Wing that un-shared it.

When the Auto-save Perspectives is set to Configured by Perspective, the Perspective
Manager will include a column to specify whether the perspective should be auto-saved before
transitioning to another perspective. This is described in more detail below.

The perspective style can be used to control how much state is stored in the perspective: By default Wing
stores only the overall layout of the GUI and set of tools present. Setting this to "Tools and Editors" will
cause the perspective to control also which editors are open. Setting it to "All Visual State" will store also
the detailed state of the tools and editors, including scroll position, selection, search strings, tree
expansion states, and so forth.

When a key binding is defined, that key sequence will cause Wing to switch to the associated perspective.

Perspective Manager Context Menu

The Perspective Manager provides the following functionality in its context (right-click) menu:



• New creates a new untitled perspective with the current state of the application.

• Duplicate makes a copy of the selected perspective, including its stored application state.

• Delete removes the selected perspective.

• Set Key Binding displays a dialog in which the key binding desired for the perspective can be typed.
This key sequence will cause Wing to switch to that perspective.

• Update with Current State replaces the stored state for the selected perspective with the current
application state.

• Restore Saved State loads the state stored in the selected perspective without making that
perspective current.

Preferences

The Perspective Manager's Configure button displays the preferences that control how perspectives
work. These include:

• Auto-save Perspectives -- Selects when the current GUI state should be auto-saved into a
perspective before switching to another perspective. Always will always auto-save all perspectives,
Never disables auto-save entirely, Prompt causes Wing to prompt each time when leaving a
perspective, and Configured by Perspective allows the behavior to be controlled for each
perspective, in the Manage Perspectives dialog. The default is Always so that the last application
state is always restored when returning to the perspective. Disabling auto-save can be useful for
perspectives that should always start with a previously stored fixed state.

• Shared Perspective File -- This is used to specify where shared perspectives are stored on
disk. The default is a file perspectives in the User Settings Directory.

Auto-Perspectives

Auto-perspectives can be used to automatically switch between the built-in perspectives edit and
debug when debugging is started and stopped. When this is enabled, Wing by default will show fewer
tools when editing and most of the debugging tools only while debugging. If the user alters which tools are
shown from the defaults, this will be remembered the next time debug is started or stopped.

Auto-perspectives are off by default and can be turned on with the Automatic Perspectives attribute
under the Debug tab in Project Properties.

Once this is enabled, Wing will save the unnamed pre-existing perspective as user and will display the
appropriate perspective edit or debug with its default tool set. Note that the perspectives edit and
debug are not created until the first time debugging is started. After that, they appear in the
Goto Perspective sub-menu in the Tools menu and in the perspective manager.

Restoring Default Toolset

In Wing Pro, the Tools menu item Restore Default Toolset will restore the tools appropriate for
the current perspective. If this is any of the built-in perspectives edit, debug, or diff and the
Automatic Perspectives preference is turned on, then the tool set will differ from that which is used
for user-defined perspectives or when automatic perspectives are disabled.

2.6. File Filters
Wing allows you to define file filters that can be used in various ways within the IDE, such as for searching
particular batches of files and adding only certain kinds of files to a project.

To view or alter the defined file filters, use File Filters in the Files > File Types preferences
group.

When adding or editing a filter, the following information may be entered:

• Name -- The name of the filter

• Includes -- A list of inclusion criteria, each of which contains a type and a specification. A file will be
included by the filter if any one of these include criteria matches the file.
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• Excludes -- A list of exclusion criteria, any of which can match to cause a file to be excluded by the
filter even if one or more includes also matched.

The following types of include and exclude criteria are supported:

• Wildcard on Filename -- The specification in this case is a wildcard that must match the file name.
The wildcards supported are those provided by Python's fnmatch module.

• Wildcard on Directory Name -- The specification in this case is a wildcard that must match the
directory name.

• Mime Type -- The specification in this case names a MIME type supported by Wing. If additional file
extensions need to be mapped to a MIME type, use the Extra File Types preference to define
them.

Once defined, filters are presented by name in the Search in Files tool's Filter menu, and in the Project
tool's Directory Properties.

Any problems encountered in using the file filters are reported in the Messages area.

Project Manager
The Project manager provides a convenient index of the files in your software project and collects
information needed by Wing's debugger, source code analysis tools, version control integration, and other
facilities.

To get the most out of Wing's debugger and source analysis engine, you may in some cases need to set
up Python Executable, Python Path, and other values in Project-Wide Properties and/or Per-File
Properties.

3.1. Creating a Project
To create a new project, use the New Project item in the Project menu. This will prompt you to save
any changes to your currently open project and will create a new untitled project.

When you create a new project, you will often want to alter some of the Project Properties to point Wing at
the version of Python you want to use, set PYTHONPATH so Wing's source analyzer and debugger can
find your files, and set any other necessary runtime environment for your code.

To add files to your project, use the following items in the Project menu:

• Add Existing Directory allows you to specify a directory to include in the project. In many cases,
this is the only operation needed to set up a new project, and it is the recommended approach. You
will be able to specify a filter of which files to include, whether to include hidden & temporary files,
and whether to include subdirectories. The list of files in the project will be updated as files matching
the criteria are added and removed from the disk.

• Add Current File will add the current editor file to the project if it is not already there.

• Add Existing File will prompt you to select a single file to add to the project view. This may also
result in adding a new directory to the project manager window, if that file is the first to be added for a
directory.

• Add New File is used to create a new file and simultaneously add it to your project.

A subset of these options can be accessed from the context menu that appears when right-clicking your
mouse on the surface of the project manager window.

3.2. Removing Files and Directories
To remove a specific file or directory, select it and use the Remove From Project menu item in the
right-click context menu from the surface of the Project Manager window, or by selecting an item on the
project and using Remove Selected Entry in the Project menu.
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If the removed file or directory is part of another directory that has been added to the project, the removal
is remembered as an exclusion that can be cleared from Directory Properties, which are accessed
by right clicking on the parent directory in the Project tool.

3.3. Saving the Project
To save a new project, use Save Project As in the Project menu. Once a project file has been
saved the first time, it will be auto-saved whenever you close the project, start a debug session, or exit
Wing.

You can also save a copy of your project to another location or name with Save Project As... in the
Project menu.

Note

Moving Project Files

When moving a project file on disk, doing so in a file browser or from the command line may
partially break the project if it is moved relative to the position of files that it includes. Using
Save Project As... in Wing instead will properly update the relative paths that the project
manager uses to locate files in the project.

3.4. Sorting the View
The project can be set to show your files in one of several modes, using the Options menu in the top
right of the project view:

• View As Tree -- This displays the project files in true tree form. The tree structure is based on the
partial relative path from the project file.

• View As Flattened Tree -- This view (the default) shows files organized according to their location
on disk. Each directory is shown at the top level with path names shown as partial relative paths
based on the location of the project file. If you alter the location of the project file with
Save Project As..., these paths will be updated accordingly.

Several sorting options are available to sort items within their directory by name, mime type, or extension.
The List Files Before Directories option may be used to control whether files or directories are
shown first in the tree view.

3.5. Navigating to Files
Files can be opened from the project manager window by double clicking or middle clicking on the file
name, or right-clicking and using the Open in Wing menu item.

Files may also be opened using an external viewer or editor by right-clicking on the file and using the
Open in External Viewer item. On Windows and Mac OS X, this opens the file as if you had double clicked
on it. On Linux, the preferences File Display Commands and Extra Mime Types can be used to
configure how files are opened.

You can also execute Makefiles, Python source code, and any executable files by selecting the
Execute Selected item from the popup menu. This executes outside of the debugger with any
input/output occurring in the OS Commands tool. Doing so also adds the command to the OS Commands
tool, where its runtime environment can be configured.

3.5.1. Keyboard Navigation

Once it has the focus, the project manager tree view is navigable with the keyboard, using the up/down
arrow keys, page up and page down, and home/end.
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Use the right arrow key on a parent to display its children, or the left arrow key to hide them.

Whenever a file is selected, pressing enter will open that item into an editor in Wing.

3.6. Project-wide Properties
Each project has a set of top-level properties that can be accessed and edited via the Properties item
in the Project menu. These can be used to configure the Python environment used when debugging,
executing, or testing code, and for the source code analysis engine, which drives Wing's auto completion,
source index, and other capabilities. Project properties are also provided to set options for the project and
to enable and configure extensions for revision control, Zope, and other tools.

Any string value for a property may contain environment and special variable references, as described in
Environment Variable Expansion.

Environment

To get the most out of Wing, it is important to set these values in the Environment tab correctly for your
project:

Python Executable -- When the Custom radio button is checked and the entered field is non-blank, this
can be used to set the full path to the Python executable that should be used when debugging source
code in this project. When Use default is selected, Wing tries to use the default Python obtained by
typing python on the command line. On OS X, Wing prefers the latest Apple-provided Python. If this
fails, Wing will search for Python in /usr/local and /usr (on Linux and OS X) or in the registry (on
Windows). To use Wing with virtualenv just set this property to the Python executable provided by
virtualenv. An easy way to get the full path to use here is to type the following in the Python that you
wish to use: import sys; print(sys.executable). This can also be typed into the IDLE that is
associated with the Python installation.

Python Path -- The PYTHONPATH is used by Python to locate modules that are imported at runtime with
the import statement. When the Use default checkbox in this area is checked, the inherited
PYTHONPATH environment variable is used for debug sessions. Otherwise, when Custom is selected, the
specified PYTHONPATH is used.

Environment -- This is used to specify values that should be added, modified, or removed from the
environment that is inherited by debug processes started from Wing and is used to expand environment
variable references used in other properties. Each entry is in var=value form (without any quotes
around the value) and must be specified one per line in the provided entry area. An entry in the form
var= (without a value) will remove the given variable so it is undefined. Note that you are operating on the
environment inherited by the IDE when it started and not modifying an empty environment. On OS X the
environment inherited by Wing may differ according to whether you launched Wing from the command line
or with the Finder. When the Use inherited environment choice is set, any entered values are ignored and
the inherited environment is used without changes.

Debug

The following properties are defined in the Debug tab:

Main Entry Point -- This defines where execution starts when the debugger is launched from the IDE.
The default is to start debugging in the current editor file. Alternatively, use this property to define a
project-wide main entry point so that debug always started in that file regardless of which file is current in
the editor. The entry point can either be a selected file in order to debug that files with the environment
specified in its File Properties, or a named entry point to select a file and use a different environment to
debug it.

Initial Directory -- When the Use default radio button is checked, the initial working directory set for 
each debug session will be the directory where the debugged file is located. When Custom is selected, 
the specified directory is used instead (use $(WING:PROJECT_DIR) for the project's directory). This 
property also sets the initial directory for the Python Shell, determines how Wing resolves partial paths on 
the Python Path for the purposes of static analysis, and is used for other features in the IDE that require a 
starting directory for a sub-process. For these, Wing will use the directory of the main debug file in the
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project as the default initial directory, or the directory of the project file if there is no main debug file
defined.

Build Command -- This command will be executed before starting debug on any source in this project.
This is useful to make sure that C/C++ extension modules are built, for example in conjunction with an
external Makefile or distutils script, before execution is started. The build is configured through
and takes place in the OS Commands tool.

Python Options -- This is used to select the command line options sent to the Python interpreter while
debugging. The default of -u sets Python into unbuffered I/O mode, which ensures that the debug
process output, including prompts shown for keyboard input, will appear in a timely fashion.

Debug Server Port -- This can be used to alter the TCP/IP port on which the debugger listens, on a
per-project basis. In this way, multiple instances of Wing using different projects can concurrently accept
externally initiated debug connections. See Advanced Debugging Topics for details.

Automatic Perspectives -- When enabled, Wing will create and automatically switch between Edit and
Debug perspectives when debugging is stopped and started. See Perspectives for details.

Options

These project options are provided:

Default Encoding sets the default text encoding to use for files when the encoding cannot be determined
from the contents of the file. This applies to all files opened when the project is open, whether or not they
are part of the project. By default, this falls back to the value set by the Default Encoding preference.

Project Home Directory sets the base directory for the project. This overrides the project file location as
the directory on which to base relative paths shown in the Project view and elsewhere. It is also used as
the directory in which the Python Shell subprocess is launched and for the starting directory when the
Default Directory Policy preference is set to Current Project.

Preferred Line Ending and Line Ending Policy control whether or not the project prefers a particular line
ending style (line feed, carriage return, or carriage return + line feed), and how to enforce that style, if at
all. By default, projects do not enforce a line ending style but rather insert new lines to match any existing
line endings in the file.

Preferred Indent Style and Indent Style Policy control whether or not the project prefers a particular
type of indentation style for files (spaces only, tabs only, or mixed tabs and spaces), and how to enforce
that style, if at all. By default, projects do not enforce an indent style but rather insert new lines to match
any existing indentation in the file.

Strip Trailing Whitespace controls whether or not to automatically remove whitespace at the ends of
lines when saving a file to disk.

Extensions

The Extensions tab of Project Properties is used to control add-ons on a per-project basis:

Enable Django Template Debugging enables Django-specific functionality that makes it possible for
Wing's debugger to stop at breakpoints and step through Django template files.

Matplotlib Event Loop Support enabled Matplotlib-specific functionality that updates plots continuously
when working interactively in the Python Shell.

Enable Zope2/Plone Support, Zope2 Instance Home, and Zope2 Host enable legacy support for older
Zope installations. They are needed because Zope 2.x implements import magic that works differently
from Python's default import and thus adding the instance home directory to PYTHONPATH is not
sufficient. Wing's source analyzer needs this extra clue to properly find and process the Zope
instance-specific sources.

When this option is activated, Wing will also offer to add the relevant Zope2/Plone files to the project, and
to install the control panel for configuring and initiating debug in Zope2/Plone. See the Zope How-To for
details.
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3.6.1. Environment Variable Expansion

Any string value for a property may contain environment variable references using the $(name) or
$ {name} notation. These will be replaced with the value of the environment variable when used by the
IDE. If the environment variable is not set, the reference will be replaced by an empty string. The system
environment, as modified by the project-wide or per-file environment property (if defined), is used to
expand variable references.

Special Environment Variables

The following special variable names are defined by Wing for use in the $(name) or ${name} form:

• WING:FILENAME -- full path of current file

• WING:FILENAME_DIR -- full path of the directory containing the current file

• WING:LINENO -- current line number in the current file

• WING:SCOPE -- x.y.z-formatted name of the current scope in the current file (if Python)

• WING:PROJECT full path of current project (including the project file name)

• WING:PROJECT_DIR -- full path of the directory containing the current project

• WING:PROJECT_HOME -- full path of the Project Home directory, as set in
Project Properties (by default this is the same as WING:PROJECT_DIR)

• WING:SELECTION -- the text selected on the current editor, if any

• WING::PYTHON -- the Python interpreter being used in the current project

These may evaluate to an empty string when there is no current file name.

3.7. Per-file Properties
Per-file properties can be set by right-clicking on a source file and selecting the Properties menu item
in the popup, by right-clicking on a file in the project view and selecting File Properties, or by
opening a file and using the Current File Properties... item in the Source menu. For Debug and
Python Settings, values entered here will override any corresponding project-wide values when the
selected file is the current file or the main entry point for debugging.

Any string value for a property may contain environment and special variable references, as described in
Environment Variable Expansion.

File Attributes

File Type -- This property specifies the file type for a given file, overriding the type determined
automatically from its file extension and/or content. This property is recommended only when the
Extra File Types preference cannot be used to specify encoding based on filename extension.

Encoding -- This can be used to specify the encoding with which a file will be saved. When it is altered for
an already-open file, Wing will offer to reload the file using the new encoding, to only save subsequently
using the new encoding, or to cancel the change. Choose to reload if the file was opened with the wrong
encoding. For already-open files, the encoding attribute change is only saved if the file is saved. If it is
closed without saving, the encoding attribute will revert to its previous setting. The encoding cannot be
altered with this property if it is being defined by an encoding comment in a Python, HTML, XML, or
gettext PO file. In this case, the file should be opened and the encoding comment changed. Wing will save
the file under the newly specified encoding.

Important: Files saved under a different encoding without an encoding comment may not be readable by
other editors because there is no way for them to determine the file's encoding if it differs from the system
or disk default. Wing stores the selected encoding in the project file, but no mark is written in the file
except for those encodings that naturally use a Byte Order Mark (BOM), such as utf_16_le, utf_16_be,
utf_32_le, or utf_32_be. Note that standard builds of CPython cannot read source files encoded in utf16 or
utf32.
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Line Ending Style -- Specifies which type of line ending (line feed, carriage return, or carriage return and
line feed) is used in the file. When altered, the file will be opened and changed in an editor. The change
does not take effect until the file is saved to disk.

Indent Style -- This property can be used in non-Python files to change the type of indent entered into the
file for newly added lines. For Python files, the only way to alter indentation in a file is with the
Indentation manager.

Read-only on Disk -- This property reflects whether or not the file is marked read-only on disk. Altering it
will change the file's disk protections for the owner of the file (on Posix, group/world permissions are never
altered).

Editor

These properties define how the file is displayed in the editor:

Show Whitespace -- This allows overriding the Show White Space preference on a per-file basis.

Show EOL -- This allows overriding the Show EOL preference on a per-file basis.

Show Indent Guides -- This allows overriding the Show Indent Guides preference on a per-file
basis.

Ignore Indent Errors -- Wing normally reports potentially serious indentation inconsistency in Python
files. This property can be used to disable this check on a per-file basis (it is also available in the warning
dialog).

Ignore EOL Errors -- When the project's Line Ending Policy is set to warn about line ending
mismatches, this property can be used to disable warnings for a particular file.

Debug/Execute

This tab is used to select the environment used when debugging or executing the file, and to set run
arguments. By default, the project-wide environment will be used with the specified run arguments.
Alternatively, use the Environment property to select a different environment defined by a launch
configuration.

3.8. Launch Configurations
Most users of Wing will use the project-wide environment for debugging, executing, and testing code.

In some cases, multiple environments are needed in the same project, for example to run unit tests in
different environments, or to set a different environment for specific entry points. To support this, launch
configurations can be managed from the Project > Launch Configurations menu item. This
manager is initially empty. Right click to create, edit, duplicate, or delete launch configurations.

Once defined, launch configurations can be referenced from per-file properties under the
Debug/Execute and Testing tabs, and in the creation of named entry points.

Launch configurations contain the following properties, as organized under the Environment and Python
tabs in the launch configuration properties dialog:

Python Executable -- When the Custom radio button is checked and the entered field is non-blank, this
can be used to set the full path to the Python executable that should be used when debugging source
code in this project. When Use default is selected, Wing uses the project configuration.

Python Path -- The PYTHONPATH is used by Python to locate modules that are imported at runtime with
the import statement. By default this uses the project setting. When the Use default checkbox
selected, the inherited PYTHONPATH environment variable is used. Otherwise, when Custom is selected,
the specified PYTHONPATH is used.

Python Options -- This is used to select the command line options sent to the Python interpreter while
debugging. The default of -u sets Python into unbuffered I/O mode, which ensures that the debug
process output, including prompts shown for keyboard input, will appear in a timely fashion.
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Run Arguments -- Enter any run arguments here. Wing does not interpret backslashes ('') on the
command line and passes them unchanged to the sub-process. The only exceptions to this rule are \'
and \" (backslash followed by single or double quote), which allow inclusion of quotes inside quoted
multi-word arguments.

Initial Directory -- Specifies the initial working directory. By default this uses the initial directory specified
by the project-wide environment. When the Use default radio button is checked, the initial working
directory will instead be the directory where the launched file is located. When Custom is selected, the
specified directory is used instead (use $(WING:PROJECT_DIR) for the project's directory).

Environment -- This is used to specify values that should be added, modified, or removed from the
environment. Each entry is in var=value form and must be specified one per line in the provided entry
area. An entry in the form var= (without a value) will remove the given variable so it is undefined. The
popup selector is used to choose the environment to modify: Either the startup environment seen when
Wing was first started, or the Project-defined environment. When Use project values or Use inherited
environment is chosen, any entered values are ignored and the selected environment is used without
changes. Note that the environment inherited by Wing may differ on OS X according to whether you
launched Wing from the command line or with the Finder.

Build Command -- This command will be executed before launching a subprocess with this launch
configurations. This is useful to make sure that C/C++ extension modules are built, for example in
conjunction with an external Makefile or distutils script, before execution is started. The build is
configured through and takes place in the OS Commands tool.

For all of these, environment variable references may be used, as described in Environment Variable
Expansion.

Shared Launch Configurations

By default each launch configuration is stored in the project file. In the launch configuration manager
dialog, the Shared checkbox can be selected to cause Wing to store that launch configuration in the
User Settings Directory instead, in a file named launch. Those launch configurations are then accessible
from all projects.

Working on Different Machines or OSes

When the Shared checkbox is selected for a launch configuration, or when shared projects are used, it is
necessary to design launch configurations carefully so that they will work across projects, machines, or
operating systems.

For example, specifying a full path in the Python Path may not work on a different OS. The key to making
this work is to use environment variable references in the form ${VARNAME} as described in
Environment Variable Expansion. The referenced environment variables can be special environment
variables defined by Wing, such as WING:PROJECT_DIR, or user-defined values that are set either
system-wide, or in Project Properties. Note that values set in Environment in Project Properties are by
default not stored in the shared project file, so those may vary on each development machine if desired.

A common example in configuring Python Path is to replace a full path like
/Users/myname/src/project/src with ${WING:PROJECT_DIR}/src (this assumes you store the
project in /Users/myname/src/project). In general, working of the project's location is a good
approach to maintaining some independence from differences on different development machines and
OSes.

To make file paths work across OSes, use forward slashes instead of back slashes. The character
sequence .. can be used to move up a directory on all OSes, as for example in
{WING:PROJECT_DIR}/../libs/src.

Source Code Editor
Wing's source code editor uses both static code analysis and inspection of live runtime state, when
available, to offer a powerful range of editing and code navigation tools.
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4.1. Syntax Coloring
The editor will attempt to colorize documents according to their MIME type, which is determined by the file
extension, or content. For example, any file ending in .py will be colorized as a Python source code
document. Any file whose MIME type cannot be determined will display all text in black normal font by
default.

All the available coloring document types are listed in the File Properties dialog's File Attributes tab. If you
have a file that is not being recognized automatically, you can use the File Type menu found there to
alter the way the file is being displayed. Your selections from this menu are stored in your project file, so
changes made are permanent in the context of that project.

If you have many files with an unrecognized extension, use the Extra File Types preference to add
your extension.

Syntax coloring can be configured as described in the section Custom Syntax Coloring.

4.2. Right-click Editor Menu
Right-clicking on the surface of the editor will display a context menu with commonly used commands
such as Copy, Paste, Goto Definition, and commenting and indentation operations.

In Wing Pro and Wing Personal, user-defined scripts may also add items to this menu, as described in the
Scripting chapter.

4.3. Navigating Source
The set of menus at the top of the editor can be used to navigate through your source code. Each menu
indicates the scope of the current cursor selection in the file and may be used to navigate within the
top-level scope, or within sub-scopes when they exist.

When editor tabs are hidden by clicking on the options drop down in the top right of the editor area, the
left-most of these menus lists the currently open files by name.

You can use the Goto Definition menu item in the editor context menu to click on a construct in your
source and zoom to its point of definition. Alternatively, place the cursor or selection on a symbol and use
the Goto Selected Symbol Defn item in the Source menu, or its keyboard equivalent.
Control-Click (and Command-Click on OS X) also jumps to the point of definition unless the
Editor > Advanced preference for this feature is disabled.

When moving around source, the history buttons in the top left of the editor area can be used to move
forward and backward through visited files and locations within a file in a manner similar to the forward
and back buttons in a web browser.

In Wing Pro and Wing Personal, other commonly used ways to navigate to files that are open include the
Window menu, which lists all open files; the Open Files tool which also supports defining named file
sets; the Recent sub-menu in the File menu; Open From Project in the File menu, which finds
project files quickly by typing a fragment of the file name; and Open From Keyboard in the File
menu, which operates in a temporary input area at the bottom of the IDE window and offers
auto-completion of file names as you type.

Find Symbol in the Source menu provides a way to find a symbol defined in the current Python scope
by typing a fragment of its name.

See also the Source Browser tool.

4.4. File status and read-only files
The editor tabs, or editor selection menu when the tabs are hidden, indicate the status of the file by
appending * when the file has been edited or (r/o) when the file is read-only. This information is
mirrored for the current file in the status area at the bottom left of each editor window. Edited status is also
shown in the Window menu by appending * to the file names found there.
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Files that are read-only on disk are initially opened within a read-only editor. Use the file's context menu
(right-click) to toggle between read-only and writable state. This alters both the editability of the editor and
the writability of the disk file so may fail if you do not have the necessary access permissions to make this
change.

4.5. Transient, Sticky, and Locked Editors
Wing can open files in several modes that control how and when files are closed:

Transient Mode -- Files opened when searching, debugging, navigating to point of definition or point of
use, and using the Project or Source Browser tools with the Follow Selection checkbox enabled are
opened in transient mode and will be automatically closed when hidden.

The maximum number of non-visible transient files to keep open at any given time can be set with the
Editor / Advanced / Maximum Non-Sticky Editors preference.

Sticky Mode -- Files opened from the File menu, from the keyboard file selector, or by double clicking on
items in the Project or Source Browser tools will be opened in sticky mode, and are kept open until they
are explicitly closed.

Locked Mode -- In Wing Pro and Wing Personal, when multiple splits are visible, a third mode is available
where the file is locked into the editor. In this case, the editor split is not reused to display any newly
opened or visited files unless no unlocked splits are present.

A file can be switched between these modes by clicking on the stick pin icon in the upper right of the
editor area.

Right-click on the stick pin icon to navigate to files that were recently visited in the associated editor or
editor split. Blue items in the menu were visited in transient state and black items were sticky. Note that
this differs from the Recent area in the File menu, which lists only sticky file visits and includes visits for all
editors and editor splits.

Transient files that are edited are also automatically converted to sticky mode.

4.6. Auto-completion
Wing can display an auto-completer in the editor and shells.

When the completer appears, type until the correct symbol is highlighted in the list, or use the up/down
arrow keys, and then press the Tab key or double click on an item. Wing will fill in the remaining
characters for the source symbol, correcting any spelling errors you might have made in the name.

To alter which keys cause auto-completion to occur, use the Auto-completion Keys preference.
Ctrl-click on the list to select multiple keys. For printable keys such as '.', '(', '[', and ':' the key will be added
to the editor and any relevant auto-editing operations will be applied. For '.' the completer will be shown
again for the attributes of the completed symbol.

To cancel out of the auto-completion popup, press the Esc key or Ctrl-G. The auto-completer will also
disappear when you exit the source symbol (for example, by pushing space or any other character that
isn't a completion key and can't be contained in a source symbol), if you click elsewhere on the surface of
the source code, or if you issue other keyboard-bound commands that are not accepted by the
auto-completer (for example, save through keyboard equivalent).

In Wing Pro and Wing Personal, the completer can be configured to display immediately, only after a
specified number of characters, or after a time delay. Completion may be case sensitive or insensitive and
the completer may be auto-hidden after a specified timeout. These and other configuration options are in
the Auto-completion preferences group.

Auto-Completer Icons

The auto-completer contains two columns of icons that indicate the type and origin of the symbol. The first
column may contain one of the following icons:

A Python builtin
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A snippet defined in the Snippets tool

An argument for the current function or method scope

The symbol was found by introspecting the live runtime state

The second column of icons may contain one of the following icons:

A Python keyword

A module name

A class name

A Python package (a directory with __init__.py in it)

A method name

A function name

An object instance (other than the basic types below)

A dictionary

A tuple

A list

A string

An integer

A float

An exception

A Python stack frame

Additionally, icons in the second column may be annotated as in the following examples (the annotation
may be applied to any of the above):

An upward pointing arrow indicates that the symbol was inherited from a superclass

A leftward pointing arrow indicates that the symbol was imported with "from x import"
style import statement

How Auto-completion Works

The information shown in Wing's auto-completer comes from several sources: (1) Static analysis of
Python code, (2) introspection of extension module contents, (3) inspection of keywords and builtins in the
active Python version, (4) introspection of the runtime application state when the debugger is active or
when working in the shells, (5) enumeration of relevant code snippets, and in some cases (6)
user-provided interface description files. See Source Code Analysis for more information on how static
analysis works and how you can help Wing determine the types of values.

Because static analysis can be defeated by Python's dynamic nature, it is sometimes more effective to
work from live runtime state. This can be done by placing a breakpoint in the source code, running to it,
and then working in the editor or (in Wing Pro) in the Debug Probe.

In non-Python files, the auto-completer is limited to words found within similar contexts in the file,
keywords defined for syntax highlighting that file type, and any snippets relevant to the editing context.

4.7. Source Assistant
The Source Assistant tool (in Wing Personal and Wing Pro) can be used to display additional
information about source symbols in the editor, auto-completer, and tools such as the Project,
Search in Files, Python Shell, Debug Probe, and Source Browser.
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The display will include links to the point of definition of the selected symbol, the symbol's type (when
available) and a link to the type's point of definition. Depending on context and symbol type, the Source
Assistant will also display relevant docstrings, call signature, return type, super-classes, overridden
methods.

When invoking a function or method, the Source Assistant will display information both for the callable
being invoked and the current argument or item in the auto-completer.

4.7.1. Docstring Type and Validity

By default the Source Assistant displays a type and validity indicator for docstrings, showing whether the
docstring was successfully parsed or reformatted. The following messages may be displayed:

â■■ PEP287 -- The docstring parses successfully using PEP 287 reStructuredText Docstring Format and
is being rendered accordingly. This only occurs when the Use PEP 287 for docstrings option is
enabled.

â■■ PEP287 -- The docstring does not parse successfully as reStructuredText and is showing inline
parse errors. This only occurs when the Show PEP 287 parse errors option is enabled.

Rewrapped -- The docstring is being shown as plain text but Wing has heuristically rewrapped
paragraphs. This only occurs when the Rewrap plain text docstrings option is enabled.

Plain Text -- The docstring is being shown as plain text, exactly as it appears in the source code.

See Source Assistant Options for a list of the available display options.

4.7.2. Python Documentation Links

For symbols in the Python standard library, Wing will attempt to compute a documentation URL whenever
possible. These point to https://docs.python.org/ but can be redirected to another server with the Source
Analysis > Advanced > Python Docs URL Prefix preference. To access locally stored
documentation, a local http server must be used because # bookmark references do not work with
file: URLs.

4.7.3. Working with Runtime Type Information

When working in the editor, auto-completer, project view, or source browser, the Source Assistant is
fueled by Wing's Python source code analysis engine. Because of Python's dynamic nature, Wing cannot
always determine the types of all values, but presents as much information as it can glean from the source
code.

When a debug process is active, or when working in the Python Shell, Wing also extracts relevant
information from the live runtime state. Since this yields complete and correct type information even for
code that Wing's static analysis engine cannot understand, it is often useful to run to a breakpoint before
designing new code that is intended to work in that context.

For more hints on helping Wing understand your source code, see Source Code Analysis and Helping
Wing Analyze Code.

4.7.4. Source Assistant Options

There are several options available to control docstring rendering. These accessed by right clicking on the
Source Assistant:

Use PEP 287 docstrings -- By default Wing tries to render docstrings by treating them as PEP 287
reStructuredText Docstring Format. This option can be used to disable PEP 287 rendering so they are
always shown as plain text instead.

Show PEP 287 parse errors -- By default Wing falls back to displaying docstrings that cannot be parsed
as reStructuredText as plain text. Enable this option to instead render them with reStructuredText parse
errors.
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Show docstring type and validity -- This enables or disables the floating docstring type and validity
indicator in the top right of the docstring area.

Rewrap plain text docstrings -- By default Wing employs a heuristic to rewrap paragraphs in docstrings,
in order to make better use of available display space. This option can be disabled to show the docstring
exactly as it appears in the source code.

Always show docstrings -- By default Wing shows the docstring only of the last symbol being displayed
in the Source Assistant, in order to save on display space. Enable this option to always show the docstring
for all symbols.

The Source Assistant context menu can also be used to copy text or HTML to the clipboard, change the
display font size, and access this documentation.

4.8. Multiple Selections
Wing Pro and Wing Personal support making multiple selections on the editor, which is a powerful way to
simultaneously edit two or more parts of your code. Most of Wing's editing operations can be applied to
multiple selections. For example, all occurrences of a word such as one may be selected and then the o
replaced with O to change all of the occurrences to One in a single operation.

The selection-add-next-occurrence command (Ctrl-D, or Command-D on the Mac and
Ctrl-> with the emacs personality) is a convenient way to quickly add selections for matching text. When
the command is invoked and something is already selected, it will find the next occurrence that matches
the primary selection. If nothing is selected when the command is invoked, it will will select the current
word.

Whether this search wraps or is case sensitive is controlled from the multiple selections toolbar icon or
Edit > Multiple Selections menu. Add next occurrence may optionally remove the selection from
the current one and add instead the following occurrrence; this option is bound to Control-Shift-D, or
Command-Shift-D on the Mac and Alt-> with the emacs personality.

Multiple selections can also be made quickly within a block, function or method, class, or file by clicking on
the multiple selections toolbar icon or using the Edit > Multiple Selections menu.

It is also possible to make an arbitrary set of selections, where the selections do not necessarily contain
the same text. This is done by holding the Ctrl and Alt keys (or Command and Option keys on the
Mac) while clicking on or selecting text with the left mouse button.

Once multiple selections have been made, any typing, cursor movement, and clipboard commands will act
on all selections simultaneously. When there multiple selections, the Escape key (or Control-G with
the emacs personality) will drop all of the extra selections.

While there are multiple selections in an editor, a floating window is shown to list all of the selections, even
those that are not visible on screen in the editor. An individual selection may be dropped by clicking the X
that appears when the the mouse is moved over its entry in the list. Closing the floating window will drop
all of the extra selections.

By default, the floating window always appears whenever there are multiple selections. It may also be
configured to never appear or to always be displayed even when there is only one selection or no
selection. This is done from Display Selections Popup preference, and it may be shown and
hidden on a case-by-case basis from the toolbar icon or Edit > Multiple Selections menu.

4.9. File Sets
File Sets are used create named sets of files that can then be opened as a group or searched from the
Search in Files tool.

File sets can be created in several ways:

• Open the desired files and use the Name Set of Open Files... item in the
Files > File Sets menu.



• Select the desired files in the Project, Open Files, or in other tools and use the
Name Set of Selected Files... item in the Files > File Sets menu.

• Select the desired files in the Project or Open Files tool, right click and select the
Name Selected File Set... menu item.

• Search in the Search in Files tool and when the search is complete use the
Name Result File Set item in the Options menu to name the set of files in which a search
match was found.

Once defined, file sets can be opened from the Files > File Sets menu and they are included by
name in the Search in Files tool's Look in menu.

To view or edit the defined file sets, use the Manage File Sets... item in the File > File Sets
menu. Right click to access the available operations in this dialog. To rename a file set, click on its name
and edit the name in place.

Binding File Sets to Keys

File sets can be bound to a key sequence, so that the pressing that sequence will open the file set in the
editor. This is done in the Manage File Sets dialog, by selecting the file set, right clicking, and
selecting Set Key Binding....

Shared File Sets

File sets can either be stored in the project file (the default) or in a shared file that is used by all projects.
To make a file set into a shared file set, open the Manage File Sets dialog and check the Shared
checkbox.

4.10. Indentation
Since indentation is syntactically significant in Python, Wing provides a range of features for inspecting
and managing indentation in source code.

4.10.1. How Indent Style is Determined

When an existing file is opened, it is scanned to determine what type of indentation is used in that file. If
the file contains some indentation, this may override the tab size, indent size, and indent style values
given in preferences and the file will be indented in a way that matches its existing content rather than with
your configured defaults. If mixed forms of indentation are found, the most common form is used.

For non-Python files you can change indentation style on the fly using the Indent Style property in the
File Properties dialog (accessed by right-clicking on the editor and available only in Wing Personal
and Wing Pro). This allows creating files that intentionally mix indentation forms in different parts of the
file. To ask Wing to return to the form of indentation it determines as most prominent in the file, select
Match Existing Indents.

For Python files, the Indent Style cannot be altered without converting the whole file's indent style
using the Indentation Manager (Wing Pro and Wing Personal only), which can be accessed from the
button next to the Indent Style property and from the Tools menu.

4.10.2. Indentation Preferences

The following preferences affect how the indentation features behave:

1. The Use Indent Analysis preference is used to control whether analysis of current file content
is used to determine the type of indentation placed during edits. It can be enabled for all files, only for
Python files, or disabled. Note that disabling this preference for Python files can result in a potentially
broken mix of indentation in the files. In general, indent styles should not be mixed within a single
Python file.

2. The Default Tab Size preference defines the position of tab stops and is used to determine the 
rendering of files with tabs only, or non-Python files with mixed tab and space indentation. In Python
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files with mixed indents, this value is ignored and the file is always shown in the way that the Python
interpreter would see it.

3. The Default Indent Size preference defines the default size of each level of indent, in spaces.
This is used in new empty files or when indent analysis has been disabled. Wing may override this
value in files that contain only tabs in indentation, in order to make it a multiple of the configured tab
size.

4. The Default Indent Style preference defines the default indentation style, one of
spaces-only, tabs-only, or mixed. This is used in new empty files or when indent analysis has
been disabled. Mixed indentation replaces each tab-size spaces with one tab character.

These preferences define how indentation is handled by the editor:

5. The Auto-Indent preference controls whether or not each new line is automatically indented.

6. The Show Indent Guides preference controls whether or not to show indentation guides as light
vertical lines. This value can be overridden on a file-by-file basis from Editor tab in File Properties.

7. The Show Python Indent Warnings preference can be used to enable or disable warnings for
Python files that may contain confusing or damaged indentation.

8. The Show Override Warnings preference controls whether or not Wing shows a warnings when
the user enters indentation that does not match the form already within a file. This is currently only
possible in non-Python files, by altering the Indent Style attribute in File Properties.

4.10.3. Indentation Policy

The project manager also provides the ability to define the preferred indentation style (overriding the
preference-defined style) and to specify a policy for enforcing line endings, on a per-project basis. This is
accomplished with Preferred Line Ending and Line Ending Policy under the Options tab in
Project Properties.

4.10.4. Auto-Indent

The IDE ships with auto-indent turned on. This causes leading white space to be added to each newly
created line, as return or enter are pressed. Enough white space is inserted to match the indentation level
of the previous line, possibly adding or removing a level of indentation if this is indicated by context in the
source (such as if, while, or return).

Note that if preference Auto-indent is turned off, auto-indent does not occur until the tab key is
pressed.

In Python code, Wing also auto-indents after typing a colon after else, elif, except, and finally.
Indentation will go to the closest matching if or try statement. I f there are multiple possible matching
statements, the colon key can be pressed repeatedly to toggle through the possible positions for the line.
Similarly, when Smart Tab is selected as the Tab Key Action, then pressing the Tab key repeatedly will
toggle the line through the possible indent positions. This can also be accomplished with the
Indent to Match toolbar and menu items (regardless of selected tab key action).

When pasting multiple lines into Python code and the caret is in the indent region or on a blank line, Wing
will auto-indent pasted text as follows: (1) If the caret is in column zero, the text is indented to match the
context, (2) If the caret is within the indent region but not in column zero, the text is indented to that
position. If the auto-indent is incorrect, a single Undo will return the pasted text to its original indentation
level, or the text can be selected and adjusted with the indentation toolbar or menu items or key
equivalents.

4.10.5. The Tab Key

By default, the action of the tab key depends on the selected Keyboard Personality, file type, and
position within the file as described under Default for Personality below.

To insert a real tab character regardless of the indentation mode or the position of the cursor on a line,
type Ctrl-Tab or Ctrl-T.
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The behavior of the tab key can be altered using the Tab Key Action preference, which provides the
following options:

Default for Personality

This selects from the other tab key actions below according to the chosen keyboard personality, current
file type, and in some cases the position of the caret within the file. In all non-Python files, the default is
Move to Next Tab Stop. In Python files, the defaults are as follows by keyboard personality:

• Normal: Smart Tab

• VI/VIM: Move to Next Tab Stop

• Emacs: Indent to Match

• Brief: Smart Tab

• Visual Studio: Move to Next Tab Stop

• OS X: Smart Tab

Indent to Match

This indents the current line or selected lines to position them at the computed indent level for their
context in the file.

Move to Next Tab Stop

This enters indentation characters matching the current file's style of indentation so that the caret reaches
the next tab stop.

Indent Region

This enters indentation characters matching the current file's style of indentation to increase the
indentation of the current line or selected lines by one level.

Insert Tab Character

This inserts a Tab character (chr(9)) into the file.

Smart Tab

This option is available for Python files only. It implements the following behavior for the tab key:

1. When the caret is within a line or there is a non-empty selection, this performs Indent to Match.
When the line or lines are already at the matching position, indentation is toggled between likely
positions as follows:

a. If a comment precedes the current line or selection, then indentation will match the position of
the prior non-comment code line (if any).

b. If multiple nested blocks match an 'else', 'elif', 'except', or 'finally', then indentation will match the
position of the enclosing blocks (traversing each in outward order).

b. In other cases, indentation is reduced by one level.

2. When the caret is at the end of a non-empty line and there is no selection, one indent level is
inserted. The Smart Tab End of Line Indents preference can be used to alter the type of
indentation used or to disable this aspect of the Smart Tab feature.

4.10.6. Checking Indentation

Wing Pro and Wing Personal analyze existing indentation whenever it opens a Python source file, and will
indicate a potentially problematic mix of indentation styles, allowing you to attempt to repair the file. Files
can be inspected more closely or repaired at any time using the Indentation Manager.

To turn off indentation warnings in Python files, use the Show Python Indent Warnings preference.
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Wing also indicates suspiciously mismatched indentation in source code by underlining the indent area of
the relevant lines in red or yellow. In this case, an error or warning message is displayed when the mouse
hovers over the flagged area of code.

4.10.7. Changing Block Indentation

Wing provides Indent and Outdent commands in the Indentation portion of the Source menu,
which increase or decrease the level of indentation for selected blocks of text. All lines that are included in
the current text selection are moved, even if the entire line isn't selected.

Indentation placed by these commands will contain either only spaces, only tabs, or a mixture of tabs and
spaces, as determined by the method described in Indentation.

Note

The command Indent Lines to Match (also in the Indentation sub-menu) will indent or
outdent the current line or selected lines to the level as a unit so that the first line is positioned as it
would have been positioned by Wing's auto-indentation facility. This is very useful when moving
around blocks of code.

4.10.8. Indentation Manager

The Indentation manager, accessible from the Tools menu, can be used to inspect and change
indentation style in source files. It has two parts: (1) The indentation report, and (2) the indentation
converter.

A report on the nature of existing indentation found in your source file is given above the horizontal
divider. This includes the number of spaces-only, tabs-only, and mixed tabs-and-space indents found,
information about whether indentation in the file may be problematic to the Python interpreter, and the tab
and indent size computed for that file. The manager also provides information about where the computed
tab and indent size value come from (for example, an empty file results in use of the defaults configured in
preferences).

Conversion options for your file are given below the horizontal divider. The three tabs are used to select
the type of conversion desired, and each tab contains information about the availability and action of that
conversion, and a button to start the conversion. In some of the conversion options, the indent size field
shown in the indentation report is made editable, to allow specification of the desired resulting indent size.

Once conversion is complete, the indentation manager updates to display the new status of the file, and
action of any subsequent conversions.

Conversions can be undone be moving to the converted source file and selecting Undo from the Edit
menu.

4.11. Folding
The editor supports optional folding for Python, C, C++, Java, Javascript, HTML, Eiffel, Lisp, Ruby, and a
number of other file formats. This allows you to visually collapse logical hierarchical sections of your code
while you are working in other parts of the file.

You can turn folding on and off as a whole with the Enable Folding preference.

The Fold Line Mode preference can be used to determine whether or not a horizontal line is drawn at
fold points, whether it is drawn above or below the fold point, and whether it is shown when the fold point
is collapsed or expanded. Fold Indicator Style is used to select the look of the fold marks shown
at fold points.
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Once folding is turned on, an additional margin appears to the left of source files that can be folded. Left
mouse click on one of the fold marks in this margin to collapse or expand that fold point. Right mouse
clicking anywhere on the fold margin displays a context menu with the various folding operations.

You can also hold down the following key modifiers while left-clicking to modify the folding behavior:

• Shift -- Clicking on any fold point while holding down the shift key will expand that point and all its
children recursively so that the maximum level of expansion is increased by one.

• Ctrl -- Clicking on any fold point while holding down the ctrl key will collapse that point and all its
children recursively so that the maximum level of expansion is decreased by one.

• Ctrl+Shift -- On a currently expanded fold point, this will collapse all child fold points recursively to
maximum depth, as well as just the outer one. When the fold point is subsequently re-expanded with
a regular click, its children will appear collapsed. Ctrl-shift-click on a collapsed fold point will force
re-expansion of all children recursively to maximum depth.

Fold commands are also available in the Folding section of the Source menu, which indicates the key
equivalents assigned to the operations:

• Toggle Current Fold -- Like clicking on the fold margin, this operates on the first fold point found in
the current selection or on the current line.

• Collapse Current More -- Like ctrl-clicking, this collapses the current fold point one more level than
it is now.

• Expand Current More -- Like shift-clicking, this expands the current fold point one more level than it
is now.

• Collapse Current Completely -- Like shift-ctrl-clicking on an expanded node, this collapses all
children recursively to maximum depth.

• Expand Current Completely -- Like shift-ctrl-clicking on a collapsed node, this ensures that all
children are expanded recursively to maximum depth.

• Collapse All -- Unconditionally collapse the entire file recursively.

• Expand All -- Unconditionally expand the entire file recursively.

• Fold Python Methods -- Fold up all methods in all classes in the file.

• Fold Python Classes -- Fold up all classes in the file.

• Fold Python Classes and Defs -- Fold up all classes and any top-level function definitions in the
file.

4.12. Brace Matching
Wing will highlight matching braces in green when the cursor is adjacent to a brace. Mismatched braces
are highlighted in red.

You can cause Wing to select the entire contents of the innermost brace pair from the current cursor
position with the Match Braces item in the Source menu.

Parenthesis, square brackets, and curly braces are matched in all files. Angle brackets (< and >) are
matched also in HTML and XML files.

4.13. Support for files in .zip or .egg files
Source and other text files stored in .zip or .egg files may be loaded into the editor as readonly files. Wing
is unable to write changes to a file within a .zip or .egg file or otherwise write to or create a .zip or .egg file.

When stepping through code, using goto definition, or using other methods to goto a line in a file, a file
within a .zip or .egg file will be opened automatically. To open a file through the open file dialog, specify
the name of the .zip or .egg file and add a / followed by the name of the file to open.



4.14. Keyboard Macros
The Edit menu contains items for starting and completing definition of a keyboard or command sequence
macro, and for executing the most recently defined macro. Once macro recording is started, any
keystroke or editor command is recorded as part of that macro, until macro recording is stopped again.
Most commands may be included in macros, as well as all character insertions and deletions.

Macros can be quite powerful by combining keyboard-driven search (Mini-search in the Edit menu),
cursor movements, and edits.

4.15. Notes on Copy/Paste
There are a number of ways to cut, copy, and paste text in the editor:

• Use the Edit menu items. This stores the copy/cut text in the system-wide clipboard and can be
pasted into or copied from other applications.

• Use key equivalents as defined in the Edit menu.

• Right-click on the editor surface and use the items in the popup menu that appears.

• Select a range of text and drag it using the drag and drop feature. This will move the text from its old
location to the new location, either within or between editors.

• On Linux, select text anywhere on the display and then click with the middle mouse button to insert it
at the point of click.

• On Windows and Mac OS X, click with the middle mouse button to insert the current emacs private
clipboard (if in emacs mode and the buffer is non-empty) or the contents of the system-wide
clipboard (in all other cases). This behavior may be disabled via the Middle Mouse Paste
preference

• In emacs mode, ctrl-k (kill-line) will cut one line at a time into the private emacs clipboard. This
is kept separate from the system-wide clipboard and is pasted using ctrl-y (yank-line). On
Windows and Mac OS X, ctrl-y will paste the contents of the system-wide clipboard only if the emacs
clipboard is empty.

• In VI mode, named text registers are supported.

It is important to note which actions use the system-wide clipboard, which use the emacs private clipboard
or VI registers, and which use the X11 selection (Linux only). Otherwise, these commands are
interchangeable in their effects.

Smart Copy

Wing can be configured to copy or cut the whole current line when there is no selection on the editor. This
is done with On Empty Selection in the Editor > Clipboard preference group. The default is to
use the whole line on copy but not cut.

4.16. Auto-reloading Changed Files
Wing's editor detects when files have been changed outside of the IDE and can reload files automatically,
or after prompting for permission. This is useful when working with an external editor, or when using code
generation tools that rewrite files.

Wing's default behavior is to automatically reload externally changed files that have not yet been changed
within Wing's source editor, and to prompt to reload files that have also been changed in the IDE.

You can change these behaviors by setting the value of the Reload when Unchanged and
Reload when Changed preferences

On Windows, Wing uses a signal from the OS to detect changes so notification or reload is usually instant.
On Linux and Unix, Wing polls the disk by default every 3 seconds; this frequency can be changed with
the External Check Freq preference.



4.17. Auto-save
The source code editor auto-saves files to disk every few seconds. The auto-save files are placed in a
subdirectory of your Cache Directory.

If Wing ever crashes or is killed from the outside, it will check this directory when it is restarted and will
offer to restore unsaved changes. The files you select to restore will be opened into Wing as edited files.

To keep the restored unsaved changes, save the file to disk.

To discard unsaved changes, use Revert to Disk in the File menu.

In Wing Pro you can compare the restored files to disk using Compare Buffer with Disk item in the
Difference/Merge toolbar item or Source > Difference/Merge menu area.

Search/Replace
Wing provides a number of tools for search and replace in your source code. Which you use depends on
the complexity of your search or replace task and what style of searching you are most familiar with.

5.1. Toolbar Quick Search
One way to do simple searches is to enter text in the search area of the toolbar. This scrolls as you type to
the next match found after the current cursor position. Pressing Enter will search for each subsequent
match, wrapping the search when the end of the file is reached.

Text matching during toolbar quick search is case-insensitive unless you enter a capital letter as part of
your search string.

If focus is off the toolbar search area and it already contains a search string, clicking on it will immediately
start searching in the current source editor for the next match. If you wish to search for another string
instead, delete the text and type the desired search string. As you delete, the match position in the editor
will proceed backward until it reaches your original search start position, so that after typing your new
search string you will be presented with the first match after the original source editor cursor position.

5.2. Keyboard-driven Mini-Search/Replace
The Edit menu contains a Mini-Search sub-menu that enumerates the available keyboard-driven search
options. These are normally initiated with the keyboard command sequences shown in the menu and can
be controlled entirely by using the keyboard. All interaction with the mini-search manager occurs using
data entry areas displayed on demand at the bottom of the IDE window.

The implementation of the mini-search manager is very close to the most commonly used search and
replace features found in Emacs, but it is available whether or not the Emacs editor personality is being
used.

The following search and replace features are available in this facility:

• Forward and Backward -- These display a search string entry area at the bottom of the IDE window
and interactively search forward or backward in the current source editor, starting from the current
cursor position. The search takes place as you type and can be aborted with Esc or Ctrl-G, which
returns the editor to its original cursor location and scroll position.

Searching is case-insensitive unless you enter a capital letter as part of your search string. To search
repeatedly, press Ctrl-U (or Ctrl-S in
emacs keyboard mode) to search forward and ``Ctrl-Shift-U (or Ctrl-R in emacs
mode) to search in reverse. The search direction can be changed any number of times and
searching will wrap whenever the top or bottom of the file is reached. You can also enter Ctrl-U
(or Ctrl-S in emacs mode) or Ctrl-Shift-U (or Ctrl-R in emacs mode) again initially while
the search string is still blank in order to call up the most recently used search string and begin
searching forward or backward with it.
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Once the mini-search entry area is visible, Ctrl-W will add the current word in the editor to the
search string. Pressing Ctrl-W more than once while the mini-search entry is visible adds
additional words from the editor to the search string.

• Selection Forward and Selection Backward -- These work like the above but start with the
selection in the current source editor.

• Regex Forward and Regex Backward -- These work like the above but treat the search string as a
regular expression.

• Query/Replace and Regex Query/Replace -- This prompts for search and replace strings in an
entry area at the bottom of the IDE window and prompts for replace on each individual match found
after the cursor location in the current source editor. Press y to replace or n to skip a match and
move on to the next one. The interaction can be canceled at any time with Esc or Ctrl-G.
Matching is case insensitive unless a capital letter is entered as part of the search string. Searching
is always forward and stops when the end of the file is reached, without wrapping to any un-searched
parts between the top of the file and the position from which the search was started.

• Replace String and Replace Regex -- This works like the above command but immediately
replaces all matches without prompting.

5.3. Search Tool
The dockable Search tool can be used for more advanced search and replace tasks within the current
editor. It provides the ability to customize case sensitivity and whole/part word matching, search in
selection, and perform wildcard or regex search and replace.

The Replace field may be hidden and can be shown from the Options menu in the bottom right of the
tool.

To the right of the Search and Replace fields, Wing makes available a popup that contains a history of
previously used strings, options for inserting special characters, and an option for expanding the size of
the entry area.

The following search options can be selected from the tool:

• Case Sensitive -- Check this option to show only exact matches of upper and lower case letters in
the search string.

• Whole Words -- Check this option to require that matches are surrounded by white space (spaces,
tabs, or line ends) or punctuation other than _ (underscores).

• In Selection -- Search for matches only within the current selection on the editor.

The following additional options are available from the Options popup menu:

• Show Replace -- Whether or not the Replace field is visible in the tool.

• Text Search -- Select this to do a regular text search without wildcard or regex.

• Wildcard Search -- Select this to allow use of special characters for wildcarding in the search string
(see Wildcard Search Syntax for details).

• Regex Search -- Select this to use regular expression style searching. This is a more powerful
variant than wildcard search that allows for more complex specification of search matches and
replacement values. For information on the syntax allowed for the search and replace strings, see
Python's Regular Expression Syntax documentation. In this mode, the replace string can reference
regex match groups with \1, \2, etc, as in the Python re.sub() call.

• Wrap Search -- Uncheck this to avoid wrapping around when the search reaches the top or bottom
of a file.

• Incremental -- Check this to immediately start or restarted searching as you type or alter search
options. When unchecked, use the forward/backward search buttons to initiate searching.
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• Find After Replace -- Select this to automatically find the next search match after each Replace
operation.

5.4. Search in Files Tool
The dockable Search in Files tool is used to search and replace within sets of files, or for searching
Wing's documentation. It performs searches in batch and displays a result list for all found matches. This
list can then be traversed to view the matches in the source editor, and is automatically updated as edits
alter the search results. Searching may span the current editor, a single selected file, all open files, all
project files, all of Wing's documentation, or sets of files on disk.

Files in a set may be filtered by file type, for example searching only through Python files in the project.

In addition the options also available in the search tool, the following choices are available in the
Options popup menu:

• Replace Operates On Disk -- Check this to replace text in un-opened files directly on disk. Caution:
see Replace in Multiple Files for details on this option.

• Recursive Directory Search -- Check this to search recursively within all sub-directories of the
selected search directory.

• Omit Binary Files -- Check this to omit any file that appears to contain binary data.

• Auto-restart Searches -- Check this to restart searching immediately if it is interupted because a
search parameter or the set of files being searched is changed.

• Open First Match -- Check this to automatically open the first batch search match, even before the
result list is clicked upon.

• Show Line Numbers -- Check this to include line numbers in the batch result area.

• Result File Name -- This is used to select the format of the result file name shown in the batch result
area.

5.4.1. Replace in Multiple Files

For searches that operate on open files, replace always occurs in the open file editor and can be undone
or saved to disk subsequently, as with any other edit operation.

When replacing text in batch mode, some of the files being searched may not currently be open in an
editor. In this case, Wing will by default open all altered files and make changes in newly created editors
that remain open until the user saves and closes them explicitly. This is the safest way to undertake
multi-file global replace operations because it clearly shows which files have been altered and makes it
possible to undo changes.

An alternative approach is available by selecting the Replace Operates on Disk option from the
Options popup. This will cause Wing to change files directly on disk in cases when there is no currently
open editor.

Because global replace operations can be tricky to do correctly, we strongly recommend using a revision
control system or frequent backups and manually comparing file revisions before accepting files that have
been altered.

5.5. Wildcard Search Syntax
For wild card searches in the Search tools, the following syntax is used:

* can be used to match any sequence of characters except for line endings. For example, the search
string my*value would match anything within a single line of text starting with my and ending with
value. Note that * is "greedy" in that myinstancevalue = myothervalue would match as a whole
rather than as two matches. To avoid this, use Regex Search instead with .*? instead of *.

? can be used to match any single character except for line endings. For example, my???value would
match any string starting with my followed by three characters, and ending with value.
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[ and ] can be used to indicate sets of match characters. For example [abcd] matches any one of a,
b, c, or d. Also, [a-zA-Z] matches any letter in the range from a to z (inclusive), either lower case or
uppercase. Note that case specifications in character ranges will be ignored unless the
Case Sensitive option is turned on.

Source Code Browser
The Source Browser in Wing Pro and Wing Personal acts as an index to your source code, supporting
inspection of collections of Python code from either a module-oriented or class-oriented viewpoint.

6.1. Display Choices
The source code browser offers three ways in which to browse your source code: All code by module, all
code by class, or only the current file. These are selected from the menu at the top left of the browser.

Project Modules

When browsing project modules, the source browser shows in alphabetical order all Python modules and
packages that you have placed into your project and all modules and packages reachable by traversing
the directory structure that contains your project files (including all sub-directories). The following types of
items are present in this display mode, each of which is displayed with its own icon:

• Packages, which are directories that contain a number of files and a special file __init__.py. This
file optionally contains a special variable __all__ that lists the file-level modules Python should
automatically import when the package as a whole is imported. See the Python documentation for
additional information on creating packages.

• Directories found in your project that do not contain the necessary __init__.py file are shown as
directories rather than packages.

• Python files found at any level are shown as modules.

Within each top-level package, directory, or module, the browser will display all sub-modules,
sub-directories, modules, and any Python constructs. These are all labeled by generic type, including the
following types:

• class -- an object class found in Python source

• method -- a class method

• attribute -- a class or instance attribute

• function -- a function defined at the top-level of a Python module

• variable -- a variable defined at the top-level of a Python module

The icons for these are shown in the Options menu in the top right of the source browser. Note that the
base icons are modified in color and with arrows depending on whether they are imported or inherited,
and whether they are public, semi-private, or private. This is described in more detail later.

Project Classes

When browsing by class, the browser shows a list of all classes found in the project. Within each class, in
addition to a list of derived classes, the methods and attributes for the class are shown.

Navigation to super classes is possible by right-clicking on classes in the display.

Current Module

The browser can also be asked to restrict the display to only those symbols defined in the current module.
This view shows all types of symbols at the top level and allows expansion to visit symbols defined in
nested scopes. In this mode, the browser can be used as an index into the current editor file.



6.2. Display Filters
A number of options are available for filtering the constructs that are presented by the source code
browser. These filters are available from the Options popup menu at the top right of the browser. They
are organized into two major groups: (1) construct scope and source, and (2) construct type.

Filtering Scope and Source

The following distinctions of scope and source are made among the symbols that are shown in the source
browser. Constructs in each category can be shown or hidden as a group using the filters in the Options
menu:

• Public -- Constructs accessible to any user of a module or instance. These are names that have no
leading underscores, such as Print() or kMaxListLength.

• Semi-Private -- Constructs intended for use only within related modules or from related or derived
classes. These are names that have one leading underscore, such as _NotifyError() or
_gMaxCount. Python doesn't enforce usage of these constructs, but they are helpful in writing clean,
well-structured code and are recommended in the Python language style guide.

• Private -- Constructs intended to be private to a module or class. These are names that have two
leading underscores, such as __ConstructNameList() or __id_seed. Python enforces
local-only access to these constructs in class methods. See the Python documentation for details.

• Inherited -- Constructs inherited from a super-class.

• Imported -- Constructs imported into a module with an import statement.

Filtering Construct Type

Constructs in the source code browser window can also be shown or hidden on the basis of their basic
type within the language:

• Classes -- Classes defined in Python source.

• Methods -- Methods defined within classes.

• Attributes -- Attributes (aka 'instance variables') of a class. Note that these can be either class-wide
or per-instance, depending on whether they are defined within the class scope or only within
methods of the class.

• Functions -- Non-object functions defined in Python source (usually at the top-level of a module or
withing another function or method).

• Variables -- Variables defined anywhere in a module, class, function, or method. This does not
include function or method parameters, which are not shown in the source browser.

6.3. Sorting the Browser Display
In all the display views, the ordering of constructs within a module or class can be controlled from the
Options popup menu in the browser.

• Alphabetically -- Displays all entries in the tree in alphabetic order, regardless of type.

• By Type -- Sorts first by construct type, and then alphabetically.

• In File Order -- Sorts the contents of each scope in the same order that the symbols are defined in
the source file.

6.4. Navigating the Views
To navigate source code from the browser, double click on the tree display. This will open source files to
the appropriate location.

Source files opened from the browser will automatically close when browsing elsewhere, except if they are
edited or if the stick pin icon in the upper right of the source area is clicked to indicate that the source file
should remain open. For details on this, see Transient, Sticky, and Locked Editors.
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The option Follow Selection may be enabled in the Options menu to cause the browser to open
files even on a single click or as the currently selected item on the browser is changed from the keyboard.

Right-clicking on classes will present a popup menu that includes any super classes, allowing quick
traversal up the class hierarchy.

6.5. Browser Keyboard Navigation
Once it has the focus, the browser tree view is navigable with the keyboard, using the up/down arrow
keys, page up and page down, home/end, and by using the right arrow key on a parent to expand it, or the
left arrow key to collapse a parent.

Whenever a tree row is selected, pressing enter or return will open the source view for the selected
symbol in a separate window, indicating the point of definition for that symbol.

Interactive Python Shell
Wing provides an integrated Python Shell for execution of commands and experimental evaluation of
expressions. The version of Python used in the Python Shell, and the environment it runs with, is
configured in your project using Project Properties or by setting a particular launch configuration from the
Options menu.

This shell runs a separate Python process that is independent of the IDE and functions without regard to
the state of any running debug process.

Convenient ways to run parts of your source code in the shell include:

Copy/Paste part of a file -- Wing will automatically adjust leading indentation so the code can be executed
in the shell.

Drag and Drop part of a file -- This works like Copy/Paste.

Evaluate File in Python Shell -- This command in the Source menu will evaluate the top level of the
current file in the shell.

Evaluate Selection in Python Shell -- The command in the Source menu and editor's context menu
(right-click) will evaluate the current selection in the shell.

The Options menu in the Python Shell tool -- This contains items for evaluating the current file or
selection

In the Python Shell, the Up and Down arrow keys will traverse the history of the code you have entered
and the return key will either execute the code if it is complete or prompt for another line if it is not.
Ctrl-Up and Ctrl-Down will move the cursor up and down and Ctrl-Return will insert a new line
character at the cursor position.

To restart the Python Shell, select Restart Shell from the Options menu in the top right of the tool.
This will terminate the external Python process and restart it, clearing and resetting the state of the shell.

To save the contents of the shell, use Save a Copy in the Options menu or right-click context menu.
The right-click context menu also provides items for copying and pasting text in the shell.

To preload some code into the Python Shell when it is started, you can set the PYTHONSTARTUP
environment variable, as supported by the Python Shell outside of Wing.

7.1. Active Ranges in the Python Shell
Code in an editor can be set up as the active range on which the Python Shell will operate, to make it
easier to reevaluate after it is edited. This is done by selecting a range of lines in an editor and pressing
the icon at the top right of the Python Shell to set the active range.

Once this is done, additional icons appear for executing the active range, jumping to the active range in
the code editor, or clearing the active range. The active range is highlighted in the code editor and should
adjust its start/end lines as code is added or deleted.
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7.2. Python Shell Auto-completion
Wing's Python Shell includes auto-completion, which can be a powerful tool for quickly finding and
investigating functionality at runtime, for the purposes of code learning, or in the process of crafting new
code. The Python Shell's completer is fueled by introspection of the runtime environment.

The Source Assistant in Wing Pro and Wing Personal will display details for the currently selected item in
the auto-completer within the Python Shell. This provides quick access to the documentation and call
signature of functions and methods that are being invoked.

Goto-definition will also work in the Python Shell, using a combination of live runtime state and static
analysis to attempt to find the definition of the symbol or its type.

7.3. Debugging Code in the Python Shell
Code executed in Wing's Python Shell can be run with or without debug. This is controlled by clicking
on the bug icon in the upper right of the tool, or using the Enable Debugging item in the Options
menu. When debugging is enabled, a breakpoint margin appears at the left of the Python Shell tool, and
breakpoints can be set here as in editors. This works for code previously typed, dragged, or pasted into
the shell. Breakpoints set in editors will also be reached, if that code ends up being executed. Wing will
copy breakpoints from a source file and stop in the Python Shell itself when Evaluate Selection is
used on a short enough range of code. However, when using active ranges or evaluating a long selection
or whole file Wing instead stops at breakpoints set within the code editor, since in those cases the code is
not visible in the shell itself.

Note that the debugger only appears active when code is actually running, and not when waiting at the
Python Shell prompt.

Whenever code is being debugged from a shell prompt, Stop Debugging and Start/Continue in
the Debug menu, and their keyboard and toolbar equivalents, will return to the prompt in the shell. Both
will continue executing code to complete the invocation from the prompt but Stop Debugging will do so
with debug temporarily disabled. The fact that code is not preemptively interrupted is a limitation stemming
from the way Python is implemented. In cases where this is a problem, the Python Shell can be
restarted instead.

Debugging Threaded Code

Threads are treated differently in the Python Shell and Debug Probe depending on whether or not
debug is enabled and/or whether the shell is at the prompt, as follows:

In the Python Shell, when debugging is disabled, threads are run continuously in the background
without debug and whether or not the shell is at a prompt. When debugging is enabled in the
Python Shell it will also debug threads. However, it will allow threads to run only while code is being
executed from the shell and the Python Shell is not at the prompt. This matches the behavior of the
debugger when it is running stand-alone files, where it halts all threads if any thread is halted. When the
Python Shell is debugged, Wing treats execution of code from the shell prompt as continuing the
debugger until the prompt is reached again. Thus it allows other threads to run as well.

In the Debug Probe, when debugging is disabled in its Options menu, threads are debugged but are
halted whenever the main thread is halted in the debugger. Threads are not run even while executing
code from the prompt in the Debug Probe so that data in all threads can be inspected without any
unexpected change in runtime state caused by running of a thread. Threads will only continue running
when the main debug program is continued. This is true whether or not the debug program was started
from a file, or from within the Python Shell. As in the Python Shell, when debugging is enabled in
the Debug Probe child threads will also be allowed to run whenever code is being executed recursively
and the Debug Probe is not at the prompt. Threads are still halted whenever the Debug Probe is at
the prompt

These subtle but necessary differences in threading behavior may affect how threaded code performs 
within the Python Shell and Debug Probe. Currently there are no options for selecting other 
behaviors (such as always letting threads run even when at the prompt, or never letting threads run even
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