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Wing IDE is a powerful software development environment for Python. Wing cuts down
on coding and debugging time, so you can build quality code more rapidly.

• For a guided tour try the tutorial.

• To try Wing on your own, see the quick start guide.

• Wing IDE 1.1 users may want to learn about migrating to Wing IDE 2.x.

• Also available: Why Use Wing IDE?
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Wing IDE Tutorial

This document introduces Wing IDE by taking you through its feature set with a small
coding example. For a faster but less informative introduction, see the Wing IDE Quick
Start Guide.

To get started, press the Next icon, second from right in the toolbar immediately above
this page.

When using this tutorial with products other than Wing IDE Professional, please note that
the screen shots include tools and features only available in Wing IDE Professional. These
can safely be ignored and, when working with the tutorial within Wing IDE, those tools
will not be discussed in the content that follows.

1.1. Tutorial: Getting Started

In addition to installing Wing IDE, you will also need to install Python. This tutorial will
work with Python version 2.0 or later.

To get Python, download it now from python.org or wingware.com.

If the above links don’t work or bring up the wrong browser, you may need to define the
BROWSER environment variable to the name of the browser executable you wish to use (for
example: mozilla) and restart Wing IDE.

On Linux/Unix, you can also add a browser command line to your URL Display Com-
mands preference. This is recommended only if your preferred browser doesn’t work when
specified with the BROWSER environment variable. Setting BROWSER will generally do a
better job reusing browser instances and creating and raising browser windows as needed.

Next, copy the entire tutorial directory out of your Wing IDE installation to a location
where you will have write access to the files in it. You can do this manually or use the
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following link to execute a script that will prompt you for a target directory to copy the
tutorial info: Copy Tutorial Now

We welcome feedback and bug reports, both of which can be submitted directly from
Wing IDE using the Submit Feedback and Submit Bug Report items in the Help
menu, or by emailing us at support at wingware.com.

1.2. Tutorial: Getting Around Wing IDE

Let’s start with some basics that will help you get around Wing IDE while working with
this tutorial.

Wing IDE’s user interface is divided into an editor area and two tool boxes separated by
draggable dividers. Use the option menus in each area to create splits or move tools around.
The Previous/Next Bookmark buttons and the Next Document, Previous Document and
Most Recent Document items in the Window menu can be used to switch quickly between
documents in the editor area, such as this tutorial and the source files you’ll be working
with later.

mailto:support@wingware.com
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Configuration Options

There are many configuration options available for customizing the user interface. Some
of these are described below. Once you make changes to any of these, your settings will be
remembered in your project file and preferences.

Splitting Panels -- The editor area and tool boxes can be split into multiple sub-panels
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by using the editor and tool box option menus. These can be accessed either by clicking
on the dropdown icon or by right-clicking on the notebook tabs. Note that when splitting
the editor area, each new split will show the same files as all others; this allows for editing
multiple parts of the same file.

Splitting your editor area or creating a separate Help tool window may make it much

easier to get around this tutorial.

The number of splits shown by default in tool boxes will vary depending on the size of your
monitor.

Minimizing Tool Boxes -- By clicking on an already-active tool tab in one of the tool
boxes, the entire area will be minimized down so that only the tabs for the area are visible.
Clicking again on any tab will restore the tool box to its previous size. Or, use F1 and
F2 to toggle the state of the two tool boxes. This is a convenient way to increase space
available to the editor or other tool box.

Shift-F2 can also be used to maximize the editor area temporarily, hiding the tools and
toolbar until Shift-F2 is pressed again.

Moving and Adding Tools -- Tools can be moved among the tool boxes or out to
separate windows by using the tool box option menu. Additional instances of any tool can
be created from the tool box option menu or in a separate window from the Window menu.

Adding Document Windows -- Additional document windows can also be created from
the Window menu. Each separate document window contains its own set of open files.

Editor Personality -- If you are used to another editor such as Visual Studio, VI or Vim,
Emacs, or Brief, you may want to put Wing into a more familiar keyboard mode using the
Personality preference. Be sure to click OK or Apply so the changes take effect.

Other Options -- Source Code Font/Size and Display Font/Size can be altered.
The toolbar’s appearance can be changed using the Toolbar Size and Toolbar Style
preferences. The tool boxes can be moved from right to left or bottom to top. The
editor option menu allows selecting between using notebook tabs or a popup menu to
navigate between open editors.

For more information on adjusting the user interface to your needs, see the Customization
chapter of the manual.
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1.3. Tutorial: Check your Python Integration

Before starting with some code, let’s make sure that Wing has succeeded in finding your
Python installation (the latest version is preferred if you have multiple versions installed).
To check this, bring up the Python Shell tool. After a moment, it should show you the
Python command prompt like this:

If this is not working, or the wrong version of Python is being used, you can point Wing in
the right direction with the Python Executable setting in Project Properties, available
from the toolbar and Project menu. You will need to Restart Shell from Options in
the Python Shell tool after altering this property.

Once the shell works, copy/paste or drag and drop these lines of Python code into it:

for i in range(0, 10):

print ’ ’ * (10 - i) + ’*’ * i

This should print a triangle as follows:
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Notice that the shell removes common leading white space when blocks of code are copied
into it. This is useful when trying out code from source files.

You can create as many instances of the Python Shell tool as you wish; each one runs in
its own private process space that is kept totally separate from Wing IDE and your debug
process.

1.4. Tutorial: Set Up a Project

Now we’re ready to get started with some coding. The first step in working with Wing
IDE is to set up a project file so that Wing can find and analyze your source code and
store your work across sessions.

Wing starts up initially with the Default Project. To create a new project separate from
the Default Project, select New Project from the Project menu now.

Next, add your source files to the project. You can do this with the Add items in the
Project menu, or by right clicking on the Project tool. For the purposes of this tutorial,
use Add Directory Tree to add all files in your copy of the tutorials directory.

Once your files have been added, save the project to disk from the Project menu. Use
tutorial.wpr as the project file name and place it in your tutorials directory.

Browsing Files

Files in your project can be opened by double clicking or right-clicking on the file list.
When the Follow Selection item in the Options menu at top right is checked, Wing will
also display the source code for files that are single clicked. However, these files are opened
“non-sticky” so that they are automatically closed again when another file is brought up.
This is indicated with the stick pin icon in the top right of the editor area:

-- Indicates the file is opened permanently until it is closed explicitly by the user.

-- Indicates that the file is opened transiently and will auto-close except if it is edited.

Clicking on the pin icon toggles between the modes as long as the file doesn’t contain
unsaved edits. Right-clicking on the icon displays a menu of recently visited files. Note
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that this contains both transient and non-transient files, while the Recent list in the File

menu contains only non-transient files.

The number of transient editors to keep open, in addition to those that are visible is set
with the Transient Threshold preference.

This mechanism helps to prevent huge numbers of files being opened when stepping in the
debugger or using the source browser, search manager, and other tools to browse files.

Note that you can alter the project display to sort files into a deep hierarchy, a flattened
hierarchy, or by mime type. These are available from the Options menu in the project
view.

Configuring PYTHONPATH

Whenever your Python source depends on PYTHONPATH (either set externally or by altering
sys.path internally), you will also need to tell Wing about your path. This value can be
entered from the Project Properties dialog, which is accessible from the Project menu
and the toolbar.

For this tutorial, you will at least need a PYTHONPATH that includes the subdir sub-directory
of your tutorials directory as shown in the figure above. This contains a module used as
part of the first coding example.
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Note that the PYTHONPATH is set up with the full path to the directory subdir. This
is strongly recommended because it avoids potential problems finding source code when
the starting directory is ambiguous, both for source code analysis purposes and in Wing’s
debugger. A partial path can be specified but Wing will issue a warning explaining why
this is a bad idea.

The configuration is used here for illustration purposes. You could easily run the example
code without a PYTHONPATH by moving the path_example.py file to the same location as
the example scripts, or by placing it into your Python installation’s site-packages directory.
Either of these allows Python to find the modules without altered PYTHONPATH.

1.5. Tutorial: Auto-completer and Source Assistant

By now Wing will have found and analysed the tutorial examples, and all the modules that
are imported and used by them. This analysis process runs in the background and allows
Wing to present you with better support during inspection and editing of code. With
larger code bases, you may notice the CPU load from this process, but with this tutorial
the analysis will happen instantaneously after the project has been configured.

The editor’s auto-completer is the most important analysis-driven tool in Wing IDE.

To try this out, scroll down to the bottom of example1.py and enter the following code
by typing (not pasting) it into the file:

news = Re

Notice that Wing shows you a popup menu of completion options as you type. You can
press tab to enter the currently selected value, or scroll around in the list with the arrow
keys. When you typed“news”this completer wasn’t helpful because you had not yet defined
news as a symbol in your source. However, once you move on to type “ = Re“, Wing will
display another completion list with ReadPythonNews highlighted.

Next, press the Tab key to enter the completion of ReadPythonNews and enter (. You
should now have this code in your editor:

news = ReadPythonNews(

If you are used to using the Enter key for auto-completion, add it to the Completion
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Keys preference.

Duplicate substitution definition name: “note”.

Now continue entering the rest of the source line so you have the following almost-complete
line of source code (the trailing ) is missing:

news = ReadPythonNews(GetItemCount()

Press enter a few times. Note that Wing IDE auto-indents the subsequent lines and adds
red error indicators under them shortly after you stop typing. This indicates that there is
a syntax error in your code:

Once you correct the line and complete it by typing the final ), the error indicators will be
removed. You should now have this complete line of code in your file:

news = ReadPythonNews(GetItemCount())

Then enter the following two additional lines of code:

PrintAsText(news)

PrintAsHTML(news)

At this point you have a complete program that can be run in the debugger. There are
many other editor features worth learning, but we’ll get back to those later in this tutorial.
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1.6. Tutorial: Debugging

In case you haven’t already figured it out, the example1.py program you have created
connects to python.org via HTTP, reads and parses the Python-related news feed that is
hosted there, and then prints the most recent five items as text and HTML. Don’t worry if
you don’t have an internet connection on your machine; the script has canned data it will
use when it cannot connect to python.org.

To start debugging, set a breakpoint on the line that reads return 5 in the GetItemCount

function. This can be done by clicking on the line and selecting the Break toolbar item,
or by clicking on the dark margin to the left of the line. The breakpoint should appear as
a filled red circle:

Next start the debugger from the toolbar or the Debug menu. Wing will show the Debug
Properties dialog with the properties that will be used during the debug run. Just ignore
this for now, uncheck the Show this dialog before each debug run checkbox at the
bottom, and press OK.

Wing will run to the breakpoint and stop, placing a red indicator on the line. Notice that
the toolbar changes to include additional debug tools, as shown below:

Your display may vary depending on how you have configured the Toolbar Size and
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Toolbar Style preferences. Note that Wing displays tooltips explaining what the tools
do when you mouse over them.

Now you can inspect the program state at that point with the Stack Data tool and by
going up and down the stack from the toolbar or Debug menu. The stack can also be
viewed as a list using the Call Stack tool.

Notice that the Debug status indicator in the lower left of Wing’s main window changes
color depending on the state of the debug process. Mouse over the indicator to see detailed
status in a tooltip:

Next, try stepping out to the enclosing call to ReadPythonNews. In this particular context,
you can achieve this in a single click with the Step Out toolbar icon or Debug menu item
(two clicks on Step Over also work). This is a good function to step through in order to
familiarize yourself with the basic debugger features covered above.
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1.6.1. Tutorial: Debug I/O

Before leaving ReadPythonNews bring up the Debug I/O tool so you can watch the
subsequent output from the program. This is also where keyboard input takes place in
debug code that requests for it.

Once you step over the line PrintAsHTML(news) you should see output appear as follows:

Note that you can also configure Wing to use an external console from the Options menu
in the Debug I/O tool. This is useful for code that depends on details of the Debug I/O
environment (such as cursor control with special output characters).

1.6.2. Tutorial: Debug Process Exception Reporting

Wing’s debugger tries to detect whether an exception is handled (part of normal operation)
or unhandled (resulting in abnormal program termination). This test is done each time an
exception is raised in the debug process. If an exception looks unhandled Wing will stop
immediately on it so you can inspect the live program state that led to the exception.

Try this out by continuing execution of the debug process with the Debug toolbar item or
Start / Continue item in the Debug menu.

Wing will stop on an incorrect line of code in PrintAsHTML and will report the error in the
Exceptions tool:
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Notice that this tool highlights the current stack frame and that you can click on frames
to navigate the exception backtrace. Whenever you are stopped on an exception, the
Debugger Status indicator in the lower left of Wing’s main window turns red.

Avoiding False Positives

In some cases, Wing IDE will incorrectly flag a normal exception as unhandled and will
stop on it. This happens when the exception is handled in C/C++ extension module code.
You can train Wing to ignore these with the Ignore this exception location checkbox
from the Exceptions tool. Wing will remember your choice and will not stop on them
again.

Alternatively, use the Exception Reporting preference to turn off the unhandled ex-
ception detector by selecting the At Process Termination option. However, this will not
work well with wxPython, PyGTK, externally launched debug processes, and in some other
cases. For most users, we recommend keeping the unhandled exception detector enabled.

For more information, see Managing Exceptions.
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1.6.3. Tutorial: Other Debugger Features

Before moving on to the rest of the IDE’s features, here are a few highlights of the debug-
ger’s other capabilities that are worth knowing about from the start:

• Main Debug File -- You can specify one file in your project as the main entry
point for debugging. When this is set, debugging will always start there unless you
use the Debug Current File item in the Debug menu. To set a main debug file, use
Set Current as Main Debug File in the Debug menu or by right-clicking on the
file in the project and selecting Set As Main Debug File from the context menu
that appears.

When set, the main debug file can be cleared with the Clear Main Debug File item
in the Debug menu. Once cleared, debugging always starts in the current editor file.
Which mode you use depends on the nature of your project.

• File Properties -- Each file in your project can override or modify your project-wide
debug properties. This is useful in projects with multiple debug entry points. File
properties can also be used to specify command line arguments for debugging. They
are accessed from the Current File Properties item in the Source menu or by
using File Properties in the editor or project context menus:

• Remote Debugging -- Wing can debug processes that are running under a web
server, as part of Zope or Plone, or that get launched from the command line and not
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from Wing. This is beyond the scope of this tutorial, and is described in Debugging
Externally Launched Code and in the Zope, Plone, and mod python quick
start guides.

1.7. Tutorial: Searching

Wing IDE provides several different interfaces for searching your code. Which you use
depends on your task.

Toolbar Search

A quick way to search through the current editor is to enter your search string in the area
provided in the toolbar:

If you enter only lower case the search will be case-insensitive. Entering one or more
upper-case letter causes the search to become case-sensitive.

Try this now in example1.py: Type GetItem in the toolbar search area and Wing will
immediately, starting with the first letter typed, search for matching text in the editor.
Notice that if you press the Enter key, Wing will move on to the next match, wrapping
around to the top of the file if necessary.

Toolbar-based searches always go forward (downward) in the file from the current cursor
position.

Keyboard-driven Search

If you prefer to search without your fingers leaving the keyboard, use the key bindings
given next to the Mini-search items in the Edit menu.

From here, you can initiate searching forward and backward in the current editor, optionally
using the current selection in the editor as the search string. You can also initiate replace
operations.
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Try this in the example1.py file: If using the default editor mode, press the Ctrl-U. If
you are using emacs mode, press Ctrl-S. For others, refer to the Mini-search group in
the Edit menu.

This will display an entry area at the bottom of the IDE window and will place focus there:

Continue by typing G, then e, then t. Notice how Wing searches incrementally with each
keypress. This lets you type only as much as you need to find the source code you are
looking for.

While the mini-search area is still active, try pressing the same key combination you used
to display it again (Ctrl-U or Ctrl-S in emacs mode) and Wing will search for the next
matching occurrence. Note that if no match is found Failed Search will be displayed.
However, pressing the mini search key combination again will wrap around and start search-
ing again at the top of the file.

As in the toolbar search, typing lower case letters results in case-insensitive search, and
using one or more upper case letters results in case-sensitive search.

Search direction can be changed during searching by pressing the key bindings assigned to
forward and backward mini-search. You can exit from the search by pressing the Esc key
or Ctrl-G in emacs mode.

Keyboard-driven mini-replace works similarly, except that you will be presented with two
entry areas, one for your search string and one for the replace string. Use Query/Replace

to be prompted for Y and N for each replace location, and Replace String to replace all
matches globally in the file.

Search Tool

The Search tool provides a familiar GUI-based search and replace tool for operating on
the current editor. Key bindings for operations on this tool are given in the Search and

Replace group in the Edit menu.

Searches may span the whole file or be constrained to the current selection, can be case
sensitive or insensitive, and may optionally be constrained to matching only whole words.

By default, searching is incremental while you type your search string. To disable this,
uncheck Incremental in the Options menu.
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Replacing

When the Show Replace item in Options is activated, Wing will show an area for entering
a replace string and adds Replace and Replace All buttons to the Search tool:

Try replacing example1.py with search string PrintAs and replace string OutputAs.

Select the first result match and then Replace repeatedly. One search match will be
replaced at a time. Search will occur again after each replace automatically unless you
turn off the Find After Replace option. Changes can be undone in the editor, one at a
time. Do this now to avoid saving this replace operation.

Next, try Replace All instead. Wing will simply replace all occurences in the file at the
same time. When this is done, a single undo in the editor will cancel the entire replace
operation.

Wildcard Searching

By default, Wing searches for straight text matches on the strings you type. Wildcard and
regular expression searching are also available in the Options menu.

The easier one of these to learn is wildcard searching, which allows you to specify a search
string that contains *, ?, or ranges of characters specified within [ and ]. This is the
same syntax supported by the Python glob module and is described in more detail in the
Search Tool manual page.

Try a wildcard search now by selecting Wild Card from the Options menu and making sure
example1.py is your current editor. Set the search string to PrintAs*(. This should dis-
play find matches, all occurences of the string PrintAs, followed by zero or more characters,
followed by (:
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Also try searching on PrintAs*[A-Z]( with the Case Sensitive search option turned
on. This matches all strings starting with PrintAs followed by zero or more characters,
followed by any capital letter, followed by (.

Finally, try PrintAsT???, which will match any string starting with PrintAsT followed by
any three characters (? matches any single character).

Wild card searching can be very useful for finding related source symbols all at once.

Regular Expression Search

Regular expressions can also be used for searching. These are most useful for complicated
search tasks, such as finding all calls to a particular function that occur as part of an
assignment statement.

For example, open\(newscache( )?,.*\) matches only calls to the function open where
the first argument is named newscache and there are at least two parameters. If you try
this with example1.py, you should get exactly one search match:



23

The details of regular expression syntax and usage can be very complicated, so this tutorial
does not cover them. For that, see the Regular Expression Syntax documentation in the
Python manual.

Search in Files Tool

The Search in Files tool is the most powerful search option available in Wing IDE
Personal. It supports multi-file batch search of the project, open editors, or other sets of
files. It can also search using wildcards and can do regular expression based search/replace.

http://wingware.com/psupport/python-manual/2.3/lib/re-syntax.html
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Before worrying about the details, try a simple batch search on the example1.py file. Select
Current File from the Look in selector on the search manager (these are the defaults).
Then enter PrintAs into the search area.

Wing will start searching immediately, restarting the search whenever you alter the search
string or make other changes that affect the result set. When you are done, you should see
results like those shown in the screen shot above. Click on the first result line to select it.
This will also display example1.py with the corresponding search match highlighted.

You can use the forward/backward arrows in the Search in Files manager to traverse your
results.

File Sets

Next, change the Look in selector to All Files in Project and change your search
string to HTML. This works the same way as searching a single file, but lists the results for
all files in your project. You can also search all currently open files in this way.

In many cases, searching is better constrained to a subset of files in your projects. For
example, only Python files. This can be done with by selecting Python Files in the
Filter selector. You can also define other file sets using the Create/Edit File Sets...

item in the Filter Selector. This will display the File Sets preference:
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Each file set has a name and a list of include and exclude specifications. Each of these
specifications can be applied to the file name, directory name, or the file’s MIME type. A
simple example would be to specify *.pas wildcard for matching Pascal files by name, or
using the text/html mime type for all HTML files.

Multi-File Replace

When working with multiple files in the result set, Wing will by default open each changed
file into an editor, whether or not it is already open. This allows you to undo changes by
not saving files or by issuing Undo within each editor.

An alternate replace mode is also available from the Options menu. If you check the Re-

place Operates on Disk item, Wing will change files directly on disk instead of opening
editors into the IDE. This can be much faster but is not recommended unless you have a
revision control system that can get you out of hot water when mistakes are made.

Note that even when operating directly on disk, Wing will replace changes in already-open
editors only within the IDE. This avoids creating two versions of a file if there are already
edits in the IDE’s copy. We recommend closing all editors when working in Replace

Operates on Disk mode, or select Save All from the file menu immediately after each
replace operation. This avoids losing parts of a replace, which might lead to inconsistent
application of the replace operation to the files in your source base.

1.8. Tutorial: Other IDE Features

There are a number of other features available in the IDE that are worth noting:

Source Index -- The top of the editor area displays a series of popup menus that act as
an index into Python source files. Select from them to navigate around your source file.

Try this out by opening example2.py from your tutorial directory. If you place the
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cursor on the line that reads print "nested2", you should see the following in the source
index area:

Each subsequent menu lists the symbols available within the preceding nested context.

If you have turned off Show Notebook Tabs in the Editor Options Menu, the file selector
menu will be prepended as follows:

Goto-Definition -- There are a number of ways to navigate to the point of definition of
symbols in your source code. One is to right-click on the symbol and select Goto Defi-

nition. Another is to move the insertion cursor to the symbol and select Goto Selected

Symbol Defn from the Source Menu (or press F4). The Source Assistant also contains
links to points of definition.

Try this from example2.py with some of the symbols imported from htmllib, such as
HTMLParser in the class definition for MyHTMLParser. Remember that the file htmllib.py

is opened in non-sticky mode and will auto-close unless you toggle the stick pin icon to

or edit the file.

Duplicate substitution definition name: “stickpin-stuck”.

Goto-Line -- Navigate quickly to a numbered source line with the Goto Line item in the
Edit menu. In emacs mode, the line number is typed into the data entry area that appears
at the bottom of the window. Press Enter to complete the action.

Keyboard-driven File Open -- Try the Open from Keyboard item in the File menu:
This displays an interactive file selector at the bottom of the IDE window that can be
much quicker for opening files than using the standard file selection dialog and allows file
selection without moving your hands from the keyboard. Use Esc to cancel or Enter to
select a file and the arrow keys to browse around the auto-completion list that it presents
as you type.
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Auto-Indentation -- Wing auto-indents lines as you type according to its static analysis
of your code. This can be disabled with the Auto-Indent preference.

Another way in which Wing uses code analysis is in auto-indentation as you type, and for
altering indentation or wrapping of code. For example, when you select a block of code
and press the tab key, the entire block is re-indented according to the correct position of
its first line relative to the preceding non-blank line of code. The Justify Text option in
the Source menu also uses the source analyser to constrain re-wrapping to a single logical
line of Python code.

Block Indentation -- The Tab key is defined to indent the current line or blocks of lines,
rather then entering a tab character (which can be done with Ctrl-Tab). The Tab Key
Action preference can be used to customize how the tab key behaves.

One or more selected lines can be increased or reduced in indentation from the Indentation
toolbar group, which contains the following icons for this purpose:

Single lines or whole blocks can also be indented automatically to their appropriate position,
as determined by analysis of the preceding line. If a range of lines is selected, the whole
block is indented or outdented without changing the relative indents within the block. This
is done from the following toolbar icon:

Note that the indentation features are also available in the Source menu, where their key
bindings are listed.

Block Commenting -- Units of code can be commented out or un-commented quickly
from the Source menu.

Brace Matching -- Wing highlights brace matching as you type unless disabled from
the Auto Brace Match preference. The Match Braces item in the Source menu causes
Wing to select all the code that is contained in the nearest matching braces found from the
current insertion point on the editor. Repeated application of the command will traverse
outward and forward in the file.

Text Reformatting -- Code can be re-wrapped with the Justify Text item in the
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Source menu. This will limit wrapping to a single logical line of code, so it can be used
for wrapping an argument list or long list or tuple without altering surrounding code.

Converting Indentation Styles -- Wing’s Indentation tool can be used to analyze
and convert the style of indentation found in source files. See Indentation Manager for
details.

1.9. Tutorial: Further Reading

Congratulations! You’ve finished the tutorial. As you work with Wing IDE on your own
software development project, the following resources may be useful:

• Wing IDE Support Website

• Wing IDE Reference Manual

• OS X Quickstart

• Zope Quickstart

• Plone Quickstart

• wxPython Quickstart

• PyGTK Quickstart

• PyQt Quickstart

• mod python Quickstart

• PyGame Quickstart

http://wingware.com/support


Migrating from Wing IDE 1.x

Moving to Wing IDE 2.x from Wing IDE 1.x should be relatively painless. The first time
you start Wing IDE 2.x, it will automatically convert your preferences from Wing IDE 1.x
and place them into your User Settings Directory (note location of this directory has
changed).

• Licensing

Wing IDE 2.x runs on a new license manager that cannot use Wing IDE 1.1 licenses. Trial
licenses are now obtained directly from the product, and all licenses are activated (bound
to a particular host) before they can be used. More information is available in Licenses

Wing IDE 1.1 licenses can be upgraded in our online store -- for free if purchased on or
after August 28th, 2003, or for half price if purchased before that date.

• Converting Projects

Wing IDE 1.x project files will be converted as they are opened and marked untitled so
they can be saved under a new name. You should not overwrite your old project files as
long as you still plan to use Wing IDE 1.x. Wing IDE 2.x project files cannot be read by
Wing IDE 1.x.

• Customizing the User Interface

Wing IDE 2.0 introduced an almost completely redesigned user interface. While the basic
“feel” of the application from the keyboard should be similar, the layout of the interface
is quite different and offers many more customization options. See the Customization
chapter of the manual to learn how to reconfigure your interface.

For those that prefer the old multi-window approach found in Wing IDE 1.1, see the
Windowing Policy preference. Also, even in combined window mode you can create as
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many document windows as you wish and move tools and editors out to separate windows
or among existing windows. Your configuration will be remembered in your project file.

• New Features

These are the major new features introduced by Wing IDE 2.x:

New User Interface -- Redesigned for better work-flow and flexibility, the new interface
(based on Gtk2) also looks much better, and is highly customizable.

Redesigned Search Manager -- This now supports multi-file search and replace, wild cards,
and regular expressions. The new search manager is also useful in designing and testing
regular expressions.

Integrated Help -- All Wing IDE documentation is now available directly within the IDE
from the Help menu and in many cases via tool tips displayed when the mouse hovers over
areas of the user interface.

Integrated Debug I/O -- Debug process I/O now appears in the Debug I/O tool within the
IDE, although using an external console is still an option.

German Localization -- German versions of the user interface and documentation are now
available.

Redesigned Source Context Menus -- These appear at the top of the editor area as a series
of menus, one for each nested scope at the current insertion point, rather than as a single
huge heirarchical menu.

Optional Editor Tabs -- Select among files using notebooks tabs or a popup menu at the
top of the editor.

Integrated Bug Reporting and Feedback -- Use the Help menu items to report bugs or submit
feedback directly from the product.

New License Manager -- Provides easier trial licensing and installation of purchased li-
censes, and adds license activation to help companies track license usage and to reduce the
impact of casual license sharing.

Message Manager -- Keeps a log of status messages by sub-system.



Why Use Wing IDE?

Wing IDE is a powerful software development environment for Python programmers. By
cutting down on coding and debugging time, Wing can help you build quality code more
rapidly.

“The best Python IDE currently available.”

-- Stephen Scherer, Ed.D., Jan 2004

“A real power tool to use for the development and debugging of
complex Python applications”

-- InformIT, Sep 2001

• Faster, more accurate coding -- Wing presents you with context-appropriate code
completion options and documentation, offers quick navigation to point of definition,
and flags syntactical errors as you type your code. A plethora of keyboard-driven
search and editing features, including Vim, Emacs, Visual Studio, and Brief keyboard
bindings, keep plenty of coding power at your fingertips.

• Speedier debugging -- Wing finds bugs fast by detecting and stopping immediately
on unexpected exceptions, letting you step through and inspect your code in the
context of the problem. Conditional breakpoints, symbolic and object reference value
tracking, and command line interaction with your paused debug program speed the
process of isolating a bug and designing a fix for it. Flexible launch options and remote
debugging allows working with code in context, even if running under a web server,
Zope or Plone, embedded as a scripting language, or launched from the command
line.

• Quicker code learning -- Wing lets you understand unfamiliar code quickly, using
its powerful search capabilities, source code browser, editor navigation menus, goto-
definition, and the debugger’s ability to watch programs in action.
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More product information is available on our website at www.wingware.com.

http://www.wingware.com/

