[wingide-users] wing 5 and pylint 1.1?

Chris Curvey chris at chriscurvey.com
Tue Mar 18 14:25:50 EDT 2014


yeah, hacking kPyLintVersion fixed that just fine.

FWIW, I also set

args = "--generated-members=objects,DoesNotExist"

in pylinkpanel.cfg.  I'm sure I will have to do others as well.  I tried
setting up a pylintrc, but I'm having troubles with that. (And my inability
to set up pylintrc is my problem, not a Wing problem)


On Tue, Mar 18, 2014 at 2:17 PM, Wingware Support <support at wingware.com>wrote:

> Chris Curvey wrote:
>
>> I've decided to try out PyLint with wing5.  I've worked through the
>> instructions, but when I try to "update" the tool, I get
>>
>> pylint: error: no such options: --include-ids
>>
>> that seems to be a deprecated option in version 1.1.
>>
>> Is this fix for this to change the value of kPyLintVersion in
>> pylintpanel.py?
>>
>
> I suspect _init_pylint_version() in pylintpanel.py is not working right
> for some reason.  --include-ids should only be added for very old versions
> of PyLint.  You could try to debug that by putting in print statements or
> just set kPyLintVersion to '1.1.0' to hack around the problem.
>
> I've added this to our list of things to try here but won't have time to
> get to it immediately.
>
> --
>
> Stephan Deibel
> Wingware | Python IDE
>
> The Intelligent Development Environment for Python Programmers
>
> wingware.com
>
>


-- 
I asked the Internet how to train my cat, and the Internet told me to get a
dog.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/wingide-users/attachments/20140318/d998a790/attachment.html>


More information about the wingide-users mailing list