[wingide-users] Wing IDE won't start on Mac OS X Mavericks after specifying DYLD_LIBRARY_PATH

Trevor T tsnipez at gmail.com
Mon Mar 3 15:22:29 EST 2014


Hi Stephan,

Thank you for the example, that did the trick!  I originally had it
formatted in bash-style, acceptable for the .profile file, but then I tried
reformatting it as:

DYLD_LIBRARY_PATH=/Users/owner/anaconda/lib

Thanks again,
Trevor


On Mon, Mar 3, 2014 at 1:16 PM, Wingware Support <support at wingware.com>wrote:

> Trevor T wrote:
>
>> I've discovered that if I specify the DYLD_LIBRARY_PATH variable in my
>> ~/.profile file, Wing IDE will not start.  Unfortunately, I need to specify
>> this variable to run the latest development version of sklearn compiled
>> from source, otherwise it complains it can't find "libmkl_intel_lp64.dylib".
>>
>> I've tried setting the variable in the Project Properties but that
>> doesn't seem to do anything either.  Perhaps my formatting is not correct
>>
>
> It should work to set it in Project Properties.  Are you using ':' as the
> path delimiter?  Here's a slightly complicated example that uses ${env}
> references (which Wing will resolve), taken from the project that I use to
> debug Wing 5 with itself:
>
> WINGHOME=/Users/sdeibel/src/ide
> PYSIDESANDBOX=${WINGHOME}/bin/sandbox
> PYRUNTIME=${WINGHOME}/bin/runtime-python2.7
> QTRUNTIME=${WINGHOME}/bin/runtime-qt
> PYSIDERUNTIME=${WINGHOME}/bin/runtime-pyside-py2.7
> DYLD_LIBRARY_PATH=${PYRUNTIME}/lib:${QTRUNTIME}/lib:${PYSIDERUNTIME}/lib
> DYLD_FRAMEWORK_PATH=${PYRUNTIME}/lib:${QTRUNTIME}/lib:${PYSIDERUNTIME}/lib
>
>
> Please let me know if this doesn't help.
>
>
> Thanks,
>
> --
>
> Stephan Deibel
> Wingware | Python IDE
>
> The Intelligent Development Environment for Python Programmers
>
> wingware.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/wingide-users/attachments/20140303/2ddd8a23/attachment.html>


More information about the wingide-users mailing list