[wingide-users] Wing IDE 5, Python 3.4 beta 1 on Windows 8

Brian Gladman brg at gladman.plus.com
Sat Dec 7 07:40:26 MST 2013


I noticed that Wing IDE 5 had been updated for the upcoming Python 3.4
so out of interest I tried the Python 3.4 beta with WING.

But it has problems and won't run any of my existing code - it gives the
following if I try to run a program (or the Python shell):

-----------------------------------------------------------------------
Trying to import netserver from C:\Program Files (x86)\Wing IDE
5.0\bin\3.4\src\debug\tserver
Unable to import findmodules
Trying to import netserver from C:\Program Files (x86)\Wing IDE
5.0\src\debug\tserver
Unable to import findmodules
Traceback (most recent call last):

  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 621, in
main
    netserver = FindNetServerModule(winghome, user_settings, tmp_log)

  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 440, in
FindNetServerModule
    raise ImportError('Could not import netserver')

ImportError: Could not import netserver

wingdb.py: Error: Failed to start the debug server
wingdb.py: Error: You may be running an unsupported version of Python
wingdb.py: Python version = 3.4.0b1 (v3.4.0b1:3405dc9a6afa, Nov 24 2013,
19:18:21) [MSC v.1600 64 bit (AMD64)]
wingdb.py: WINGHOME='C:\\Program Files (x86)\\Wing IDE 5.0'
Trying to import netserver from C:\Program Files (x86)\Wing IDE
5.0\bin\3.4\src\debug\tserver
Unable to import findmodules
Trying to import netserver from C:\Program Files (x86)\Wing IDE
5.0\src\debug\tserver
Unable to import findmodules
Traceback (most recent call last):

  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 621, in
main
    netserver = FindNetServerModule(winghome, user_settings, tmp_log)

  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 440, in
FindNetServerModule
    raise ImportError('Could not import netserver')

ImportError: Could not import netserver

wingdb.py: Error: Failed to start the debug server
wingdb.py: Error: You may be running an unsupported version of Python
wingdb.py: Python version = 3.4.0b1 (v3.4.0b1:3405dc9a6afa, Nov 24 2013,
19:18:21) [MSC v.1600 64 bit (AMD64)]
wingdb.py: WINGHOME='C:\\Program Files (x86)\\Wing IDE 5.0'
Traceback (most recent call last):
  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 621, in
main
    netserver = FindNetServerModule(winghome, user_settings, tmp_log)
  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 440, in
FindNetServerModule
    raise ImportError('Could not import netserver')
ImportError: Could not import netserver

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "C:\Program Files (x86)\Wing IDE 5.0\bin\wingdb.py", line 634, in
main
    sys.exit(-1)
SystemExit: -1
-----------------------------------------------------------------------

I am wondering if there is any way around this as it would be nice to
try out 3.4 without losing my favourite Python IDE.

   with my best regards,

       Brian Gladman



More information about the wingide-users mailing list