[wingide-users] Wing 4.1 logs me out during startup

Wingware Support support at wingware.com
Mon Apr 22 08:51:19 EDT 2013


Catherine Devlin wrote:
> I'm having a bizarre problem: when I start Wing 4.1, the Wingware logo 
> flashes as it begins to come up, and then I'm logged out of my machine.
>
> I'm running on Ubuntu 12.10.  I've used this combination (Wing 4.1 + 
> Ubuntu 12.10) for months, and have only started having the problem 
> this morning.  My only recent system change was installing f.lux, but 
> I removed f.lux, rebooted the machine, and the problem remains.
>
> Sorry this isn't much useful information; I can't even tell you the 
> precise version number I'm using, because I can't start Wing to find 
> out.  (I do have automatic check for updates set, though, so I think 
> it must be the latest.)  Is there a logfile somewhere that would give 
> more light on what's happening?  I don't see anything relevant-looking 
> at the tail of /var/log/syslog.

Wow, that's pretty weird. The log file for Wing is 
~/.wingide4.1/error-log.  Can you email that to support at wingware.com?

The only way Wing I could see Wing causing this directly is if you have 
something in a script that does it (the top level of script files is 
executed at startup time, as in any module load).  Those are in 
~/.wingide4/scripts, /usr/lib/wingide4.1/scripts, and any other 
directory given in main.script-path preference ~/.wingide4/preferences 
(look w/ a text editor, since you can't get at the preferences GUI in 
Wing).  The one under /usr/lib should really not contain anything other 
than what Wing puts there, so you might try checking if anything there 
has changed since installation, but some features are implemented in 
scripts so just removing those is not a good permanent solution.

Please let me know if this does not help.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com


More information about the wingide-users mailing list