[wingide-users] no problem with numpy in Wing IDE, but...

rzn8tr raycores at gmail.com
Tue Sep 25 00:15:43 EDT 2012


On Win7-64: If I run my program from with Wing IDE, it runs fine and does not
display any errors.  If I run it from the Command Prompt, using the same
path to the Python executable as I have set in Wing IDE, it fails with an
error when trying to import numpy:

    import numpy as np
  File "c:\Python27\lib\site-packages\numpy\__init__.py", line 143, in
<module>
    import add_newdocs
  File "c:\Python27\lib\site-packages\numpy\add_newdocs.py", line 9, in
<module>
    from numpy.lib import add_newdoc
  File "c:\Python27\lib\site-packages\numpy\lib\__init__.py", line 13, in
<module>
    from polynomial import *
  File "c:\Python27\lib\site-packages\numpy\lib\polynomial.py", line 17, in
<module>
    from numpy.linalg import eigvals, lstsq
  File "c:\Python27\lib\site-packages\numpy\linalg\__init__.py", line 48, in
<module>
    from linalg import *
  File "c:\Python27\lib\site-packages\numpy\linalg\linalg.py", line 23, in
<module>
    from numpy.linalg import lapack_lite
ImportError: DLL load failed: The specified module could not be found.

Why the difference?

On the slight chance that it is related, I'll mention that I'm trying to
chase down a problem where the pyinstaller packaged version of the program
runs fine on my win7 dev machine, but fails because it can't find two files
on three other machines I have tried.  I don't know why the file name
changes between machines.
1. mk2_mc.dll,  mk2_def.dll
2. mk2_avx.dll, mk2_def.dll
3. mk2_mc3.dll, mk2_def.dll 

I was attempting to track down when these modules are loaded by running
python in verbose mode. 




--
View this message in context: http://wingide.992054.n4.nabble.com/no-problem-with-numpy-in-Wing-IDE-but-tp4655226.html
Sent from the WingIDE - User mailing list archive at Nabble.com.


More information about the wingide-users mailing list