[wingide-users] Annoying keyboard issues

Wingware Support support at wingware.com
Wed May 23 15:01:34 MDT 2012


Tom Stambaugh wrote:
> I've just started using Wing IDE Pro v4.1.6-1 on my brand-new 
> MacBookPro (which I think is running "Lion"). I've been using Wing on 
> Windows and Linux for years. For better or worse, Wing runs in X11 on 
> the Mac.
>
> I'm having some truly annoying issues with keyboard support. 
> Sometimes, for reasons that escape me, Wing simply stops responding to 
> keystrokes. The mouse works fine, but it's as though my keyboard is 
> disconnected.
>
> On the Mac, I seem to be able to get things going again by 
> mouse-clicking a few Wing windows.
>
> I've seen this a few times on my Windows 7 machine as well. So far, in 
> Windows 7, I've needed to restart Wing to get the keyboard back.
>
> Am I the only one seeing these problems?

On the Mac it might be caused by using the X11 provided by Apple instead 
of the latest XQuartz.  I'm not sure what would cause this on Windows.  
Is that in a vm or on a separate machine?

I've also seen something like this on my Mac but it's dead for 
everything and I need to unplug and replug my keyboard.  In my case it's 
might be caused by a combination of a weird ergonomic keyboard, vmware, 
and xquartz but I've never been able to narrow it down.  Probably not 
the same thing as what you're seeing but seemed worth mentioning.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list