[wingide-users] Confused about OS Commands tool box display of unicode data.

Przemysław Lib an.przemek at gmail.com
Mon Mar 19 01:04:11 MDT 2012


Hi!

I do not know "OS Command" whatever. :D I'm new!
However your problem may be related to different python installation
present on your computer.
In IDE you run it under Python x and outside IDE you run it in Python y.
Make sure that you run trouble-free your app outside IDE* on the same
python *you have provided for wingide!

PS Provide your python versions. (all of them if you have multiple)


2012/3/18 Barry Mossman <BarryMossman at primos.com.au>

> Hi I have read some data from text file encoded with utf-8 as follows:****
>
> ** **
>
> with codecs.open(filename='playcounts.txt', mode='r', encoding='utf-8') as
> scrobble_file:****
>
>             data = scrobble_file.readline()****
>
> ** **
>
> I then print the data with a print statement.****
>
> ** **
>
> If I do this in the debugger, or run the program externally outside the
> IDE, the displayed output is as expected.****
>
> ** **
>
> If I run the program using the OS Comands tool box the print statement
> fails with “'ascii' codec can't encode character u'\xe1' in position 6:
> ordinal not in range(128)”****
>
> ** **
>
> Is there something I need to configure with regard to the OS Commands
> toolbox. ****
>
> ** **
>
> I tried the Edit|Preferences|Debugger|IO options, but could find anything
> for the OS Command toolbox display.****
>
> ** **
>
> I am running on Windows. Wing v4.1.3-1****
>
> ** **
>
> Thanks.****
>
> ** **
>
> ** **
>
> _________________________________________________
> Wing IDE users list
> http://wingware.com/lists/wingide
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/wingide-users/attachments/20120319/a1a5dfed/attachment.html>


More information about the wingide-users mailing list