[wingide-users] Confused about OS Commands tool box display of unicode data.

Barry Mossman BarryMossman at primos.com.au
Sun Mar 18 06:50:09 MDT 2012


Hi I have read some data from text file encoded with utf-8 as follows:

 

with codecs.open(filename='playcounts.txt', mode='r', encoding='utf-8') as
scrobble_file:

            data = scrobble_file.readline()

 

I then print the data with a print statement.

 

If I do this in the debugger, or run the program externally outside the IDE,
the displayed output is as expected.

 

If I run the program using the OS Comands tool box the print statement fails
with "'ascii' codec can't encode character u'\xe1' in position 6: ordinal
not in range(128)"

 

Is there something I need to configure with regard to the OS Commands
toolbox. 

 

I tried the Edit|Preferences|Debugger|IO options, but could find anything
for the OS Command toolbox display.

 

I am running on Windows. Wing v4.1.3-1

 

Thanks.

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/wingide-users/attachments/20120318/8c7c364e/attachment.html>


More information about the wingide-users mailing list