[wingide-users] Having trouble installing package on OSX...

Scott Lasley slasley at space.umd.edu
Tue Jan 31 14:44:55 MST 2012


On Jan 31, 2012, at 4:30 PM, Anthony Palomba wrote:

> Sorry, I mean I am running Xcode 4.2.1 (4D502)

The installer for that version of XCode does not install the gcc compiler.  From sys.version it appears that python from the python.org 2.7.2 installer was built with GCC 4.2.1 (Apple Inc. build 5666) (dot 3).  I think that's why distutils is trying to use gcc-4.2 to compile your module and fails to find it.

You can get a package that installs gcc-4.2 and gfortran from the R Project (http://r.research.att.com/tools/).
http://r.research.att.com/tools/gcc-42-5666.3-darwin11.pkg

I think installing XCode 3 or XCode 4.1 in a separate directory from XCode 4.2 will also install the gcc compilers in /usr/bin, but I have not tried this.

There is also the osx-gcc-installer github project at https://github.com/kennethreitz/osx-gcc-installer.  The GCC-10.7.pkg package should install gcc-4.2 in /usr/bin.  I have not tried this one either.

Hope this helps,
Scott


More information about the wingide-users mailing list