[wingide-users] Malfunctioning undo in 4.1.0

Danny Bloemendaal Danny.Bloemendaal at informaat.nl
Mon Oct 31 08:46:22 MDT 2011


On 31 okt. 2011, at 15:08, Wingware Support wrote:

> On 10/31/11 9:51 AM, Danny Bloemendaal wrote:
>> I'm experiencing some severe undo problems while working with the new 4.1 where, at some point, it starts to mis many intermediate steps when doing undos. Like it jumps back let's say 10 edits instead of one. I've had it several times now since it was released. I have to close and reopen the current document to fix get it back to normal but you miss your undo buffer at that moment of course.
>> 
>> Anyone else experiencing this as well? Just beware for this. You might loose stuff (I just did).
> 
> This is probably a bug in auto-editing, so turning that off should avoid 
> it.  I haven't yet managed to replicate or find the bug but will keep 
> looking into it.   The most likely operation that may be causing this is 
> auto-entering args so you could also try turning just that off (and 
> please let me know if you find out whether or not that helps).
> 

I already had that auto-entering args disabled. I'll disable auto-editing completely and see how it goes.

> Note that if you run into this bug then redo should restore what was 
> removed, but of course only before you make further edits.
> 
> Thanks,
> 
> -- 
> 
> Stephan Deibel
> Wingware | Python IDE
> Advancing Software Development
> 
> www.wingware.com
> 



More information about the wingide-users mailing list