[wingide-users] Wing 4.1 installer

Michael Hipp michael at redmule.com
Sat Oct 29 11:57:17 MDT 2011


I would regard this as a bug and it was a bit annoying, but not fatal...

On my Win7 systems, I installed Wing 4.1 with no problems. But later 
when I was working I realized that I was still running 4.0.x. I looked 
and saw that 4.0 had not been uninstalled/upgraded and was still the 
default when clicking on a .wpr file. I uninstalled 4.0. But the file 
association for .wpr stayed with 4.0 or was removed entirely so now 
clicking on a project file brought me an error or an offer to "open 
with...".

On the newer version of Windows, getting file associations fixed is 
harder than it ought to be and that's something the installer should 
just do right.

FWIW, here's what I think Wing's installer ought to do:
1) If an older version of Wing is present, uninstall (i.e. upgrade) that 
older version. Provide a checkbox/option in the installer to keep old 
versions. IMHO, most people just want the newer version or else they 
wouldn't have downloaded it.
2) Set the file association on .wpr to the newly installed version.

IMHO, the above represents "expected behavior" for the most common use 
cases - someone who just wants to get back to work with the newest 
version of Wing.

Also, I really, really, really, really wish you'd add '--new' on the 
file association command in Windows. Please, pretty please, with sugar 
on top. I tire of having to do it manually after (almost) every upgrade.

Thanks for all you do...
Michael Hipp


More information about the wingide-users mailing list