[wingide-users] X11 losing focus issue on Mac OS

Wingware Support support at wingware.com
Thu Jun 9 09:34:56 MDT 2011


On 6/9/11 11:15 AM, Luc Bourhis wrote:
> Hi Danny,
>
>> >  Has anybody ever been able to fix that extremely irritating focus problem in Wing (X11) where every so often some process steals the focus (and never give it back)? I googled a lot for this problem and it seems some kind of sync process in the background is causing this but I haven't found a cure. All tips I did find didn't fix it. It's driving me nuts.
>> >  
>> >  Anybody?
> I have experienced that problem for one year at the very least. You have surely read the discussions onx11-users at lists.apple.com:  the very developer in charge of X11 development at Apple, Jeremy Huddleston, seems at a loss about that issue. He can't even reproduce it, even though a handful of people have reported that bug over the past two or three years. For the time being, no solution in sight I am afraid.
>
> A native WingIDE may land before a fix for that bug actually;-)

I've seen this also more often than I would like.  The various 
descriptions of its cause seem to include disabling certain periodic 
background tasks but none of those applied in my case.  Basically, it's 
another OS X app taking focus away from X11.  I suspect there are 
multiple causes and maybe the root problem is that X11 uses some sort of 
window/focus mode that allows this where other native apps don't.

In any case, there's not much we can do and as you note it's one of many 
reasons to get away from X11 on the Mac.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list