[wingide-users] 4.0.1-1 - Django beheavior

Fabio Fornaro fabio.fornaro at gmail.com
Sat Apr 2 15:58:39 MDT 2011


Hello,
I'm experiencing this behavior in WingIDE 4.0.1-1 :

I have this simple class
*
*
class Accountant(models.Model):
    def __init__(self):
        name = models.CharField(max_length=10)
        surname = models.CharField(max_length=20)

First Problem: I get no auto-completion for the models.CharField(...)
parameters (ie. max_length, unique etc...) --- I tried also to force
 "site-packages\django" path in project's python path but with no luck.

Second Problem: on issuing the "Django" -> "Generate SQL" command menu I
only get:

BEGIN;
CREATE TABLE "ApplicationOne_Accountant" (
    "id" integer NOT NULL PRIMARY KEY
)
;
COMMIT;

with  no "name" nor "surname" table columns definition. I tried both sqlite
& mssql django backends with the same behavior.

I'm running Python 2.6.6 with django 1.2.5 on Windows.

Can anybody help?

Thanks in advance,
Fabio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20110402/2154cc77/attachment.html


More information about the wingide-users mailing list