[wingide-users] Plone 4 with zope 2.12

Jason Mehring nrgaway at yahoo.com
Thu May 6 17:27:53 MDT 2010


Thanks for the info.

I successfully configured and installed the egg created by Encolpe.  I was also able to convert it to work with the latest versions (2.3.6) by manually applying the patches Encolpe made and getting rid of the Products namespace.

I also needed to change a setting in 'parts/client1/etc/zope.conf' or the link in the ZMI control panel would still not show up in Zope 2.12.  Change the following setting:

enable-product-installation off

to 

enable-product-installation on

Encolpe:  Thanks for sharing the egg!




----- Original Message ----
From: Wingware Support <support at wingware.com>
To: Jason Mehring <nrgaway at yahoo.com>
Cc: wingide-users at wingware.com
Sent: Thu, May 6, 2010 1:06:02 PM
Subject: Re: [wingide-users] Plone 4 with zope 2.12

Jason Mehring wrote:
> I can't get wing to work with Plone 4 (zope 2.12).  I even created an egg (Products.WingDBG).
>
> I get the following message when starting plone:
> 2010-05-05 19:28:08 INFO WingDBG Installed Wing Debug Service in Control Panel
>
> but when I go to the ZMI control panel, there is no link to Wing options
>
> Does anyone have any work-arounds I can try since its kinda hard to develop for Plone 4 without being able to use the debugger.
>  

We haven't yet had time to look into this but another user has made an 
egg available here:

http://bitbucket.org/encolpe/wingdbg

Note that WingDBG is open source so if it doesn't work feel free to try 
to debug it. ;-)

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com





More information about the wingide-users mailing list