[wingide-users] Impressions and feedback from a new user

Wingware Support support at wingware.com
Wed Jul 7 10:58:25 MDT 2010


Phil Vandry wrote:
> As a new user (I don't know how come I never found out about it before 
> now), I've been trying Wing IDE for about a week and a half now. I 
> really like it in principle and it has lots of great things going for 
> it, but unfortunately I have decided not to buy it. The reason is 
> because of the editor. Generally, of course, I spend a quite a large 
> chunk of time in the editor so I'm afraid I have high expectations 
> that it should work correctly, but I have found several cases where it 
> doesn't do what I ask it to do. Inescapably, that's a deal breaker.

Thanks!  This is useful feedback.  I've fixed a few things and have 
included some notes that may help get things working:

> - Copy & Paste
>
> In MacOS, I can't copy something from another application and paste it 
> in Wing. I tried the usual MacOS keys ⌘C and ⌘V, I tried the 
> traditional X11 way (select with left button and paste with middle 
> button), nothing seems to work.
>
> I can get copy & paste working within Wing with Ctrl-C and Ctrl-V 
> (still no ⌘C and ⌘V or X11 middle button) but I had to set a 
> preference for that. Shouldn't that work by default? The menu suggests 
> some alternate keybindings like Ctrl-Insert but I've never seen this 
> before and I don't even have that key on my keyboard anyway. Standard, 
> well-known copy&paste methods should be better supported.
>
> (by the way, I guess lack of support for ⌘C and ⌘V is related to the 
> recent discussion about lack of a native MacOS version of Wing, but I 
> have to say I kinda like it under X11 just the way it is... I'm afraid 
> I would lose focus-follows-mouse if it were MacOS-native!)

Assuming you were using the default keyboard personality in Wing, this 
should work.   Can you verify that you have unchecked "Enable Key 
Equivalents Under X11" in the X11 server's preferences?  When that is 
checked, the X11 server gets the ⌘ keys.  Upgrading to the latest 
XQuartz (http://xquartz.macosforge.org/trac/wiki) may help also (try 
both left and right ⌘ keys if you have two, since we've had reports of 
one of them not working).  If none of that helps, or if only one ⌘ key 
is working, please send your OS X version number and X11/XQuartz version 
number to support at wingware.com so we can try to replicate this here.  
It's working for me on OS X right now, but it's probably version 
dependent (something in X11 changing under us).

> - "x" doesn't work correctly at the end of a line.
>
> When pressing "x" at the end of a line, the last character of the line 
> should be erased and the cursor should back up to the new last 
> character. In Wing the cursor remains at the same place, which is an 
> impossible position for the cursor in vi (in vi the cursor can never 
> be beyond the end of a line). The incorrect cursor position then 
> causes subsequent editing commands to take effect at the wrong location.

Thanks for pointing that out.  I've fixed it in our sources for Wing 
3.2.10+.  Please don't hesitate to let us know about other such vi mode 
problems with the Submit Bug Report item in Wing's Help menu.  Vi is 
complex and sometimes inconsistent internally and we're not vi users so 
rely on user reports to fix things like this.

> - "p" and "P" commands don't insert at the correct place.
>
> The "p" is supposed to always take the lines that have been yanked or 
> cut into a vi buffer and insert them between the current line and the 
> next line (i.e. after the current line). Similarly, "P" is supposed to 
> insert the buffered lines between the previous line and the current 
> line (i.e. before the current line). In Wing, both commands actually 
> chop the current line in two pieces at the cursor position and insert 
> the buffered lines between the pieces.

I've also fixed this one.

> - "Confirm Reload"
>
> I constantly get a dialog asking me to confirm reloading files that 
> have changed from disk. The list of files it wants to reload is all of 
> the files in my project. None of them have actually changed...

That's certainly not what Wing should be doing.  Are these files that 
have changed in the editor?  By default, Wing should only prompt to 
reload files that are both changed in the editor and by some other 
process on disk.  This is controlled in the Files / Reloading preferences.

In any case, this seems to indicate a bug in the reload detection code, 
probably specific to a particular OS and file system type.   Can you 
send more details about your machine to support at wingware.com or submit a 
bug report from Wing's Help menu so we can try to replicate this here?

> - last line of the file is confusing
>
> (I list this one for completeness but I could live with this issue, 
> it's kinda minor)
>
> In vi, it is impossible to position the cursor past the last line of 
> the file. In Wing in vi mode, it is possible to place the cursor one 
> line past the end of the file.
>
> This gives the impression that there is a blank line at the end of the 
> file, but there actually isn't.

This is due to how the underlying code editor widget works.  I'll see if 
we can prevent getting into that position.  A similar issue exists with 
moving past the end of the line (as you noted) and we end up having to 
enforce cursor position as part of every action that can move it.

Thanks for the feedback!

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list