[wingide-users] Hurray for native WingIDE on OS X!

Daniel Tavares daniel at 510systems.com
Fri Jul 2 13:41:44 MDT 2010


Just wanted to take the opportunity and show my support for Cocoa GUI for
WingIDE.

>From the thread below:
...
> A OS X version of Wing that doesn't use X11 is in our plans.
...

+1!

I've been using WingIDE Pro for over 3 years now, of which, the majority of
time was on Windows.
As of a few months ago I started working full time in OS X and decided to
stick with Wing. But I must
say that the quality bar drops significantly from Windows to OS X.

I know it's not a simple task, but, my wish is that the WingIDE's user
experience should be the same, regardless
of what OS you're on.

Let me know when this new feature is available and I'll be more than happy
to try it out!

Cheers,
Daniel


Message: 6
> Date: Thu, 1 Jul 2010 14:20:04 -0600
> From: Vincent Davis <vincent at vincentdavis.net>
> Subject: Re: [wingide-users] Totally broken OSX keyboard shortcuts,
>        cmd key         does not work
> To: Wing IDE Support <support at wingware.com>
> Cc: wingide-users at wingware.com
> Message-ID:
>        <AANLkTinB7G4znVDj8VWw_gGT4qIga06Uy_WEEa700JWF at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
>
> On Thu, Jul 1, 2010 at 2:04 PM, Wing IDE Support <support at wingware.com>
> wrote:
> > On 7/1/10 3:45 PM, JAZ wrote:
> >>
> >> I cannot use WingIDE Pro. I tried any variants of X11 and WingIDE
> >> options. The command key and all its native OS-X shurtcuts do not
> >> trigger anything.  In WingIDE cmd-h and cmd-d behave  like backspace
> >> and delete keys. The same for Cntrl. All native OS-X shurtcuts are not
> >> working. It is very annoying. I have use mouse or everything, even for
> >> saving buffer. What the hell has happend with Wing IDE Pro for OSX?
>
> I am running WingIDE Pro on osx 10.6.4 and everything works good.
> including cmd-h and cmd-d
> In x11 there are keyboard preferences, on the input tab I have not
> check marks. There is also a full screen mode (x11) but it make Expose
> and space not work.
> Vincent
>
> > Has Wing worked previously for you?  If so, when did it stop working?  I
> > wonder if it's some sort of xmodmap problem.  Could you submit a bug
> report
> > from inside Wing and include the error log?
> >
> > A OS X version of Wing that doesn't use X11 is in our plans.
> >
> > Thanks,
> >
> > John
> > _________________________________________________
> > Wing IDE users list
> > http://wingware.com/lists/wingide
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20100702/3588a49a/attachment.html


More information about the wingide-users mailing list