[wingide-users] Totally broken OSX keyboard shortcuts, cmd key does not work

Vincent Davis vincent at vincentdavis.net
Thu Jul 1 14:20:04 MDT 2010


On Thu, Jul 1, 2010 at 2:04 PM, Wing IDE Support <support at wingware.com> wrote:
> On 7/1/10 3:45 PM, JAZ wrote:
>>
>> I cannot use WingIDE Pro. I tried any variants of X11 and WingIDE
>> options. The command key and all its native OS-X shurtcuts do not
>> trigger anything.  In WingIDE cmd-h and cmd-d behave  like backspace
>> and delete keys. The same for Cntrl. All native OS-X shurtcuts are not
>> working. It is very annoying. I have use mouse or everything, even for
>> saving buffer. What the hell has happend with Wing IDE Pro for OSX?

I am running WingIDE Pro on osx 10.6.4 and everything works good.
including cmd-h and cmd-d
In x11 there are keyboard preferences, on the input tab I have not
check marks. There is also a full screen mode (x11) but it make Expose
and space not work.
Vincent

> Has Wing worked previously for you?  If so, when did it stop working?  I
> wonder if it's some sort of xmodmap problem.  Could you submit a bug report
> from inside Wing and include the error log?
>
> A OS X version of Wing that doesn't use X11 is in our plans.
>
> Thanks,
>
> John
> _________________________________________________
> Wing IDE users list
> http://wingware.com/lists/wingide
>


More information about the wingide-users mailing list