[wingide-users] Not able to debug from MAYA

Wingware Support support at wingware.com
Tue Dec 21 11:53:34 MST 2010


On 12/21/10 1:09 PM, sunny chopra wrote:
> I'm also facing problem, and many times i am not even able to
> connect to wing from autodesk maya (actually i am able to connect to 
> wing from
> maya only twice)
> i'm following all the instructions given in help and this group but no
> luck.
> Using maya 2008 with wing 3.2.12(trial) (had no luck with connecting 
> using
> maya2011 sp1)
> Also tried disabling firewall, btw i'm on win 7 64bit

The log seems to show Wing is refusing the connection, or it is 
otherwise not getting through.  Since you got connected twice, I'm 
wondering if it's just the case that Wing already has an active debug 
session.  You would need to stop that first so that wingdbstub can 
connect from Maya.

Another common problem:  If Maya is running on another machine than Wing 
IDE or as another user, you may be missing the wingdebugpw file.  The 
mayamel wiki seems to cover that case at http://tinyurl.com/2cj95z6 
(requires clicking links to reveal content in-line, which I found a bit 
confusing) or see our docs at 
http://wingware.com/doc/debug/importing-the-debugger

> is there any project settings we need to do inside wing (other than
> giving mayapy.exe as python executable and adding script directory as
> PYTHONPATH, in project settings)

Not that I know of and those settings are not used when debugging Maya 
with wingdbstub.  There is some additional information at 
http://wingware.com/doc/howtos/maya and the mayamel wiki at 
http://tinyurl.com/2cj95z6

Please let me know if this does not help.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list