[wingide-users] beta b5

Wingware Support support at wingware.com
Mon Dec 20 18:00:12 MST 2010


On 12/20/10 7:14 PM, John Fabiani wrote:
> I'm not sure what is going on but on my setup (openSUSE 11.3, python 2.6.5,
> wxPython) debugging is not working as well as it once did with earlier
> versions (3.x).   I set a break point and It just does nothing - never stops
> at the break point.  I get no exceptions -nothing. It does not appear to crash
> because I can still edit.  But I can close wing, reopen and start the same
> debug session on the same program and it stops on my break point.  It is not a
> data issue and I'm sure it is not my code not executing.  The problem as
> always is hard to repeat - but I have discovered it many times since
> installing Wing 4.

If you can set the Debugger /Advanced / Debug Internals Log File 
preference when this happens and send us the output, that might tell us 
what is going on.  I'm assuming you're initiating debug from the IDE and 
not using wingdbstub.  If that latter, you need to set kLogFile in 
wingdbstub.py instead and also then it's worth checking to be sure that 
no debug process is already active when it's failing.

> I'm still getting major delays when opening wing too.  At first I thought the
> delays had something to do with my project wpr file being corrupt.  But I have
> recreated the project file and I still get delays.  I open wing and expect to
> immediately select something or click on the menu to open something but I get
> nothing and if I wait maybe 5-10 seconds the action occurs.  Then even after
> opening and waiting for wing to settle down I still get strange delays.  For
> example I will highlight a word and then do a ctrl-f.  I would expect the
> search string to appear in the search box but nothing for 5-10 seconds then
> suddenly it will appear in the search box.  But several times I could not get
> it to do anything and had to re-select or type the string in the search box
> myself.
> I realize this is why it's call beta but I'm surprised to see these delays in
> one of your beta's.

We're still working on optimizing the new analysis functionality on 
which refactoring and find uses is based, and that is probably the 
cause.  It should show status info in lower left of the IDE window while 
analyzing.  If you're seeing these delays once that is done, please let 
us know.

BTW, running multiple instances of Wing seems to cause a lot of problems 
in beta5 due to database concurrency problems.  If you think you've run 
into that, you can clear the cache in the Source Analysis preferences 
and then just run one copy of Wing to work around the worst of it 
(although the analysis process will of course have to complete to 
repopulate the cache).

Though I've found it quite usable and am loving the new functionality 
myself, I think I'd agree this beta is perhaps a bit rougher in some 
ways than others in our history.  That's a result of a substantial 
rewrite of the analysis and type inferencing engines, which are quite 
complex.  Since that's so central to almost everything you do with Wing, 
the bugs are more noticeable than when we work on code that's more 
isolated to a particular tool or feature.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list