[wingide-users] beta b5

John Fabiani johnf at jfcomputer.com
Mon Dec 20 17:14:31 MST 2010


I'm not sure what is going on but on my setup (openSUSE 11.3, python 2.6.5, 
wxPython) debugging is not working as well as it once did with earlier 
versions (3.x).   I set a break point and It just does nothing - never stops 
at the break point.  I get no exceptions -nothing. It does not appear to crash 
because I can still edit.  But I can close wing, reopen and start the same 
debug session on the same program and it stops on my break point.  It is not a 
data issue and I'm sure it is not my code not executing.  The problem as 
always is hard to repeat - but I have discovered it many times since 
installing Wing 4.  

I'm still getting major delays when opening wing too.  At first I thought the 
delays had something to do with my project wpr file being corrupt.  But I have 
recreated the project file and I still get delays.  I open wing and expect to 
immediately select something or click on the menu to open something but I get 
nothing and if I wait maybe 5-10 seconds the action occurs.  Then even after 
opening and waiting for wing to settle down I still get strange delays.  For 
example I will highlight a word and then do a ctrl-f.  I would expect the 
search string to appear in the search box but nothing for 5-10 seconds then 
suddenly it will appear in the search box.  But several times I could not get 
it to do anything and had to re-select or type the string in the search box 
myself.
I realize this is why it's call beta but I'm surprised to see these delays in 
one of your beta's.

Johnf


More information about the wingide-users mailing list