[wingide-users] changing python2.6 to 2.7

Lukasz Michalski lm at zork.pl
Thu Aug 26 13:56:28 MDT 2010


Hi,

I just upgraded my system and switched from python2.6 to 2.7. Now when I
open my project then wing says that python cannot be found and I need to
install it or set path to exe in project settings.

Setting path to 'python' solves this. But I have now python 2.7 in my
path, python2.6 is removed.

Even having path to python exe in project settings does not allow me to
run python inside wing:

Python shell shows this:
Traceback (most recent call last):
  File "/usr/local/lib/wingide3.2/bin/wingdb.py", line 542, in main
    netserver = FindNetServerModule(winghome, user_settings)
  File "/usr/local/lib/wingide3.2/bin/wingdb.py", line 362, in
FindNetServerModule
    raise ImportError('Could not import netserver')
ImportError: Could not import netserver
wingdb.py: Error: Failed to start the debug server
wingdb.py: Error: You may be running an unsupported version of Python
wingdb.py: Python version = 2.7 (r27:82500, Jul  8 2010, 09:15:13)
[GCC 4.5.0 20100615 (release)]
wingdb.py: WINGHOME='/usr/local/lib/wingide3.2'
Traceback (most recent call last):
  File "/usr/local/lib/wingide3.2/bin/wingdb.py", line 553, in main
    sys.exit(-1)
SystemExit: -1

When I try to debug my project I got exactly the same message.

What should I reset to make wing use python 2.7? Is it supported?

Thanks,
Łukasz


More information about the wingide-users mailing list