[wingide-users] No shift key in WingIDE

Dan-Erik Lindberg dan-erik.lindberg at vfm.slu.se
Mon Aug 16 11:52:41 MDT 2010


I'm using the latest 4.0 beta (Version 4.0.0-b3).

For some reason, I can't use shift, ctrl or alt within WingIDE. It is only within the IDE that it isn't working, and it applies any time the IDE is open and the active window.

For example: If I try to write ( I only get 8
(I'm using swedish keyboard layout, so the american equivalent would be *)

Another example: If I try to copy something with ctrl-c the text I am trying to copy will instead be overwritten with a c.

I've tried going into Preferences and reverting to factory defaults, as I thought it may be something to do with keyboard personalities. I've also tried changing to a different keyboard personality, but it didn't make the problem go away.

As you can imagine, it is rather frustrating to write code without being able to write for example () or [] or even =... So I'd appreciate some help.

I was able to use shift and ctrl and alt after installation of WingIDE. Then I installed python(x,y) (a scientific distribution of python which I found easy to use because it bundles Qt and other packages with python). And I believe it is after this installation that shift, ctrl, alt stopped working. Before installing python(x,y) I had python 3.1 installed, and I then changed the python shell to use python 2.6.5 that is bundled with python(x,y). But I don't understand how this could have an effect on my shift, ctrl and alt keys in WingIDE...

Should I just uninstall/reinstall everything? I haven't done that yet, because I would prefer to understand what went wrong so I can avoid it in the future.

Regards,

Dan-Erik


More information about the wingide-users mailing list