[wingide-users] socket connect issues

Wingware Support support at wingware.com
Tue Oct 20 20:02:10 MDT 2009


chris botos wrote:
> Hi all,
> 
> I am running wing 3.0.2-1 (rev 0) that I have compiled for Solaris.
> I have a python program that starts a TCP/IP server on a C-thread.
> Within the python program for testing I am trying to connect to the
> server as a client with
> 
> fd= socket.socket ( socket.AF_INET, socket.SOCK_STREAM )
> fd.connect((sereverip, 50000))
> 
> If I run the program within wing, the connect fails.
> If I run it normally it connects.
> 
> Is there something special I have to do to wing to be able to do this
> within the debugger?

Are you running the above test code in the same process as
the server code?  If so, it's probably a threading issue,
although I'm just guessing at this point.

Note BTW that Wing's debugger uses port 50005 and 50015.  You
seem to be using 50000 so should be OK but it's close so I
figure I should mention this potential conflict as well.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list