[wingide-users] Cannot execute: waiting for shell to restart.

Skyblues jeffbonarwagner at yahoo.com
Fri Feb 13 11:22:09 MST 2009




Wingware Support wrote:
> 
> Skyblues wrote:
>> I am demoing the WingIDE Pro version. I bring up WingIDE and see the
>> following in the interactive "Python Shell" area. 
>> 
>> "Cannot execute: waiting for shell to restart."
>> 
>> I execute the "restart shell" option and I get the following error:
>> 
>> "The debug process never connected back to Wing IDE:  Aborting debug
>> session    
>> See Trouble-shooting Failure to Debug in the users manual."
>> 
>> I have Enthough Python 2.5 and ActiveState Python 2.6 installed in
>> "D:\Development\Python25" and "D:\Development\Python26" respectively. I
>> have
>> manually pointed to the Python executable for both Python versions in the
>> Project Properties.
>> 
>> I am running WingIDE 3.1.1-1 on Vista x64.
>> 
>> Any suggestions? I really like the looks of WingIDE but just can't seem
>> to
>> get it to run a simple program because, apparently, it can't find the
>> Python
>> executable.
> 
> Try Wing 3.1.7.  Version 3.1.1 did not yet support Python 2.6 and I
> suspect
> that Wing is finding Python 2.6 in preference and failing to use it
> properly.
> Note that you can also point Wing to a particular Python with the Python
> Executable attribute in Project Properties (from the Project menu).  It
> may
> work to use that to point to the Enthought Python 2.5 install, without
> having
> to upgrade Wing (although in general we recommend going to the latest in
> any
> #.# version).
> 
> If that doesn't help, please let me know.
> 
> Thanks,
> 
> -- 
> 
> Stephan Deibel
> Wingware | Python IDE
> Advancing Software Development
> 
> www.wingware.com
> 
> _________________________________________________
> Wing IDE users list
> http://wingware.com/lists/wingide
> 
> 

Hi Stephan,

Thank you for the suggestion. I installed WingIDE 3.1.7 and also pointed
Wing to both versions of Python (with the Python Executable attribute in
Project Properties) and the results are the same.

Any idea what may be wrong? I hope I can get this working.

Best regards,
Jim
-- 
View this message in context: http://www.nabble.com/Cannot-execute%3A-waiting-for-shell-to-restart.-tp21987470p22002167.html
Sent from the WingIDE - User mailing list archive at Nabble.com.



More information about the wingide-users mailing list