[wingide-users] Exception: "<type 'exceptions.OSError'>"

Ting Zhou coomteng at gmail.com
Fri Feb 6 03:43:25 MST 2009


Dear developers of wingide,

I am trying to runwingide-101-3.1.7-1-i386-linux on my Ubuntu 8.04. I
have got the error message as

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
wingide - 2009/02/06 11:08:06 - Output: []
wingide - 2009/02/06 11:08:06 - Reasons:
wingide - 2009/02/06 11:08:06 -   OSError(2, 'Could not exec:
/usr/bin/python2.5')
wingide - 2009/02/06 11:08:06 -   OSError(2, 'Could not exec:
/usr/bin/python2.5')
wingide - 2009/02/06 11:08:06 - interp version= None
wingide - 2009/02/06 11:08:06 - PYTHONPATH [u'/home/zhou']
wingide - 2009/02/06 11:08:06 - General: Cannot find Python::Python
could not be found or is not installed on this computer. You need to
install Python before you can debug or obtain correct source code
analysis results.  If Python is already installed, use Project
Properties to set the Python Executable to use.

wingide - 2009/02/06 11:08:07 - PYTHONPATH [u'/home/zhou']
wingide - 2009/02/06 11:08:07 - PYTHONPATH [u'/home/zhou']
wingide - 2009/02/06 11:08:07 - PYTHONPATH [u'/home/zhou']
wingide - 2009/02/06 11:08:07 - interp version= None
wingide - 2009/02/06 11:08:07 - PYTHONPATH [u'/home/zhou']
wingide - 2009/02/06 11:08:07 - Debugger: Listening for back-connection
wingide - 2009/02/06 11:08:07 - popenE with
[u'/home/zhou/wingide-1013.1/wingdb', '--no-xterm', '-',
'127.0.0.1:60839', '-1', '--first-stop',
"r''+chr(60)+r'none'+chr(62)+r''", '--nowait-on-exit',
'--stdout-encoding=UTF-8', '--stdin-encoding=UTF-8',
"r'/home/zhou/wingide-1013'+chr(46)+r'1/src/debug/tserver/_sandbox'+chr(46)+r'py'"]
wingide - 2009/02/06 11:08:10 - EXCEPTION IN SAFE SELECT 4
wingide - 2009/02/06 11:08:11 - select timed out when execing:
/home/zhou/wingide-1013.1/wingdb
wingide - 2009/02/06 11:08:11 - Runtime failure details:
wingide - 2009/02/06 11:08:11 - Exception: "<type 'exceptions.OSError'>"
wingide - 2009/02/06 11:08:11 - Value = '[Errno 2] Could not exec:
/home/zhou/wingide-1013.1/wingdb'
wingide - 2009/02/06 11:08:11 - Traceback:
wingide - 2009/02/06 11:08:11 -   File
"2.5/src/debug/client/runstate.pyo", line 702, in _DebugFile
wingide - 2009/02/06 11:08:11 -   File "2.5/src/wingutils/spawn.pyo",
line 1035, in CreatePopenE
wingide - 2009/02/06 11:08:11 -   File "2.5/src/wingutils/spawn.pyo",
line 702, in __init__
wingide - 2009/02/06 11:08:11 -   File "2.5/src/wingutils/spawn.pyo",
line 771, in _do_fork
wingide - 2009/02/06 11:0Debugger: No debug process / not listening for
connections
wingide - 2009/02/06 11:08:11 - Debugger: Could not start debug
process::Could not launch debugger for
"/home/zhou/wingide-1013.1/src/debug/tserver/_sandbox.py".  The python
interpreter "None" may not exist.
wingide - 2009/02/06 11:08:11 - Debugger: Could not start shell
process::Could not start debug process::Could not launch debugger for
"/home/zhou/wingide-1013.1/src/debug/tserver/_sandbox.py".  The python
interpreter "None" may not exist.
wingide - 2009/02/06 11:08:20 - Instance manager: Removed lock file
/home/zhou/.wing101-3/instance
8:11 - Debugger: No debug process / not listening for connections
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I have installed the python version 2.5.2 from ubuntu official release
and it works fine. It locates at /usr/bin/python2.5.


-- 
Best wishes Ting


More information about the wingide-users mailing list