[wingide-users] installation on ubuntu

Wingware Support support at wingware.com
Wed Oct 1 06:24:13 MDT 2008


Kathleen Krause-Thompson wrote:
> I am installing on Ubuntu and I just downloaded the tar'ed version. Then 
> I ran  wing-install.py. The install ran without errors, however, when I 
> tried to start up wing3.1 I did a 'sh wing3.1' and got this error message
> exec: 192: 
> /usr/local/bin/wingide-3.1.4-1-i386-linux/y/bin/PyCore/python: not found

Is the 'y' really there or is it actually the following?

/usr/local/bin/wingide-3.1.4-1-i386-linux/bin/PyCore/python

> Acutally python is found at this location with these perms: -rwxr-xr-x
> 
> I am running Python 2.4 at another location. Can Wing be configured to 
> use that? Any other ideas?

Wing needs to use the Python that comes with it for its own execution.
Your debug process can run against any Python version 2.0->2.6.

My guess is you have a 64 bit machine and don't have the ia32-libs
compatibility package installed.  The Python Wing is trying to use
is a 32 bit app.

Please let us know if that doesn't help.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list