[wingide-users] Wing IDE 3.1 final released

Wingware Support support at wingware.com
Wed May 7 12:53:01 MDT 2008


Tony Cappellini wrote:
> Are the project & global settings from Wing 3.0 compatible with 3.1?
> Are the project files compatible?

Yes, they should be with a few minor exceptions:

* The new templating tool in 3.1 is different and independent from the
one in 3.0 so a project w/ one won't show the tool when run in the
other version of Wing.  3.0 does not have the new tool (of course)
and 3.1 purposely disables the old one, which is however still included
with Wing in scripts/templating.py.

* Any key bindings set in the OS Commands tool are now stored in the
project.  Existing bindings for commands will still work, however, and
will still be stored in preferences.  They can be removed using the
Keyboard / Custom Key Bindings preference.

If you plan on constantly going back and forth between versions, using
two projects might be less confusing overall.  However, in any case,
there's no issue w/ the shared part of 2-part shared projects in case
you have some developers using 3.0 and some 3.1.

> How do you get Wing 3.1 to use the recent projects and files from 3.0?

It should just do it.  Both look at the same user settings directory
and thus the same recent-* files.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list