[wingide-users] Bug in integrated interactive interpreter -- Wing 101, Slackware Linux 12.0, tar.gz distribution, Python 2.5.1

Wingware Support support at wingware.com
Wed Jun 18 08:21:54 MDT 2008


Devin Jeanpierre wrote:
> As you can see here. <
> http://scorchsaber.com/uploads/images/debugging/wing101.png >
> 
> I'm not sure if there's anything I can/should do to fix it-- if it's a
> bug, I guess bringing it up is enough. If not, please tell me what to
> do, and I will do it. If you need any more information, I can tell it.
> I have tried, among other things, restarting Wing IDE 101, restarting
> the interactive interpreter, and changing the interactive
> interpreter's version from 2.5.1 to 3.0 alpha (incompatible print
> statement, so it didn't work at all).

This is odd.  Does the caret in the shell show and is it ever after the
 >>> prompt as it should be?

Wing 101 version 3.1.1 worked for me just now w/ Python 2.5.2 on Linux.
I doubt the 2.5.1->2.5.2 makes any difference, tho.

Perhaps sending us your preferences and error-log from ~/.wing101-3 would
show us something (please email privately to support at wingware.com).

Note that Wing doesn't yet support Python 3.0 so that part is expected.

Thanks for the bug report.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list