[wingide-users] PyLint Panel and WingIDE 3.1

Wingware Support support at wingware.com
Tue Jun 3 09:01:22 MDT 2008


Wingware Support wrote:
> Mateusz Biliński wrote:
>> I have a problem with using PyLint panel in WingIDE 3.1
>> (Professional). It simply doesn't work. :)
...
> --enabled-ids and --enable-classes are invalid arguments in pylint 0.14.0
> 
> Commenting out that line in your config should make it work -- sort of.
> On top of that, it looks like pylint's output has changed so the script in
> scripts/pylintpanel.py needs modification to parse that properly.
> 
> The solution is possibly to use the newer --output-format=parseable option
> and modify the script to parse that.  Hopefully that will remain constant
> into future releases.
> 
> Ignoring the number immediately after the E, W, etc, may also be enough
> to get it working.  I can't look at it right now in more detail but
> adding print statements in scripts/pylintpanel.py and looking at Wing's
> Messages tool's Scripts channel may be enough to figure out how to fix it
> if this is an urgent problem for you.

Oops, my mistake -- it _does_ work with pylint 0.14.0 once you get the args
correct (comment out any extra args in the pylint preferences file).

I was confused by not seeing errors in Wing that I saw from pylint on
the command line, but that was due to the Python Path not being set
correctly outside of Wing.

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list