[wingide-users] Wing IDE 3.0.3 released

Yarko T yarkot1 at gmail.com
Mon Jan 14 20:36:07 MST 2008


So I have the 10 day supposedly Pro trial, and I upgraded today and got
3.0.2...

Is that expected?


On 1/14/08, Mike Bernson <mike at mlb.org> wrote:
>
> the date on the web site is wrong.
> Version 3.0.3 (stable release) - January 14, 2007
>
>
> Wingware wrote:
> > Hi,
> >
> > We're happy to announce version 3.0.3 of Wing IDE, an advanced
> development
> > environment for the Python programming language. It is available from:
> >
> > http://wingware.com/downloads
> >
> > This release focuses on fixing some usability issues found in Wing 3.0.2
> ,
> > including fixes for input handling in Debug I/O, Zope debugging on
> > 64-bit Linux, several emacs and vi mode improvements, and about 34
> > other bugs.
> >
> > See the change log for details:
> >
> > http://wingware.com/pub/wingide/3.0.3/CHANGELOG.txt
> >
> > It is a free upgrade for all Wing 3.0 users.
> >
> > *About Wing IDE*
> >
> > Wing IDE is an integrated development environment for the Python
> > programming
> > language.  It provides powerful debugging, editing, code intelligence,
> > testing, and search capabilities that reduce development and debugging
> > time, cut down on coding errors, and make it easier to understand
> > and navigate Python code.
> >
> > New features added in Wing 3.0 include:
> >
> > * Multi-threaded debugger
> > * Debug value tooltips in editor, debug probe, and interactive shell
> > * Autocompletion and call tips in debug probe and interactive shell
> > * Automatically updating project directories
> > * Testing tool, currently supporting unittest derived tests (*)
> > * OS Commands tool for executing and interacting with external commands
> (*)
> > * Rewritten indentation analysis and conversion (*)
> > * Introduction of Wing IDE 101, a free edition for beginning programmers
> > * Available as a .deb package for Debian and Ubuntu
> > * Support for Stackless Python
> > * Support for 64 bit Python on Windows and Linux
> >
> > (*)'d items are available in Wing IDE Professional only.
> >
> > System requirements are Windows 2000 or later, OS X 10.3.9 or later for
> > PPC or
> > Intel (requires X11 Server), or a recent Linux system (either 32 or 64
> > bit).
> >
> > *Purchasing & Upgrading*
> >
> > Wing IDE Professional & Wing IDE Personal are commercial software and
> > require
> > a license  to run.  To upgrade a 2.x license or purchase a new 3.xlicense:
> >
> > Upgrade:   https://wingware.com/store/upgrade
> > Purchase:  https://wingware.com/store/purchase
> >
> > Any 2.x license sold after May 2nd 2006 is free to upgrade; others cost
> > 1/2 the normal price to upgrade.
> >
> _________________________________________________
> Wing IDE users list
> http://wingware.com/lists/wingide
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20080114/dc410009/attachment.html


More information about the wingide-users mailing list