[wingide-users] trouble installing on 64bit

Tyson Wenger tyson.wenger at vltool.com
Fri Aug 15 07:16:09 MDT 2008


I am trying to install wing3.1.3 on Fedora 9 with a 64bit board and I'm 
having some trouble.  I tried the linux rpm package and received an 
error saying "libX11.so.6 is needed by wingide".  I did some researching 
and found that I needed the ia-32 libs for it to compile.  Therefore I 
used this command to get the files "yum install libXtst.i386".  After 
getting this library, the rpm worked correctly and wing was installed.  
Now when I try and run wing from the command line nothing happens.   I 
tried running wing from its local directory and then received this error: 

DYNLIB_DIRS=/usr/lib/wingide3.1/bin/2.5/src, 
/usr/lib/wingide3.1/bin/2.5/opensource, 
/usr/lib/wingide3.1/bin/2.5/external/docutils/extras, 
/usr/lib/wingide3.1/bin/2.5/external/docutils, 
/usr/lib/wingide3.1/bin/2.5/external/pyscintilla2, 
/usr/lib/wingide3.1/bin/2.5/external/pygtk, 
/usr/lib/wingide3.1/bin/PyCore/lib/python2.5
PATCHES=
Traceback (most recent call last):
  File "wing.py", line 577, in <module>
    Main()
  File "wing.py", line 554, in Main
    squelch_output = Initialize()
  File "wing.py", line 530, in Initialize
    InitializeConfig()
  File "wing.py", line 326, in InitializeConfig
    config.gStartupEnv = _GetStartupEnv()
  File "wing.py", line 286, in _GetStartupEnv
    from wingutils import location
  File "2.5/src/wingutils/location.pyo", line 32, in <module>
  File "2.5/src/wingutils/patchimporter.pyo", line 92, in load_module
ImportError: /usr/lib/wingide3.1/bin/2.5/src/wingutils/statops.so: wrong 
ELF class: ELFCLASS32

Any help would be much appreciated, I'm stuck.


More information about the wingide-users mailing list