[wingide-users] backend issues matplot lib - strange error

John washakie at gmail.com
Fri Sep 21 16:30:10 MDT 2007


It seems to happen outside as well? I've run it just as a standalone
program. It's seems like maybe it's something with memory.. but I have a lot
(2gb RAM, 1.8 Ghz on Windows XP -though will ultimately port this to LINUX).

Anyway, it runs, but then becomes very slow... ultimately crashing sometime
during the second of the two print figure loops.

-john


On 9/20/07, Wingware Support <support at wingware.com> wrote:
>
> John wrote:
> > I'm working with Wing trying to create a program that creates batch
> > plots using matplotlib. I'm having a lot of trouble with the backend. It
> > seems to become non-responsive regardless of what I try. I've tried
> > setting interactive off, which of course, works, but then it's rather
> > difficult to debug my plotting.
>
> When running in Wing's debugger, we stop the Python interpreter
> completely while stepping or at breakpoints, so the debug process
> event loop isn't serviced and its windows will not update.  We're going to
> look into adding hooks for forcing updating during debugging fairly soon,
> since this has become a commonly reported problem.
>
> > Also, I've run the script all the way through (it's pasted below for
> > reference). It is crashing as it enters the last plotting loop, plotting
> > averages. However, if I comment out the previous two loops and run it, I
> > have no problems. Does anyone have any 'best practices' or
> > recommendations for working with matplotlib and the backends (currently
> > I'm using TkAgg  - as I have other problems with the alternatives).
> >
> > Finally, I'm attaching an error message which pops up when the
> > programming crashes.
>
> Can you confirm whether this crash happens only in our debugger or
> also when run outside of Wing?
>
> Thanks,
>
> --
>
> Stephan Deibel
> Wingware | Python IDE
> Advancing Software Development
>
> www.wingware.com
>
>


-- 
Configuration
``````````````````````````
Plone 2.5.3-final,
CMF-1.6.4,
Zope (Zope 2.9.7-final, python 2.4.4, linux2),
Five 1.4.1,
Python 2.4.4 (#1, Jul 3 2007, 22:58:17) [GCC 4.1.1 20070105 (Red Hat
4.1.1-51)],
PIL 1.1.6
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20070921/ae73b8f5/attachment.html


More information about the wingide-users mailing list