[wingide-users] backend issues matplot lib - strange error

Wingware Support support at wingware.com
Thu Sep 20 20:50:25 MDT 2007


John wrote:
> I'm working with Wing trying to create a program that creates batch 
> plots using matplotlib. I'm having a lot of trouble with the backend. It 
> seems to become non-responsive regardless of what I try. I've tried 
> setting interactive off, which of course, works, but then it's rather 
> difficult to debug my plotting.

When running in Wing's debugger, we stop the Python interpreter
completely while stepping or at breakpoints, so the debug process
event loop isn't serviced and its windows will not update.  We're going to
look into adding hooks for forcing updating during debugging fairly soon,
since this has become a commonly reported problem.

> Also, I've run the script all the way through (it's pasted below for 
> reference). It is crashing as it enters the last plotting loop, plotting 
> averages. However, if I comment out the previous two loops and run it, I 
> have no problems. Does anyone have any 'best practices' or 
> recommendations for working with matplotlib and the backends (currently 
> I'm using TkAgg  - as I have other problems with the alternatives).
>  
> Finally, I'm attaching an error message which pops up when the 
> programming crashes.

Can you confirm whether this crash happens only in our debugger or
also when run outside of Wing?

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list