[wingide-users] Upgrading 3.0 disables Plone/Zope debugger

Ei Fujioka efujioka at duke.edu
Tue Oct 2 15:23:00 MDT 2007


Hello again.

Well, I've found another problem.
I can have the debugger connect to WingIDE only once.

When I stop the debugger by hitting "Stop" in WingDebugService in ZMI 
and click "Start" again, I always get the following page.

"Could not connect to Wing IDE"

This page lists up possible causes but non of them gives me a clue.
When I can connect first time, why not on the second attempt?
Only way to work around is to restart zope. So it's quite inconvenient.

Has anyone experienced the same problem?
Any solution for this?

Thanks,

Ei


Ei Fujioka wrote:
> Thank you for your super quick reply.
> 
> Yes, 'Remove' has solved the problem.
> 
> Only thing that doesn't work as expected is that the IDE status doesn't 
> change to "Connected" although I can debug. I need to refresh the page.
> 
> Well, if this is a tiny bug, I don't care much...
> 
> Thank you so much. You saved my time.
> 
> Ei
> 
> Encolpe Degoute wrote:
>> Hello,
>> to make it simple:
>> Go to Zope Control Panel and click on 'Wing Debug Service' then in 
>> 'Remove'.
>> Click on 'Are you sure?' then on 'Remove'.
>> And restart Zope.
>>
>> One other way, in 'Wing Debug Service' go in 'Configure' then fix the
>> Wing home dir to /usr/lib/wingide3.0
>>
>>
>> Ei Fujioka a écrit :
>>> Hello all,
>>>
>>> It seems upgrading 3.0 from 2.1 doesn't upgrade the Plone/Zope debugging
>>> feature and I got stuck.
>>> Could someone help me get things right?
>>>
>>> What I did are...
>>>
>>> First, Products/WingDBG wasn't upgraded so I manually deleted it and in
>>> WingIDE 3, went to Project-Properties then checked "Enable Zope2/Plone
>>> support". This seems to have installed new WingDBG as after restarting
>>> Zope, Control_Panel/WingDebugService in ZMI shows Wing Debugger Version
>>> 3.0.0.
>>>
>>> However, when I click [Start] in WingDebugService, "Debugger" status
>>> turns to "Started" but "IDE" says "Not connected". Clicking [Connect]
>>> makes no difference.
>>>
>>> I looked into WingIDE's Preferences-Debugger-External/Remote but wan't
>>> sure how to configure it.
>>> It says...
>>> Allowed Hosts: 127.0.0.1
>>> Server port: 50005
>>> Location Map: 127.0.0.1  Same as localhost
>>> Common Attach Hosts: 127.0.0.1 50015
>>> # the same configuration as WingIDE 2.1
>>>
>>> The debugging feature worked fine with WingIDE 2.1.
>>> WingIDE 3.0 got installed without deleting 2.1 (not asked about this).
>>> I use Plone 2.5 on the same Windows 2000 box.
>>> It seems the debugger is launched at port 50080 on Plone but can't
>>> access from browser (is it because the debugger is not connected to 
>>> IDE?).
>>>
>>>
>>> Is there something else I need to do to upgrade the debugger?
>>>
>>> Thanks,
>>>
>>> Ei
>>>
>>
>>
> 

-- 
======================
   Ei Fujioka
   Research Associate
   Duke University

   (919) 613-8021
   efujioka at duke.edu
======================



More information about the wingide-users mailing list