[wingide-users] AttributeError being squashed?

Chris Curvey ccurvey at gmail.com
Wed May 2 07:02:41 MDT 2007


Hey all,

I'm wondering if I did something wrong with my Wing configuration.

In a few places, I have code that looks like this:

sql = "select * from foo where id = %(id)s" % (self)

I've noticed that if I misspell "id" (the part within parentheses), I get an
AttributeError when I run the script from the command line.  But when I run
it via debug in Wing, the statement gets treated as the last statement in
the function.

Did I click something that's causing that exception to be ignored by Wing?
If so, how can I clear that?

-Chris

P.S.  The class containing this code does have a __getattribute__ method.
Not sure if that's important, or a red herring.

-- 
I am often wrong, but I am never in doubt.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20070502/b042e110/attachment.html


More information about the wingide-users mailing list