[wingide-users] Debugging stopped working

Wingware Support support at wingware.com
Tue Mar 27 08:45:58 MDT 2007


Morten Lied Johansen wrote:
> 
> I installed the latest two patches yesterday, and today I can't execute 
> or debug my project from inside Wing. At the same time, there is no 
> interactive shell.
> 
> In the Python Shell I get "Cannot execute: waiting for shell to 
> restart", and nothing happens. If I try the "Restart shell" option, 
> nothing happens for a few seconds, and then I get:
> 
> Debugger: Connection Failed::The debug process never connected back to 
> Wing IDE:  Aborting debug session
> 
>         See Trouble-shooting Failure to Debug in the users manual.
> 
> I haven't really used Wing the last couple days, so I can't say for sure 
> that this is something introduced with the patches yesterday, but I'm 
> fairly sure I haven't changed anything else in my setup, and it worked 
> last time I needed it.
> 
> Running on Windows XP with python 2.4.
> 
> Any ideas?

We've seen this more and more frequently caused by inability to write
files to the user settings directory (location varies; given 5th item
in the about box) or from failure to write to the temp directory
(sometimes because it is full, with >65K files).  I'm not sure why
this is becoming more common (a Windows update, some common add-on,
or...?).

If you send in a bug report from the help menu with the error log
included, that may provide us with more info to work with.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list