[wingide-users] import error ("no module named <bla>"), with Plone 2.1.1 on Mac OS X

Wingware Support support at wingware.com
Thu Feb 8 12:20:33 MST 2007


On Thu, 2007-02-08 at 10:23 -0600, T. Kim Nguyen wrote:
> In the Project Properties, I had tried to leave the Python Path to
> "use default", but then have since tried this custom value
> 
> 
> > /Applications/Plone2/Library/Software/Zope278/Zope/lib/python:/Applications/Plone2/Sites/Default:/Applications/Plone2/Sites/Default/Products
> 
> and several other variations of the same, but continue to get the
> import errors.

I suspect Zope2's path hackery is breaking down from your altering the
Python Path in Project Properties.  Can you remove that,
use /Applications/Plone2/Sites/Default as your ZOPEHOME
and see if that works?

If not, please send me the errors you're getting with that.  It may be
you need to edit /Applications/Plone2/Sites/Default/etc/zope.conf but I
don't have enough info about how you set things up to make specific
suggestions at this point.

-- 
Stephan Deibel

Wingware
Wing IDE for Python
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list