[wingide-users] Re: wingide-users Digest, Vol 44, Issue 2

Lawson English lenglish5 at cox.net
Mon Dec 3 18:26:09 MST 2007


that took care of it, thanks...

Even got it to work, once I could see that I was formatting my packet wrong.


Whee.. Now, only 565 more packets to document (not kidding).

Its part of an IBM-led project to document and eventually transform 
Second LIfe into an internet standard for 3D virtual worlds.


Its a scary mess at this point:


https://wiki.secondlife.com/wiki/Category:Messages

Lawson



wingide-users-request at wingware.com wrote:

Lawson English wrote:

> > Hi, I'm currently using the Wing IDE 101 and I've run into a strange 
> > problem.
> > 
> > I'm logging into a game server (Second Life) and trying to send UDP 
> > packets. I can do the login process just fine and retreive the 
> > appropriate info, but when I attempt to start communicating with the 
> > server using UDP, I get... nothing. Not eve debug print statements as 
> > output.
>   

Are your executing this in Wing's debugger or using the Evaluate File
in Shell command?  The latter probably won't work right since output
is not shown until the evaluated code completes and it will be sitting
in the 'while 1' loop.  Try debugging it instead.

This is a general problem in how the Python Shell (and Debug Probe
in Wing IDE Pro) work, which we'll try to fix soon (it's on our high
priority list).

If that's not it, please let us know.

Thanks,



More information about the wingide-users mailing list