[wingide-users] Python version

Wingware Support support at wingware.com
Tue Aug 21 07:16:48 MDT 2007


Timothy Reaves wrote:
>     With 3.0 on a Mac, how do I specify which version of Python I want 
> to run the IDE with?  10.5 defaults to 2.5, and I have 2.4 installed 
> because the developers of Zope refuse to live in the modern world.  
> Version 2.4 is what is found on the path (and is the Current 
> framework).  I'd like to use 2.5
> 
>     With Java, this is doen with a plist seting; I don't find one for 
> python in the Wing plist file.

It's done in Project Properties from the Project menu.  Set the
Python Executable to change from whatever default Wing is finding.

I'm not sure if you'll run into problems w/ Zope under Python 2.5.
You will if there are extension modules that you haven't recompiled.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list