[wingide-users] Python version

Martijn Pieters mj at zopatista.com
Tue Aug 21 02:28:28 MDT 2007


On 21. aug. 2007, at 07.44, Timothy Reaves wrote:
> 	With 3.0 on a Mac, how do I specify which version of Python I want  
> to run the IDE with?  10.5 defaults to 2.5, and I have 2.4  
> installed because the developers of Zope refuse to live in the  
> modern world.  Version 2.4 is what is found on the path (and is the  
> Current framework).  I'd like to use 2.5

You set the python interpreter on a per-project basis.

As for Zope and python 2.4: I am sure the Zope project would welcome  
your help in getting Zope to run on python 2.5! We especially would  
appreciate a security audit to see if the restricted mode (used in  
TALES expressions and Python Scripts) needs any work to be secure  
under python 2.5. A GSOC project is taking care of other aspects such  
as the C extensions, at least for Zope 3. :-)

Martijn Pieters


More information about the wingide-users mailing list