[wingide-users] WingIDE 3.0.0a1 crash in Mac OS X

Wingware Support support at wingware.com
Mon Apr 16 17:47:57 MDT 2007


Jaroslaw Zabiello wrote:
> 2007/4/15, Martijn Pieters <mj at zopatista.com>:
> 
>> > WingIDE 3.0.0a1 cannot be even started on my MacBook Pro. The
>> > following raport is generated by Mac OS X:
>>
>> There was a build error and a1 depends on MacPython 2.5 to be
>> installed; it depends on the Mac Framework provided by that release.
>> This was caused by a new build machine, apparently. A future build
>> will fix that.
>>
>> In the meantime, download MacPython from http://www.python.org/
>> download/mac/ and alpha1 will work just fine.
> 
> It does not work for me. I had MacPython 2.5. Now I changed to never 
> MacPython
> (http://www.python.org/download/releases/2.5.1/) but I have still the
> same problem  - WingIDE crashes. Both versions crash:
> wingide-2.1.4-2-i386.dmg and for wingide-3.0.0-a1-i386.dmg,

OK, then this is some other problem as 2.1.4 should not have
the bad dependency.

You may be able to start Wing by launching X11 first and then
running Contents/MacOS/wing inside the WingIDE.app folder
from an xterm opened from X11.  We've seen in a few cases that
the launcher fails to start Wing, for as-yet unknown reasons
when otherwise Wing does run if launched in this way.

If that fails, run it with the --verbose command line option
and send that or the contents of ~/.wingide3/error-log (or
~/.wingide2/error-log for Wing 2.1.4) to support at wingware.com.

Thanks,

-- 

Stephan Deibel
Wingware | Python IDE
Advancing Software Development

www.wingware.com



More information about the wingide-users mailing list