[wingide-users] Wing IDE 2.1 released

Wingware Support support at wingware.com
Mon Jun 19 16:00:26 EDT 2006


Hi,

We're pleased to announce the release of Wing IDE 2.1 for
Windows, Linux, and OS X.  This release can be downloaded
from:

   http://wingware.com/downloads

Highlights of Wing IDE 2.1 include:

* Visual Studio, VI/Vim, and Brief key bindings
* Subversion and Perforce support (+)
* Search in selection
* Easier to configure Tab key
* Auto-completion also for extension modules
* Improved auto-completion for wxPython and PyGTK
* Named bookmarks (+)
* Redesigned and improved search tools
* Breakpoint manager (+) and call stack as list
* Folding and breakpoint margins context menu (right click)
* Improved long string display for debugger
* Character, line, and block select modes
* Folding commands for top level classes/defs in Python code
* Syntax highlighting for additional languages
* Evaluate file or selection in Python Shell
* Print selection
* PDF formatted documentation
* Improved performance on Windows
* Support for Intel Macs
* Support for Python 2.5 alpha1
* Support for 64 bit Linux debugging
* Add New File feature for projects
* Automatic patch/update manager
* Improved black background display theme
* Maximize editor surface toggle (Shift-F2)
* Hundreds of bug fixes and minor improvements

(+) These are available in Wing IDE Pro only

Release notes:

* The OS X version is now distributed as disk images -- just drag
   and drop from the disk image to install
* Debugger status is now in the bottom left of the window and
   shows a popup menu when clicked on
* New Tab Key Action preference requires removing any keyboard
   binding override for 'tab'
* The black background display theme Aero has been removed and
   replaced with Black-Background, requiring reselecting from
   the Display Theme preference.

A complete list of changes is available here:

http://wingware.com/pub/wingide/2.1.0/CHANGELOG.txt

Version 2.1 is a free upgrade for Wing version 2.0 users; any
license for the 2.x series will work with both.  Version 2.1 can
co-exist with 2.0.  Although they share the same configuration
files, it is possible to switch back and forth between them on
the same system.

System requirements are Windows 2000 or later, OS X 10.3.9 or
later for PPC or Intel (requires X11 Server), or a recent Linux
system (either 32 or 64 bit).

Sincerely,

The Wingware Team


More information about the wingide-users mailing list