[wingide-users] 2.1b and 2.0 crash on Ubuntu Dapper

Wingware Support support at wingware.com
Mon Apr 3 20:02:51 EDT 2006


On Mon, 3 Apr 2006, Matt Feifarek wrote:
>> On 4/3/06, Matt Feifarek <matt.feifarek at gmail.com> wrote:
>> I did not setup Wing in any non-default way (I didn't configure it to use
>> system gtk, as far as I know). So, I doubt that I was using "the system-wide
>> GTK".
>
> I take it back; I had clicked the checkbox in preferences. I 
> suppose I did that way back when and didn't think of it as 
> "special".
> 
> What is the recommended thing to do?

Using Wing's private gtk is safer overall, except you'll need to 
use the fixed run-wing.sh I provided.

Our general intention is that Wing "just works" and the only way 
to do that safely is with a private GTK.  We've allowed users to 
run with the system GTK because it often works and matches Wing's 
look better to the system.  However, it can crash in ways that 
are hard for us to control.

Stephan Deibel

--
Wingware
Wing IDE for Python
Advancing Software Development

www.wingware.com


More information about the wingide-users mailing list