[wingide-users] Debugging cgi script on local machine

Peter Mott peter at monicol.co.uk
Sat Oct 22 14:22:17 EDT 2005


I'm on Windows XP SP2 running Apache on my local machine. I have Windows
Firewall installed and no doubt lots of other security things that I know
nothing about!  As far as I can I have ruled out that class of problems. 

 

wingdbg - 2005/10/22 16:33:01 - 'netserver CLOSECHANNEL' 

wingdbg - 2005/10/22 16:33:01 - 'Bound attach listener to port' 50015 

wingdbg - 2005/10/22 16:33:01 - '******************** START DEBUG
************************' 

wingdbg - 2005/10/22 16:33:01 - 'ABOUT TO INIT' 

wingdbg - 2005/10/22 16:33:01 - 'SET UP C CORE' 

wingdbg - 2005/10/22 16:33:01 - 'RESET' 

wingdbg - 2005/10/22 16:33:01 - 'setting __fClient to'
<netserver.CNetworkServer instance at 0x009BE328> 

wingdbg - 2005/10/22 16:33:02 - 'RESET' 

wingdbg - 2005/10/22 16:33:02 - 'Could not connect to debug client' 

wingdbg - 2005/10/22 16:33:03 - "Exception is: socket.error(10061,
'Connection refused')" 

wingdbg - 2005/10/22 16:33:03 - 'netserver CLOSECHANNEL' 

wingdbg - 2005/10/22 16:33:03 - 'Starting non-client run' 

wingdbg - 2005/10/22 16:33:03 - 'RESET' 

wingdbg - 2005/10/22 16:33:03 - '####### BASEDIR:
c:\\home\\anzi\\webs\\www.botoxdoc.co.uk\\htdocs\\cgi-bin\\testspec' 

wingdbg - 2005/10/22 16:33:03 - '__BlockUntilReadyToRun' 

wingdbg - 2005/10/22 16:33:03 - 'CHECK FOR CONNECTION' 

wingdbg - 2005/10/22 16:33:03 - 'LISTENER INFO:' ('0.0.0.0', 50015) 

wingdbg - 2005/10/22 16:33:03 - 'SELECT RESULT' [] [] [] 

wingdbg - 2005/10/22 16:33:03 - 'ProgramQuit called' 

wingdbg - 2005/10/22 16:33:03 - 'STOPPING DEBUG' 

wingdbg - 2005/10/22 16:33:03 - 'RESET' 

wingdbg - 2005/10/22 16:33:03 - 'setting __fClient to' None 

wingdbg - 2005/10/22 16:33:03 - 'RESET' 

wingdbg - 2005/10/22 16:33:03 - 'netserver CLOSECHANNEL' 

wingdbg - 2005/10/22 16:33:03 - 'Closing attach listener socket'

 

I can debug _sometimes_ for a little bit. But soon the above happens. Any
suggestions much appreciated. Perhaps a socket is not being closed properly?


 

Peter

-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/wingide-users/attachments/20051022/dbaa9033/attachment.htm


More information about the wingide-users mailing list